1 Reply Latest reply on May 17, 2016 11:49 AM by Intel Corporation

    How to disable snd-usb-audio?

    DufeRob

      Hello. I have a usb web camera Microsoft LifeCam Studio. This one has an audio problem with linux, but if I add the string "blacklist snd-usb-audio" into the blacklist.conf file then the problem with "frequency 0x82" is vanished. But AFAIK Edison kernel has builtin snd-usb-audio. Therefore it cannot be disabled by blacklist or rmmod command.

      Please help me to stop this module.

      Thanks in advance.

        • 1. Re: How to disable snd-usb-audio?
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi DufeRob,

          Did you test it with the Edison board or with another Linux PC? Given that snd-usb-audio is builtin in the Linux kernel you’ll need to deactivate from the kernel directly. I would suggest you to check chapter 5 of the Edison Board Support Package, http://download.intel.com/support/edison/sb/edisonbsp_ug_331188005.pdf, Customizing the Linux* Kernel. You’ll find a quick explanation on how to make modifications to the kernel. In summary, you’ll need to open the Linux kernel Configuration and search for the module to disable it. Make sure to save a copy of the default configuration in case you need to get back to the original file.

          Regards,
          Pablo