13 Replies Latest reply on Jul 14, 2016 5:04 PM by Intel Corporation

    NUC6i5SYH - drives doesn't appear under UEFI boot

    Hardzsi

      Hi,

       

      I recently bought my NUC after waiting a few month to see the infamous WHEA issue being finally solved by 0042 BIOS. Yes, i follow this forum since February or so...

       

      My NUC is a fresh product: produced in April (-503) and already uploaded with 0042 BIOS - however there were no blue dot stickers indicating that. 

       

      Hardware:

      Kingston HyperX Impact 16GB DDR4

      Samsung SSD 850 EVO 250GB

      Samsung SpinPoint 1TB HDD

       

      My problem is, both these drives appear under legacy boot in the BIOS and not under UEFI boot.

       

      WP_20160513_06_59_14_Pro.jpg WP_20160513_07_00_14_Pro.jpg

       

      Do you have any idea, why is that? Is there something i can set in the BIOS to solve it?

       

      Actually, I could easily install Windows 10 Home x64 (original Windows USB pendrive) to the SSD without any problem, but it just disturbs me, that i'm forced to use some outdated BIOS boot loader instead of the GPT offered by UEFI.

       

       

      Thanks,

      Hardzsi

        • 1. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
          N.Scott.Pearson

          Just ignore this. Disable Legacy so that UEFI must be used and then insert your media to install Windows. You will see the drives show up under UEFI once they have been loaded with GPT...

           

          ...S

          • 2. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
            Hardzsi

            Dear Scott,

             

            Thanks, that was the first i've tried, after reading this discussion with someone who had similar problem:

            intel nuc d54250wyk, uefi boot cannot see msata ssd? - AnandTech Forums

             

            Unfortunately, that solution did NOT work for me: if i disabled Legacy Boot, it hangs during the booting process: display something like "i cannot found any boot device" and stop there. With Legacy Boot disabled, i also tried manually choosing the boot device (pendrive with Win10) by pressing F10, but then it only listed the LAN booting as an option, so neither SDD and HDD nor USB key were listed.

             

             

            Regards,

            Ferenc

            • 3. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
              N.Scott.Pearson

              Ok, your installation media is Legacy-only and you will have to enable Legacy Boot in order use it. If should still install ok, however; boot from it and go on with installation. Remember that you  only care about it showing up in the boot order list once you have the O/S on it...

              • 4. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                Intel Corporation
                This message was posted by Intel Corporation on behalf of

                Hi,
                 
                Requirements for installing Windows in UEFI mode:

                • UEFI must be enabled in the BIOS
                • A DVD/CD-ROM drive (bootable USB flash drives with the OS may work, but as official practice always use the original Windows media)
                • A genuine copy of Windows supporting UEFI in 64-bit (Windows® 7, Windows® 8, Windows 8.1, Windows 10 etc).
                 
                If you don’t see a drive with UEFI in the boot manager there only three possible reasons for that:
                • UEFI is not enabled
                • The copy of Windows is not genuine or it is 32-bit
                • The media used is not supported (for some USB bootable drives)
                 
                The steps to install the operating system in UEFI mode should be simple:
                • Enter the board BIOS and enabled “UEFI Boot” and make sure “Legacy boot” is also enabled.
                • Save changes by pressing F10 on your keyboard and exit bios.
                • Booting up the board into the default “Boot manager” by pressing the “F10” key.
                • From the drives listed pick the one with the DVD/CD-ROM/Flash driver description that starts with UEFI.
                • Follow the Windows setup and then select the HDD you want to use for the installation.
                 
                 
                Best wishes,
                 
                 
                Ivan
                • 5. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                  Hardzsi

                  Dear Scott and Ivan,

                   

                  Thank both of You for the extra info and tips!

                   

                  Unfortunatelly, I could not find the source of this problem so far:

                  - "UEFI Boot" and "Legacy Boot" are both enabled (checked), as you can see here - although i'm not sure if there's another place in BIOS where UEFI can/should be enabled:

                  BIOS.Boot.Priority.jpg

                  - When booting up with "Boot manager" (pressing F10), You can see (bottom right), that the same drives appear in the list, but none of them starts with UEFI, so i can only boot legacy way

                  - My Windows 10 is genuine (a USB-key version) and contains both Home and Pro x64 and x32 versions, however, the licence key is for the x64 Home version only, therefore i installed that:

                  Win10.package.jpg

                  - I also checked the content of the genuine Windows pendrive, but it seems to me that it contains the necessary *.EFI files for UEFI booting - although i didn't check, which file system it was formatted to:

                  Win10.pendrive.content.jpg

                   

                  I tried to plug the Windows 10 pendrive into 3 different USB slots on NUC out of 4 and entered BIOS to check Boot pirority screen for each, but it always appeared as on the upper screenshot.

                   

                  As a last hope, i also upgraded BIOS from 0042 to 0044 using F7 method, loading defaults (F9) before and after the upgrade (first screenshot is from 0044), but unfortunately there were no change in finding my UEFI-enabled devices...

                   

                  Have you got any idea, how i could solve this problem?

                  • 6. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                    N.Scott.Pearson

                    All you can do is proceed to boot from the USB installation key and install Windows 10 onto your SSD...

                    • 7. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                      Intel Corporation
                      This message was posted by Intel Corporation on behalf of

                      Try changing the SATA devices from AHCI mode to RAID mode if that option is available on this unit, and then press F10 to save it and restart.
                       
                      Do you know if this drive was used before or it was installed in another system?
                       
                      If the HDD has been used before and is initialized as MBR, it might not be detected properly in UEFI.
                       
                      You could try formatting the hard drive.
                       
                      Regards,
                       
                      Ivan
                       

                      • 8. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                        Paulussie

                        Hi,

                         

                        I remember running into the same problem and as I recall the problem was that the USB stick I made via MS was MBR formatted. As I recall I tried the  stick for speed but went back to using the CD when I ran into this.

                         

                        If you want to install UEFI you need a boot device that uses GPT and not MBR. here is some more info about that.

                         

                        Kind regards,

                         

                        Paul

                        • 9. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                          Intel Corporation
                          This message was posted by Intel Corporation on behalf of

                          Thank you Paulussie for that valuable information you have kindly provided.
                           
                          Best wishes,
                           
                          Ivan
                           

                          • 10. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                            nucnuc6i3

                            I ran into exactly the same situation, can't get the official win 10 usb stick to boot in UEFI mode. Booting it in legacy mode, I end up with a win10 installation in legacy mode. If someone knows of a way around that, with the original stick, please inform us. Until then, if ever, this is how I solved the problem (thanks to Paulussie's comment):

                             

                            1. Made an iso-image to disk of the original MS usb stick with cdburnerxp.

                            CDBurnerXP: Free CD and DVD burning software

                            2. Wrote the image to another 16GB usb stick with Rufus (GPT partition scheme for UEFI/FAT32)

                            Rufus - Create bootable USB drives the easy way

                            3. Disabled legacy boot in the NUC bios, booted the new stick, removed the old partitions (legacy) during installation, creating new ones (UEFI setup automatically).

                            4. Now I have an UEFI win10. Used Rufus to create an Ubuntu 16.04 UEFI stick from the downloaded iso-file also. Great.

                            • 11. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                              Hardzsi

                              Thanks, since i bumped into this problem and search for it, i became aware quickly on how to prepare an UEFI-capable Win10 USB-stick.

                               

                              The problem is, that

                              a) I just can't believe, that the original, official USB-stick prepared by Microsoft was made NOT to be UEFI-aware. It's just ridiculous... I could buy only a Win10 licence way more cheaper and would prepare my own install media with Rufus as it's deatailed above (and in lots of forums), but i intentionally bought an official boot media thinking that such is prepared professionally and i can avoid hacking an install media myself. As it seems, I was wrong...

                               

                              b) I spent a few days customizing my Win10 insallation and i've been using this system since 2 months without any problems. It's fast and i'm satisifed with it. At this point, moving to UEFI by reformatting the SSD drive and investing another day to install the OS, all my needed software tools and to re-customize the OS again would be just too much of an investement for my part, so i won't do that, thanks. Indeed, GPT would offer more succesful recovering from any system crashes, but i had so far no freezing or crashes, so i can live with my current legacy fle system...

                              • 12. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                                N.Scott.Pearson

                                This is a moot (and almost silly) discussion. Switching from Legacy to UEFI is not going to speed anything up. Recovery capabilities are on par between the two disk formats.

                                • 13. Re: NUC6i5SYH - drives doesn't appear under UEFI boot
                                  Intel Corporation
                                  This message was posted by Intel Corporation on behalf of

                                  Hello Hardzsi:
                                   
                                  We are glad to hear that finally you were able to find a way to make the work properly.
                                   
                                  If you need further assistance do not hesitate in contact us again.
                                   
                                  Any questions, please let me know.
                                   
                                  Alberto