3 Replies Latest reply on May 10, 2016 9:51 AM by Intel Corporation

    Purple screen in my NUC6i3SYH with Ubuntu 16.04

    Tocinillo

      Hi everyone!

       

      Recently I installed Ubuntu 16.04 in my NUC6i3SYH. Everything is working but when I boot to Ubuntu a purple background and the display sleeps a few seconds before the plymouth. I tried everything (I added "nomodeset", "acpi=off", etc. a lot of combinations in /etc/default/grub) with no luck. The f$&/$/ screen always appears.

       

      I reinstalled the OS with same result.

       

      PS: With Ubuntu 14.04 everything works like a charm...

        • 1. Re: Purple screen in my NUC6i3SYH with Ubuntu 16.04
          hegenious

          I ran into all kinds of problems trying ubuntu 16.04.

          I think it's to new. Intel hasn't released drivers for it yet. When I run the Intel-Linux driver installer on 16.04 (or 16.04 derivatives, for that matter) it throws an error about unsupported OS. The latest ubuntu that Intel supports is 15.10, there's nothing there yet for 16.04 on Intel Graphics Installer for Linux* 1.4.0 | 01.org

           

          On the other hand it might as well be that your splash image used during boot is missing and ubuntu hangs for a while searching for it.

          Try pressing ESCAPE as soon as the purple screen appears. If you then can see the boot messages rolling over your screen, the splash is missing.

          You should check your syslog, X11 log; and run dmesg for boot messages.

           

          Cheers,

          Heg

          • 2. Re: Purple screen in my NUC6i3SYH with Ubuntu 16.04
            Tocinillo

            Hi!

             

            Thanks for the quick reply. I think is driver related also. It's not about plymouth (I applied my own custom and shows correctly but after the "purple screen").

             

            I have the same problem that this guy: Booting Ubuntu: Temporarily stuck on a purple screen - Page 2 - Linux & Unix

            About the purple screen annoyance: the delay might be due to the system detecting/checking/loading hardware or other components (see mremski answer).

            You can check the logs (/var/log/) for errors.

            So If a check the boot problems with: journalctl -k | egrep "(error|fail|warn|ignore)"...this is the output:

             

             

            may 09 23:26:52 SalonDigital kernel: [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored

            may 09 23:26:52 SalonDigital kernel: sdhci-pci 0000:00:1e.6: failed to setup card detect gpio

            may 09 23:26:52 SalonDigital kernel: [drm] failed to retrieve link info, disabling eDP

            may 09 23:26:52 SalonDigital kernel: EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro

            may 09 23:26:52 SalonDigital kernel: iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-19.ucode failed with error -2

            may 09 23:26:52 SalonDigital kernel: iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-18.ucode failed with error -2

            may 09 23:26:52 SalonDigital kernel: iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-17.ucode failed with error -2

             

            It's very curious, because the in my custom Ubuntu 14.04 (openbox, up to kernel 4.4) I can't reproduce the "purple screen", so It's something related to systemd instead upstart (used in 14.04) and drivers...

            • 3. Re: Purple screen in my NUC6i3SYH with Ubuntu 16.04
              Intel Corporation
              This message was posted by Intel Corporation on behalf of

              Hi,
               
              Intel has not validated Ubuntu with this NUC; I suggest trying to get some support at the Ubuntu website here:
              http://www.ubuntu.com/
               
              The version reported as supported is the Linux* Mint, you can see Supported Operating Systems for Intel® NUC Products
               
               
              Regards,
               
              Ivan