5 Replies Latest reply on May 23, 2016 8:30 AM by Intel Corporation

    Using Intel HD 2000 Graphics to play Second Life no longer supported, Why?

    MarilynAngela

      Why isn't there anymore updates to the drivers so I can still run my game? I been playing this for 3 years and now it will no longer load saying "Firestorm is unable to run because your video card drivers did not install properly,are out of date or unsupported hardware." My driver is up to date and it shown on the list that it won't be updated. Is there anything that can be done about this? 

       

      Thanks, Marilyn