1 2 3 Previous Next 31 Replies Latest reply on Jun 29, 2016 6:31 PM by Intel Corporation

    Yocto Image build problem

    Bart_H

      Hi all,

       

      So I'm building a full yocto image for the Galileo Gen 2, because I want to run Csound on it and use it as a portable synth that accepts MIDI input.
      This has been done before, and I'm basing it off this paper: http://lac.linuxaudio.org/2015/papers/2.pdf


      I'm using the BSP and following the build guide. (Available here): Download Intel® Quark™ BSP
      So, up until step 6.1, everything is good, but then I get the following error:

       

      ERROR: Layer 'networking-layer' depends on layer 'meta-python', but this layer is not enabled in your configuration

       

      I've checked all my dependencies and I've tried adding "meta-python" folder to the local.conf file but that just throws up another error:

       

      ERROR: Layer 'meta-python' depends on layer 'openembedded-layer', but this layer is not enabled in your configuration



      I'm unsure if adding directories to the configuration file is the right approach but I can't take this any further

      since there is no "openembedded-layer" directory I can find.

       

      At this point I'm stuck, since without the full yocto install I don't have access to the ALSA libraries needed by CSound.
      So if someone could please tell me where I might be going wrong it would be very much appreciated!

       

      Bart

       

      Edit: I'm running Ubuntu 14.04

        • 1. Re: Yocto Image build problem
          Bart_H

          Any help with this available?
          I've been reading Yocto Project Board Support Package Developer's Guide, but It hasn't given any clues as to how to fix this.
          I'm new to the BSP so any advice would be helpful.

          • 2. Re: Yocto Image build problem
            PaulaK

            hello Bart_H,

             

            Did you added the meta-python layer to conf/bblayers.conf? Because all the references for meta directories are listed there.

            And in what distro are you building this image?

             

            Regards,

            Paula

            • 3. Re: Yocto Image build problem
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Bart_H,

              1. Are you building the default image or are modifying something from the default build?
              2. Have you already tried using meta-openembedded? Remember to add it to the conf/bblayers.conf as Paula mentioned.
              3. Do you know which particular ALSA packages you need? I’m asking this because some of these packages comes with the eglibc image and you might just use this image without the need of building it from scratch. See the packages installed below:

              root@galileojdk:~# opkg list-installed | grep alsa
              alsa-conf - 1.0.28-r0.0
              alsa-conf-base - 1.0.28-r0.0
              alsa-lib - 1.0.28-r0.0
              alsa-lib-dev - 1.0.28-r0.0
              alsa-state - 0.2.0-r5.0
              alsa-state-dev - 0.2.0-r5.0
              alsa-states - 0.2.0-r5.0
              alsa-utils - 1.0.28-r0.0
              alsa-utils-aconnect - 1.0.28-r0.0
              alsa-utils-alsactl - 1.0.28-r0.0
              alsa-utils-alsaloop - 1.0.28-r0.0
              alsa-utils-alsamixer - 1.0.28-r0.0
              alsa-utils-alsaucm - 1.0.28-r0.0
              alsa-utils-amixer - 1.0.28-r0.0
              alsa-utils-aplay - 1.0.28-r0.0
              alsa-utils-aseqdump - 1.0.28-r0.0
              alsa-utils-aseqnet - 1.0.28-r0.0
              alsa-utils-dev - 1.0.28-r0.0
              alsa-utils-iecset - 1.0.28-r0.0
              alsa-utils-midi - 1.0.28-r0.0
              alsa-utils-speakertest - 1.0.28-r0.0

              Additionally, you can get the eglibc image from the following site

               

              Regards,
              Juan

              • 4. Re: Yocto Image build problem
                Bart_H

                Hi,

                 

                Thanks for the response!

                 

                 

                PaulaK
                Yes, I added the meta-python layer to conf/bblayers.conf. In my original post I mistakenly said I added it to local.conf.
                (Both local.conf and bblayers.conf are in the same directory, hence the mix-up)

                 

                 

                At that point I get the second error I describe in my original post.

                I am using Ubuntu 14.04 LTS

                 

                 

                IntelCorporation
                1 - For now I am building the default image.
                I will want to modify the build after I do a default image trial run and setup the cross-compile toolchain.

                 

                 

                2 - I have not tried using meta-openembedded. I was under the impression that it was included in the BSP/updated via the svn?
                There are meta-openembedded folders within the BSP and svn repo, but beyond that I'm unsure what I should be doing with meta-openembedded.

                 

                 

                3 - I don't know what ALSA packages I will need but I would like to access all of them.
                I definitely want an eglibc image for my purposes. However the default eglibc image won't suffice because I want to customise several parts of it.
                For example, I would like to modify the libsndfile in meta/recipes-multimedia/libsndfile/libsndfile1.x.x.bb.

                 

                Regards,
                Bart

                • 5. Re: Yocto Image build problem
                  xbolshe

                  Hi,

                   

                  it seems commands like shown below were not executed before ./setup.sh:

                   

                  $ git config --global user.name "user"
                  $ git config --global user.email "user@mail.local"
                  
                  
                  
                  

                   

                  I guess need to delete all files, execute these commands, do a building procedure again.

                   

                  Another possible solution is to install missed packages like:

                   

                  sudo apt-get install gcc make patchutils
                  
                  
                  

                   

                  Last command shall be executed before ./setup.sh

                   

                  BR,

                  xbolshe

                  • 6. Re: Yocto Image build problem
                    PaulaK

                    Hi there,

                     

                    I think this error is thrown in recent Ubuntu versions (14.x and 15.x), I remember I had this issue while trying to bitbake from an Ubuntu machine. I`ve cloned the meta-python layer and tried to bitbake again. I don`t know if this is recommended.

                    BSP 1.2.1 build guide said it was tested on a Debian wheezy, I think in the future they could include other popular distros as Ubuntu.

                     

                    Best 

                    • 7. Re: Yocto Image build problem
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Hi

                       

                      I’m using Ubuntu 14.04 and I’m able to build a default image with the following commands:
                      cd edison-src
                      git config --global user.name “myusername”
                      git config --global user.email “myemail”
                      mkdir ss dl
                      ./meta-intel-edison/setup.sh --dl_dir=/PathToEdison-Src/edison-src/dl --sstate_dir=/PathToEdison-Src/ss --build_dir=/PathToEdison-Src/edison-src
                      source poky/oe-init-build-env
                      bitbake edison-image

                       

                      Are you using these commands to build the default image with the ww25.5-15 source files? If you are not able to build a image with these commands please let us know and attach the complete error log in a file so we could check and see what we are missing in your image.

                       

                      Regards,
                      Carlos

                      • 8. Re: Yocto Image build problem
                        Bart_H

                        Hi,

                         

                        I fresh installed Ubuntu 14.04 and included the step recommended by xbolshe:

                         

                        git config --global user.name "user" 

                        git config --global user.email "user@mail.local" 

                         

                        I'm unfamiliar with git, so I just entered them verbatim as above. I assume "user" doesn't have to be replaced with another username?
                        The good news is that the meta-python error no longer occurs, however I'm not getting the error shown below:Untitled.png

                         

                        Does anyone have any advice what the next step might be?

                         

                        Thanks,
                        Bart

                        • 9. Re: Yocto Image build problem
                          Bart_H

                          It seems that the solutions here maybe have helped:

                          problem with bitbake build process in release 2.1 BSP User's Guide

                           

                          I ran "sudo apt-get install libsdl1.2-dev" and the full image is now building.
                          I'll report whether it is successful.

                           

                          Bart

                          • 10. Re: Yocto Image build problem
                            Intel Corporation
                            This message was posted on behalf of Intel Corporation

                            Hi Bart_H,

                            In fact, you should enter your own GitHub credentials, so I would suggest to create an account (in case you don’t have one) and use that specific username and email. That might be the reason of the new error that you’re getting.
                            If you have already tried with the process in the other thread, please let us know how it went and if it solved the issue.

                            Regards,
                            Pablo

                            • 11. Re: Yocto Image build problem
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              Hi Bart_H,

                               

                              Do you have updates on this case? Did you get different results using your own credentials to complete the process?

                               

                              Regards,
                              Pablo

                              • 12. Re: Yocto Image build problem
                                Bart_H

                                Hi Pablo,

                                 

                                I was able to finish the build. I have yet to verify if it is successful, but I think it might be (SD LED blinks on boot, it is recognized as a device via USB connection).

                                 

                                I am now trying to figure out how to connect via ssh to the Galileo while running the image I built.

                                I read that LAN isn't enabled by default on the Galileo? My understanding is that on the default uClibc image, the LAN is enabled via arduino IDE sketch.
                                Since the arduino IDE normally depends on uClibc, however I'm running an eglibc image, so this won't work (I have tried).

                                 

                                One thing to be aware of - the image files you must save to your SD card don't exactly match the ones listed in the grub.conf file.
                                For example, the "bzImage.bin" file is by default just called "bzImage" (missing the file extension) in the grub.conf file.

                                Although it's a trivial edit, without it, the yocto image won't boot on the Galileo.

                                 

                                Regards, Bartley

                                • 13. Re: Yocto Image build problem
                                  Intel Corporation
                                  This message was posted on behalf of Intel Corporation

                                  Hi Bart_H,

                                  With the board connected, do you get any message in the Serial console when you connect the Ethernet cable? You should get a message indicating that a LAN connection has been enabled. Now, for the uClibc image, which is the small/standard image for the Galileo board, the network will be up automatically (you could even use the ping command to test it). For the eglibc image, the larger image for the Galileo, you’ll have to bring the network interface up. You’ll need to use the ifup and ifdown Linux commands if you want to enable or disable the network interface.

                                  Regards,
                                  Pablo

                                  • 14. Re: Yocto Image build problem
                                    Bart_H

                                    The network connection seems to be up, however I can't SSH to the board.

                                    I'm not going through a router, and then I try to SSH to the board via ethernet and this is what I'm seeing:

                                    Screenshot from 2016-05-21 02_05_02.png

                                     

                                    I've checked the /etc/ssh/sshd_config file and the port is 22. In short I don't know what I'm doing wrong.
                                    I've been looking up guides but so far no progress. Any advice appreciated.

                                    1 2 3 Previous Next