4 Replies Latest reply on May 4, 2016 10:53 AM by Intel Corporation

    Chipset driver not updating

    Richard800XL

      Hi there,

       

      I am trying to update my processor chipset using the Intel Driver Update Utility (version 2.4.0.15) but it doesn't appear to be updating. I am running Windows 10 Home edition 64-bit (which is up to date), the motherboard I have is an ASRock B75 Pro3-M (the BIOS is the latest version) and the processor is an Intel Core i7-3770 CPU @ 3.40GHZ and the installed chipset device software is 10.0.10586.0. When I scan using the utility it tells me the latest version is 10.1.1.14 so I download and install it and then the utility informs me that it has been successfully installed and that I must restart my computer for the changes to take effect. When I run the scan utility again after the restart it tells me that the installed version is 10.0.10586.0 which is the original version. Device Manager tells me that the best driver software for my device is already installed and if this is the case then fair enough but I'm just wondering why the Driver Update Utility tells me that 10.1.1.14 is the latest version. Any help or advice would be most welcome.

       

      Thanks in advance,

       

      Richard

        • 1. Re: Chipset driver not updating
          Pyromanical

          I have the exact same problem, and have had it ever since the first time I tried to update my drivers.

          My driver is currently 7.0.0.1144 (clearly you can see how long it hasn't let me update it), and whenever I download and install it I get a message saying that it's been successful. After restarting and scanning again, it still says that the version is 7.0.0.1144- no matter how many times I try (regardless of doing it manually or not), it doesn't let me update it.

           

          I've tried atleast 20 times in the past year and have went through multiple forum posts about it but none have helped me with this problem...

          • 2. Re: Chipset driver not updating
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            If you are unable to update to the latest chipset driver is because your current operating system already have the latest INF supported for your chipset type. 

            The latest INF will work if you do a fresh operating system installation, at this point, your computer is covered with the latest version supported.
             

            Alllan. 

            • 3. Re: Chipset driver not updating
              Richard800XL

              Thanks for your help Alllan, I have a little additional information that may be worthwhile sharing.

               

              Immediately prior to performing the update the Driver Update Utility allows you the opportunity to review the relevant Readme file. I noticed that point 3 in section 6 (Installing the Software in Silent Mode) reveals that you can check whether the update was successful by reviewing the Version value in the HKEY_LOCAL_MACHINE\Software\Intel\InfInst registry entry. I checked mine using the regedit command and it is set to 10.1.1.14 yet a subsequent scan using the Driver Update Utility and Device Manager indicate that the version to be 10.0.10586.0.

               

              Richard

              • 4. Re: Chipset driver not updating
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                So, you have the latest INF installed. That seems great. The registry entry is showing the latest version. 

                Allan.