4 Replies Latest reply on Sep 11, 2016 10:15 AM by B96mike

    (BIOS Recovery Problem) Problem while updating BIOS of Intel NUC5i7RYH

    Joymala

      Image.jpg

      My NUC was making loud noise (fan-noise probably) frequently, causing disturbance to my colleagues. After searching in the internet, I had initially tried to update the BIOS of my NUC5i7RYH using the EXE file RYBDWi35.86A.0355.EB.EXE available at Download BIOS Update [RYBDWi35.86A]

      That caused my system to reboot and show that BIOS update has failed. My NUC stopped booting to Windows-7 (64bit) from that point. It wouldn't even show the Intel's initial screen with F2, F7, F10 options. No output to my screen/HDMI-cable at all.


      Then I tried two things. At first, I tried the method suggested here: BIOS Recovery Update Instructions for Intel® NUC by opening the chassis and removing the yellow jumper.

      I tried with BIO files of version 0355 (the latest) and then version 0350 (the one that was present before BIOS-problem started). I could get Intel's initial screen, and also enter the Visual BIOS, but of no use.

      I am facing the problem shown in above screen - "Flash update failed!" while trying to recover BIOS using USB in ALL cases.


      The second thing I tried is to remove more screws, and then remove the battery beneath and keep it disconnected for a while. After putting back the battery, I get the same screen attached and it is still not booting after I place the jumper back.


      Is there any known issue with that EXE file? How can I bring my NUC back to normal? I will be thankful for your kind suggestions. Please help.