8 Replies Latest reply on Oct 28, 2010 4:58 AM by

    D510MO Issues

    sjr

      Last night I put together a small system using the new D510MO desktop board.  I ran into a couple of issues with which I could use some help, if anyone has similar experiences.

       

      Overall, I'm very pleased with this board.  This is a secondary machine that sits in the living room and mainly streams audio off the internet, with occasional light browsing thrown in.  The main goal was silence and not power, which was why I went with this board, and you practically have to put your ear on the case to hear the case fan.   It post'ed the first time, and except for the (relatively minor) issues above, so far -- knock on wood -- it looks good.

       

      --Booting from USB devices:  There are some odd anomalies here.  I didn't have a slim internal CD/DVD drive on hand, so wanted to install my OS from an external USB drive. I enabled USB boot in BIOS, and as far as I can tell the settings are correct.  However, the system stubbornly refuses to recognize my USB DVD/CD-ROM drive (drive should be "known good", as other computers will boot from it correctly).   Thinking that it might be an issue with the case (Silverstone SG06), I tried connecting the CD/DVD drive to the USB ports on the back of the machine, i.e. the ones hardwired into the motherboard.  No joy there either.  The drive powers up, so the ports aren't dead, but the machine just won't boot from it. I got the machine to boot from a thumb drive with Ubuntu Netbook Remix 9.04 on it, and installed that on the internal drive as a stopgap, but it's not an ideal OS for this (see below) -- oh, and the USB drive will only boot from one of the two front mounted ports.   Would welcome any thoughts on this -- I will eventually probably have to get a slim internal SATA CD/DVD drive, but in the meantime this is a bit of a pain.

       

      --The UNR that I used to boot was 9.04, and when I installed it to my internal hard drive (a Kingston SSDNow V 64GB) it went fine.  But when I updated it with the various patches and so forth (not a version upgrade, just the components of the OS) the machine gets to the desktop wallpaper and hangs.  I'll ask about this in the Ubuntu forums as well, but am curious if anyone else has encountered this.

       

      --Graphics issues:  The machine's connected to a smallish LCD, which displays the resolution independent of the computer.  When I get the splash screen, the LCD says it's running at 1280x800, but it drops back to 1024x768 maximum on the desktop.  I've read the thread elsewhere on this site about Intel integrated graphics refusing to run at native resolutions, but as far as I could tell the workarounds applied to Windows, which I'm trying to avoid using.  (I put that part of the budget into the case and SSD instead.)

       

      Thanks in advance for any input.

       

      --sjr

        • 1. Re: D510MO Issues
          jmlobdell

          I installed a dual boot using Ubuntu 9.10 amd64 and Win 7 Home Premium 64 bit  last night.  No installation problems at all.  I remember that 9.04 had issues with some graphics systems (including mine).  I just went back to 8.10 until 9.10 came out.  The system displays 1920x1200@60Hz on my computer monitor, a Dell Ultrasharp U2410 (the default resolution), but insists on displaying 1366x768 on my TV, a 42" LG LCD, which has a native resolution of 1920x1080.  According to the Intel product guide for the D510MO, it will support up to 2048x1536@75HZ (analog only).  According to the Intel technical product spec sheet, some D510MO's are optionally wired to support single channel LVDS @ 1366x768 (mine doesn't have this).  I think that the reason the display tops out at 720p on the LG is because it runs at a 120Hz refresh rate, rather than the more common 60Hz.  If I were you, I'd do a reinstall using 9.10, preferably from a SATA DVD drive temporarily hooked up to your second SATA port.  This would skirt any problems you're having trying to install from a USB DVD.

          Check to see which USB pinouts you hooked up to; the set next to the HD audio header will support 2 front USB ports, but the one labeled 6-12 on your quick start guide is for a USB flash drive; pins 2, 4, 6 and 8 are dead; only the "keyed" side is live (pins 1, 3, 5 and 7).

          I also am using a Silverstone case, a LaScala LC19.  I do have a slim Blu-Ray drive in mine and wish I didn't!

          Hope this has been of some help.

          jml

          • 2. Re: D510MO Issues
            sjr

            Jon, thanks, very helpful response.

             

            --The upgrade to 9.10 solved the video resolution issues nicely.  A little tweaking on the LCD's end and it's pretty much good to go now.

             

            -- Took a look at the mobo in my machine and confirmed the front panel connector is in the correct USB port.  I got it to boot successfully from the optical drive by using the external drive's AC adapter, so I'd guess that this had something to do with the voltage supplied by the board to the USB port. 

             

            Next step will be to swap out the case's stock fan for something a little quieter, and put in a picoPSU/power brick combo to replace the overkill stock PSU.  I'll keep the PSU around in case I wind up upgrading to a more powerful mini-ITX motherboard in the future.  The replacement PSU's cabling only has one SATA power connector attached to it, so I'll stick with the drive as the only storage in the case for the moment.

             

            While I'd like a little more modern selection of ports on the back of the motherboard (PS/2 and VGA in 2010, for real?) overall I thought this board is great.  The machine's already next to silent, and should be as close as I can get with the next couple of tweaks.  Oh -- and two thumbs up for the Silverstone case, which looks like a keeper.

            • 3. Re: D510MO Issues
              jmlobdell

              I've ordered a mini PCIe Broadcom Crystal decoder (BCM 970012), which might solve, in part, this motherboard's rather serious video shortcomings.  Of the other d510 mbs I've seen previewed, only Zotac's 2 models are fitted with an HDMI output.  My previous experience with Zotac has not been good and the mere presence of an HDMI output, which might or might not actually work, would not be enough to convince me to try another Zotac product.  Intel's board may have little in the way of bells and whistles, but it is hard to argue with the price (or the quality control).

              Have you tried using the SPDIF to output streaming audio?  If you have, I'd be interested in your opinion.  I'm getting excellent results linking the d510mo coaxially to my AV unit (an Arcam Solo Movie 5.1), but I'm only getting 2.1 sound.

              I wonder if you really need a fan at all.  I have the version of the LaScala that has room for 2 hard drives, but doesn't have a memory card reader.  This version of the case has no case fan at all.  Even after being on all day, the heatsink on the d510mo hardly warms up!

              I agree the LC19 is a "keeper," but no thanks to SilverStone.  The quality control is terrible; several parts were lying loose in the case and the bracket that holds the DVD drive and HDD had been "racked' during manufacture so that the Blu-Ray player sat slightly cockeyed in the chassis, preventing it from opening and closing.  A local fab shop fixed the problem for me.  Expect little help from SilverStone, btw.  SilverStone product support is the computer chassis equivalent of Allstate.

              • 4. Re: D510MO Issues
                Tolu

                Hi Jon,

                 

                can you explain how to connect a cinch jack to the onboard S/PDIF connector? Did you just solder the cable to the pins or did you use some additional resistors or a third-party-connector?

                 

                Regards

                Tolu

                • 5. Re: D510MO Issues
                  jmlobdell

                  I used a Gigabyte SPDIF-OUT connector cable - S/N: 12CR1-1SPOUT-03R, which provides both a TOSLINK and a coaxial connection.  If you get one of these, be sure it's an output not an input.  The input connector can be easily identified - the area around the TOSLINK connector is painted red.  The relevant accessory page can be found on Gigabyte's website:   http://www.gigabyte.com.tw/Products/Motherboard/Accessory/List.aspx

                  These connectors are hard to find.  Check Amazon.com and e-Bay; Gigabyte probably won't sell you just one.  eg.:  http://cgi.ebay.com/Intel-Motherboard-S-PDIF-Out-Audio-Cable-Bracket-HTPC-/160356880482

                  BTW, the SPDIF connector will deliver 5.1 audio content from an appropriate source.  I have a 5.1 receiver and speaker system, so I don't know if the digital audio output is capable of 7.1 or not.  Sure wish this thing had an HDMI output!

                  Jon Lobdell

                  • 6. Re: D510MO Issues
                    zylko

                    Jon Lobdell,

                     

                    Does the BCM 970012 has solved your video decoding issues? Have you test that card with some kind of DLNA server? I’m wondering how it will support the D510MO in multistreaming with on-fly re-coding (decoding – encoding) from one video format to another (esp. to H.264) in res. around 2CIF or PAL.

                    • 7. Re: D510MO Issues
                      jmlobdell

                      The answer to your first question is a qualified "yes".  The installation of the Broadcom chip enabled glitch-free 1900x1080 video streaming from any source using Adobe's flash player, as long as the most recent version is installed.  1920x1080 playback of BluRay discs is also fine using appropriate decoding software (in my case CyberLink Power DVD 10).  However, I have not been able to get the D510MO to reliably record or play back HD TV content from over-the-air broadcasts.  I have a copy of Nero MediaHome 4, but have not used it, so the answer to your 2nd question is "no".  AT&T recently extended U-Verse coverage to our area.  Ma Bell's set-top box allows up to 4 programs to be played/recorded at once.  I've also acquired an Oppo BluRay player, which handles BluRay discs, DVDs and CDs quite well and, along with the AT&T U-Verse box, renders the D510MO pretty much redundant.  Right now, it's been relegated to playing DVD discs for my grandchildren when they are visiting and streaming Shoutcast audio when they are not.  I cannot answer your question about transcoding.  I've never attempted it.  Sorry I can't be of more help.

                      jml

                      • 8. Re: D510MO Issues

                        Yes, I can confirm! I have problems with D510MO and some different USB DVD-drive. Some timesmother board does not start at all (does not power ONex: D510MO+ AgeStar model FUBCP+SONYAD-7240 dvd-rom)

                        It work but POST takes too much time With USB DVD by NEC and SerialATA-to-USB box

                        OS installation simetimes timeout with NEC and SUB3A.

                        If I attach AgeStar SUB3A PC boots very slowly (PC does not respond any key pressed Num Lock Caps not blinking), if I dettach it while booting it starts in seconds (but without USB DVD-ROM).

                        It does not care that USB port is used to attach the USB DVD-ROM.

                        Bios - the last one 8/3/2010 ver. 0311