1 Reply Latest reply on Apr 26, 2016 3:29 PM by Intel Corporation

    modprobe probem:unknown symbol

    mengyize

      Hello guys:
           I add a `udlfb` module into the edison-yocto image,  according to the Kconfig:

      config FB_UDL

          tristate "Displaylink USB Framebuffer support"

          depends on FB && USB

          select FB_MODE_HELPERS

          select FB_SYS_FILLRECT

          select FB_SYS_COPYAREA

          select FB_SYS_IMAGEBLIT

          select FB_SYS_FOPS

          select FB_DEFERRED_IO

          ---help---

            This is a kernel framebuffer driver for DisplayLink USB devices.

            Supports fbdev clients like xf86-video-fbdev, kdrive, fbi, and

            mplayer -vo fbdev. Supports all USB 2.0 era DisplayLink devices.

            To compile as a module, choose M here: the module name is udlfb.

       

      But when I run `modprobe` on the edison board, it gives me :

      support2.png

      I run

      ./udlfb.ko | grep depend

      and it shows me that the module depends on fb_sys_fops,sysfillrect,syscopyarea,sysimgblt, and I have already run 'modprobe' one by one. What should I do ?