1 Reply Latest reply on Jan 17, 2017 4:11 AM by pbasov

    Intel X710 for 10GbE SFP+ drops all packets

    AlexeyDyadin

      Server platform:

      Intel(R) Xeon(R) CPU E5-2680 v3 @ 2.50GHz x 2

      64GB RAM

      3.10.0-123.el7.x86_64 kernel, CentOS 7

       

      Intel X710 card (4x10Gbps) drops all ingress packets. ethtool port rx_dropped counter increases, ifconfig shows there are no any packets available for this port.

       

      ifconfig eth28

      eth28: flags=4547<UP,BROADCAST,RUNNING,NOARP,PROMISC,MULTICAST>  mtu 9000

              inet6 fe80::290:bff:fe45:f72f  prefixlen 64  scopeid 0x20<link>

              ether 00:90:0b:45:f7:2f  txqueuelen 1000  (Ethernet)

              RX packets 0  bytes 0 (0.0 B)

              RX errors 0  dropped 0  overruns 0  frame 0

              TX packets 0  bytes 0 (0.0 B)

              TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

       

      ethtool -S eth28

           port.rx_bytes: 2954509409188

           port.tx_bytes: 0

           port.rx_unicast: 8366695797

           port.tx_unicast: 0

           port.rx_multicast: 247430

           port.tx_multicast: 0

           port.rx_broadcast: 3968

           port.tx_broadcast: 0

           port.tx_errors: 0

           port.rx_dropped: 4071979899

           port.tx_dropped_link_down: 0

           port.rx_crc_errors: 0

           port.illegal_bytes: 0

           port.mac_local_faults: 0

           port.mac_remote_faults: 0

           port.tx_timeout: 0

           port.rx_csum_bad: 0

           port.rx_length_errors: 0

           port.link_xon_rx: 0

           port.link_xoff_rx: 0

           port.link_xon_tx: 0

           port.link_xoff_tx: 0

           port.rx_size_64: 5125057

           port.rx_size_127: 481023287

           port.rx_size_255: 145733686

           port.rx_size_511: 7678405724

           port.rx_size_1023: 11564810

           port.rx_size_1522: 45094628

       

           rx-*.rx_bytes: 0

           rx-*.rx_packets: 0

       

       

      latest firmware and drivers installed

      ethtool -i eth28

           driver: i40e

           version: 1.4.25

           firmware-version: 5.02 0x80002249 0.0.0

           bus-info: 0000:84:00.1

           supports-statistics: yes

           supports-test: yes

           supports-eeprom-access: yes

           supports-register-dump: yes

           supports-priv-flags: yes

       

      Also tried to disable rx-offload features (with no effect):

      ethtool -k eth28

      Features for eth28:

      rx-checksumming: off

      tx-checksumming: off

              tx-checksum-ipv4: off

              tx-checksum-ip-generic: off [fixed]

              tx-checksum-ipv6: off

              tx-checksum-fcoe-crc: off [fixed]

              tx-checksum-sctp: off

      scatter-gather: off

              tx-scatter-gather: off

              tx-scatter-gather-fraglist: off [fixed]

      tcp-segmentation-offload: off

              tx-tcp-segmentation: off

              tx-tcp-ecn-segmentation: off

              tx-tcp6-segmentation: off

      udp-fragmentation-offload: off [fixed]

      generic-segmentation-offload: off

      generic-receive-offload: off

      large-receive-offload: off [fixed]

      rx-vlan-offload: off

      tx-vlan-offload: on

      ntuple-filters: off

      receive-hashing: on

      highdma: on

      rx-vlan-filter: off

      vlan-challenged: off [fixed]

      tx-lockless: off [fixed]

      netns-local: off [fixed]

      tx-gso-robust: off [fixed]

      tx-fcoe-segmentation: off [fixed]

      tx-gre-segmentation: on

      tx-ipip-segmentation: off [fixed]

      tx-sit-segmentation: off [fixed]

      tx-udp_tnl-segmentation: on

      tx-mpls-segmentation: off [fixed]

      fcoe-mtu: off [fixed]

      tx-nocache-copy: on

      loopback: off [fixed]

      rx-fcs: off [fixed]

      rx-all: off [fixed]

      tx-vlan-stag-hw-insert: off [fixed]

      rx-vlan-stag-hw-parse: off [fixed]

      rx-vlan-stag-filter: off [fixed]

       

      Have no idea what to do, need help.