3 Replies Latest reply on Apr 19, 2016 3:05 PM by Intel Corporation

    Unable to record with ALSA utils

    mr_crocodile556

      Hello,

       

      After recording my voice with the arecord command, i tried replaying it however no sound was heard.

      There was only a slight buzzing sound. I believe that my recording is playing however i do not know why it wasn't properly output.

       

      May i know what did i do wrong here?

       

      Following the steps of Motion detecting video streaming doorbell under "Configuration of USB soundcard",

      I am only able to play a test sound downloaded using aplay command.

      However, I am facing the problem I've stated above using the arecord -vv command.

       

      Is there any specific mic i must connect to?

      I am using my  a-JAYS One+ earpiece as the microphone.

       

       

      Cheers!

        • 1. Re: Unable to record with ALSA utils
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi,

          Are you able to perform all the steps under “Configuring a USB sound card for the Intel® Edison”?

          Take a look at http://manpages.ubuntu.com/manpages/precise/man1/aplay.1.html . According to this, arecord is a recorder for the ALSA soundcard driver and aplay plays instead of recording, not the other way around. Are you trying to play files using the arecord command?

          Were you able to record using the arecord command? What’s the complete command you used to record?
          The recommended way to record using arecord is: arecord –D <device_name> -f <format> -r<Hz_value> <output_name>.wav
          You can play these recorded files with aplay, such as: aplay <output_name>.wav

          You can see more information on arecord and aplay and their options in the link posted above.

          Sergio
           

          • 2. Re: Unable to record with ALSA utils
            mr_crocodile556

            Thank you for the useful link! Yes I am able to perform all the steps under "Configuring a USB sound card" I am currently using the command of root@edison:~# arecord -vv /home/motion/test.wav Can i have an example of the recommended way as i do not know how to locate my device name and format.

            • 3. Re: Unable to record with ALSA utils
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Type arecord –l and look for your device. Notice the card number and the device number. These are the parameters for the –D option. So for a card number 2 and device number 0 this option is “hw:2,0”. On format there are different options to choose, look at the website of our previous post for some options but keep in mind that not all may work on the Edison.

              An example of an arecord command may look like this:
              arecord -D hw:2,0 -f S16_LE -r16000 output.wav

              Sergio