3 Replies Latest reply on Apr 14, 2016 3:16 PM by DufeRob

    Flash problem (dfu error)

    DufeRob

      Hello. I tried to flash yocto to Edison but I get an error. Here is the listing:

      sudo ./flashall.sh

      Using U-Boot target: edison-blankcdc

      Now waiting for dfu device 8087:0a99

      Please plug and reboot the board

      Flashing IFWI

      ##################################################] finished!

      ##################################################] finished!

      Flashing U-Boot

      ##################################################] finished!

      Flashing U-Boot Environment

      ##################################################] finished!

      Flashing U-Boot Environment Backup

      ##################################################] finished!

      Rebooting to apply partition changes

      Now waiting for dfu device 8087:0a99

      Flashing boot partition (kernel)

      ##################################################] finished!

      Flashing rootfs, (it can take up to 5 minutes... Please be patient)

      ##dfu_download: libusb_control_transfer returned -1

      Rebooting

      U-boot & Kernel System Flash Success...

      Your board needs to reboot to complete the flashing procedure, please do not unplug it for 2 minutes.

       

      Help me please.

        • 1. Re: Flash problem (dfu error)
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi,

          First, make sure you’re powering the board with an external power supply before attempting to flash. What OS are you using on your computer? Have you installed dfu-util before running the flashall such as in https://software.intel.com/en-us/flashing-firmware-on-your-intel-edison-board-linux. What image are you attempting to flash?

          Sergio
           

          1 of 1 people found this helpful
          • 2. Re: Flash problem (dfu error)
            DufeRob

            Thank you for response.

            I tried with an external power and w/o it. I got the same result.

            I use Ubuntu 14.04 on PC. I installed dfu-util. I tried to flash the latest image with yocto. But before this I had ubilinux with ROS,

            Also I tried phoneFlashTollLite but unfortunately I have the follow error:

             

            04/14/16 23:46:14.863 INFO : [Port 6] Running `"/usr/lib/phoneflashtoollite/dfu-util" "--alt" "u-boot-env1" "-D" "/home/duferob/Downloads/iot-devkit-prof-dev-image-edison-20160315/u-boot-envs/edison-blankcdc.bin" "-t" "4096" "-R" "-d" "8087:0a99"` command

            04/14/16 23:46:15.930 WARNING: [Port 6] Command `"/usr/lib/phoneflashtoollite/dfu-util" "--alt" "u-boot-env1" "-D" "/home/duferob/Downloads/iot-devkit-prof-dev-image-edison-20160315/u-boot-envs/edison-blankcdc.bin" "-t" "4096" "-R" "-d" "8087:0a99"` failed

            04/14/16 23:46:15.931 INFO : [Port 6] Retrying `"/usr/lib/phoneflashtoollite/dfu-util" "--alt" "u-boot-env1" "-D" "/home/duferob/Downloads/iot-devkit-prof-dev-image-edison-20160315/u-boot-envs/edison-blankcdc.bin" "-t" "4096" "-R" "-d" "8087:0a99"` command

            04/14/16 23:46:16.056 ERROR : [Port 6] Command `"/usr/lib/phoneflashtoollite/dfu-util" "--alt" "u-boot-env1" "-D" "/home/duferob/Downloads/iot-devkit-prof-dev-image-edison-20160315/u-boot-envs/edison-blankcdc.bin" "-t" "4096" "-R" "-d" "8087:0a99"` failed

            04/14/16 23:46:16.056 ERROR : [Port 6] Flash failed (Command type: DFU)

            • 3. Re: Flash problem (dfu error)
              DufeRob

              It's very weird, but after using the phoneFlashTollLite with the error I tried flashall.sh again but with screen control. And it flashed my Edison. Thank you, Sergio.