1 2 Previous Next 22 Replies Latest reply on May 9, 2016 9:45 AM by Intel Corporation

    Linux mint and Ubuntu crash on NUC6i5SYH

    F.S

      Hi guys,

      I got my NUC6i5 right after it was released to the market in February. Here is my experiences on installing and running Linux mint and Ubuntu on NUC6i5SYH. Both Linux distributes crashed on NUC after several weeks. I hope we can find out what caused the problems, linux or hardware, or both?

       

      SSD: Samsung 850 EVO 500M

      RAM: Corsair 8G*2

       

      First one:

      System: Linux mint 17.3

      BIOS: 0036

       

      To make the wifi and bluetooth working, you have to update the kernel to 4.2.X. There is interference between wifi and bluetooth which caused the wifi unstable, very slow and keep disconnecting about every 5 or 10 minutes. It can be resolved by turning off the bluethooth. I want to know if it is a common issue for the Intel 8260 chip used in the NUC or it is only happened on my NUC. Also, is there any way to resolve it?

       

      After running for almost one month, the NUC was found automatically restarted and freezed at login screen in a morning. Tried to restart the computer and it stopped booting at login screen every time. The only way to login the system was by compatibility mode. And got a warning that software rendering video was working. I decided to format the SSD and make a fresh installation. However, when I boot with my installation disk, I also have similar problem. Some time I could successfully load the installation program but mostly crashed and keep restarting. In those success cases, it mostly crashed while installing the system. It happened I got my system (Linux mint) installed. But I still have the same problem as before reinstalling the system. Mostly, the computer keep rebooting by itself after go to the login screen. I also got some error warning while booting with flash drive.

      To confirm if it is due to the installation drive, I also tried Ubuntu 14.04 TLS. It got the same problem, too. Freeze at login screen or automatically rebooting.

      Meanwhile, the problem became worse and worse while I trying to reboot and reinstall. It crashed early and early while booting.


      After those failures, I got my first NUC replaced by Intel.


      Second one:

      System Ubuntu 14.04 TLS

      BIOS: 28, 36


      I know Linux mint and Ubuntu are almost the same. But Ubuntu has later kernel which support the hardware better, at least wifi and bluetooth (both worked right after the system installed). Actually, I got lest problems from Ubuntu than Linux mint. It ran pretty good before it crashed.


      I got my second NUC crashed less than a month, right after I got my first NUC replace case closed.


      On last Sunday morning, the previously suspended NUC was found stuck on a blue light with black screen. I tried to restarted it many times and every time it froze on login screen where the keyboard and mouse were both locked with out any reflection. Actually, I got several seconds before the keyboard and mouse locked. Then, I tried to reinstall my system (Ubuntu). I also got my keyboard and mouse w/o any reflection. So, I cannot do anything.Every time I booted into the graphic screen, I lost my control of the system. Another weird thing I found is the day before the NUC crashed, the wifi became unstable and I had to disable and enable it to connect to wifi. This might be coincident. Both keyboard and mouse can be recognized in BIOS.

      After disconnected power cable for one day. I tried above again. The graphic UI could work longer (about 1 minute, before was about several seconds) before got frozen. But, if I restart the NUC, that working time went back to several seconds again.

      As for the suggestions by Inetl rep., I updated BIOS to 36, it did not help. Tried to log into terminal shell tty1 (Ctrl+Alt+F1) or  tty2 (Ctrl+Alt+F2): freeze after several seconds, too. And the condition became worse and worse while trying. Finally, I got restarting when press the key combinations. Also, network cannot be connected (devices can not find) under recovery mode. I also tride newer version Ubuntu 16.04 TLS beta 2, whose kernel should support Skylake better. Still froze on the installing. Which mean I cannot install the system I have.


      I know, for Linux, the graphic driver bugs may result in kernel errors, GPU crashes and even complete system freezes. But cannot install linux on NUC after several weeks using is weird. And both NUC got conditions became worse while trying more. I my opinion, I think there might be some hardware or firmware problems besides the system driver issues.


      I want to give the NUC another try to see if I would get the third crash. I am still waiting. Ubuntu 16.04 TLS is going to release in following weeks. And I have not tried the 42 version Bios on my NUC.


      Thanks for the help from Intel rep.


      Best,


        1 2 Previous Next