9 Replies Latest reply on Jun 7, 2016 9:58 AM by ivanu_intel

    NUC will not recognise USB devices.

    dcx3li

      I'm trying to install an OS on my NUC but the unit will not recognise USB devices after the initial CD/DVD boot up.

        • 1. Re: NUC will not recognise USB devices.
          hegenious

          Which OS? Windows 7 perhaps? It's a known issue with Win7 install media, because they don't include native drivers for USB3.

           

          This method worked fine for me with Win7 Ultimate.

          • 2. Re: NUC will not recognise USB devices.
            ivanu_intel

            Hello dcx3li,

             

            Thank you for joining the Intel communities.

             

            We need more information, what is the NUC model? What operating system are you installing?

             

            Let me know if hegenious suggestion helped you with this issue.

             

            Regards,

             

            Ivan

            • 3. Re: NUC will not recognise USB devices.
              dcx3li

              Thanks for your input, yes I totally forgot about the USB3 driver issue with Win7. I installed Win8/8.1 then upgraded to Win10 (not sure why!). I still found using the NUC difficult to use because using more then one USB port wasn't possible, I had a keyboard dongle and external HDD (with it own power supply) connected to the unit but the HDD and keyboard would disconnect and reconnect constantly, even though the specs regarding the NUC states that you can connect 4 devices. I have found a way around this - I have bought a powered USB hub and this seems to have solved the problem....so far.

              • 4. Re: NUC will not recognise USB devices.
                hegenious

                Hmm, still not normal that you cannot connect devices to all 4 usb ports. As you say, it's in the specs and my NUC supports all 4 USB ports

                First I would try and rule out the wireless keyboard and its dongle by connecting a wired usb keyboard and mouse connected to usb ports 1 and 2.

                See how that works when you add the HDD connected to the 3rd usb port. If that's still fine, the wireless device may be the culprit.

                if you have a USB stick laying around or a smartphone, connect that to port nr 4 and see it works/charges the battery.

                If still you can connect only 1 device at a time, there's something wrong with the NUC.

                Hope this helps with troubleshooting, the work around you already have it

                • 5. Re: NUC will not recognise USB devices.
                  ivanu_intel

                  Hi dcx3li,

                   

                  What is the model of your Intel® NUC?

                   

                   

                  Regards,

                   

                  Ivan

                  • 6. Re: NUC will not recognise USB devices.
                    tech1e_guy

                    Hi,

                    I recently updated my NUC D34010WYK with Windows 10 OS. I also updated the BIOS to the latest version. After successfully installed windows 10 X64, USB won't recognize my USB 2.0 flash drives. I tried different usb drives front and back ports. All ports are enabled in bios.

                    But my Logitech keyboard usb dongle is recognized and USB 3.0 flash drives are recognized but not USB 2.0 flash drives.

                    In device manager, it says USB 3.0 extensible host controller - 1.0 (Microsoft). I tried to install Intel USB 3.0 host controller driver meant for my NUC (Only available for windows 7 version). But it says my system does not meet minimum requirements.

                    I downloaded Intel driver update utility program and it scanned my system and tells no drivers installed (however I have installed intel latest LAN and Chipset driver for windows 10 from support page).

                    All usb ports were working fine with windows 7. Now in windows 10, only usb 2.0 drives are not working. I toggled usb legacy in bios but no change. I also uninstalled Microsoft usb 3.0 host controller driver but when I reboot, it is automatically installed.

                    • 7. Re: NUC will not recognise USB devices.
                      ivanu_intel

                      Try reinstalling the Intel® Chipset Device Software.

                      Also, see Front USB Ports Do Not Work

                       

                      Check Device Manager to see if your USB ports or hubs are working properly.

                       

                      Open Device Manager by clicking the Start button Picture of the Start button, clicking Control Panel, clicking System and Maintenance, and then clicking Device Manager. Administrator permission required if you are prompted for an administrator password or confirmation, type the password or provide confirmation.

                      Double-click Universal Serial Bus controllers and check to see if all your USB ports, hubs, and controllers are functioning correctly. Any devices not functioning will have a yellow exclamation mark in front of them.

                       

                      Regards,

                       

                      Ivan

                      • 8. Re: NUC will not recognise USB devices.
                        tech1e_guy

                        I Installed the chipset software. Checked device manager - no issues. All ports are functioning correctly. No yellow mark in any of the devices.

                        I am running Windows 10 X64 - latest build

                        I narrowed down the issue.

                        USB3 devices: All work fine

                        USB2 devices: All work except a couple of USB2 drives I have.

                        Those couple of USB2 drives work fine in my desktop running Windows 10 x64 also. But when I insert it to front or back ports, the usb light is solid but is not recognized at all by NUC.

                        These flash drives were used in Linux before. I tried formatting to Fat32 with default settings. Still won't read.

                        • 9. Re: NUC will not recognise USB devices.
                          ivanu_intel

                          Being that the case I suggest you to replace the unit, most likely the unit is defective because this unit has been tested and the USB port work ok. Please submit a warranty replacement at the following link:

                          https://customercare.intel.com/?lang=en-US

                           

                          Regards,

                           

                          Ivan