10 Replies Latest reply on Apr 13, 2016 8:53 AM by Amy_Intel

    Machine Check Error - IBA GE Slot 00c8 v1365

    paramountain

      I might miss mentioning a step or switch the order of events because I did not take notes.

       

      I was using a DZ68BC (BIOS=0028), i5-2500k, 8GB Crucial Ballistix Tactical DDR3-1333, and Seasonic 650W PSU which has been running for about a year in its present configuration. I powered it off to change SSDs -- I'm playing with Linux distributions -- and when I powered it back on, I noticed that the time was off by hours (it might have been that way before). Okay, so it needed a new battery. I just happened to have a new CR 2032. So I powered it back off and replaced the battery. I powered it back up, changed the time in BIOS, and installed Zorin OS using a CD-ROM I have used a few times already. It finished normally and told me to remove the disc and reboot. That's when things changed.

       

      I removed the disc and pressed Enter as instructed, but instead of rebooting the PC went to a screen I had never seen on this DZ68BC, but I have seen it on my DH67BL, the screen that indicates that it is trying to perform a network boot. That's strange, because I disabled network boot in BIOS, something I always do. Okay, I'd start fresh. I rebooted, entered BIOS, and pressed F9 to return to default, but after saving the system returned to the network boot screen, which kind of made sense because that was now enabled. I rebooted and pressed F10 to select the booting device because I thought everything was normal. However, in the list of bootable devices there were three entries: the CD-ROM drive, the Intel 530 SSD, and IBA GE Slot 00c8 v1365. Oh boy, that's not good.

       

      So I powered down and pulled every add-on card out of the case -- Creative sound card, SIIG USB 2.0, and SIIG USB 3.0 -- because that message looked like the PC wanted to boot from a PCI or PCIe slot. I powered up and immediately after the BIOS screen saw the message Machine Check Error. Oh boy, big trouble. I rebooted again and saw the same message. I powered down, removed the battery, and let it sit for a five minutes. I put the old battery back in, hit the power switch, and saw the blue light flicker just for a second and the fans started turning, but then it shut down. I tried it again with the same results. I switched back to the new battery, but same results.

       

      It looks like either the processor or the board is toast. I just happen to have a spare DH67CL board and a spare Sandy Bridge processor to try both components, but I'd like to hear the official explanation of Machine Check Error and IBA GE Slot 00c8 v1365. I understand there is no warranty. I will update this post as I learn more.

       

      UPDATE: It's the board. I bread-boarded the DH67CL with the same memory sticks and i5-2500k and it booted right up into BIOS. Oh well, the DH67CL always worked okay. Scott will be ecstatic to know that the DH67CL BIOS was updated into Sandy / Ivy territory from before.

        • 1. Re: Machine Check Error - IBA GE Slot 00c8 v1365
          N.Scott.Pearson

          First of all, the fact that the time is off doesn't mean that the battery is dead or needs to be replaced. I have seen Linux distributions that buggered up the CMOS (including date/time) settings. Replacing the battery isn't (usually) an issue, however.

           

          Second, the label "IBA GE Slot 00c8 v1365" was just what was used back then to indicate that it was going to use this particular GE LAN NIC for network boot. It was displayed this way to allow differentiation between the NICs on boards that had dual NICs.


          Third, I have also seen Linux distributions that corrupt the BIOS configuration as well (usually when UEFI is enabled; there are some conversations in the NUC forum recently about this happening with certain versions of Linux).

           

          Are you truly dead? does this happen consistently?

           

          ...S

          • 2. Re: Machine Check Error - IBA GE Slot 00c8 v1365
            paramountain

            I updated my earlier post. Yes, the board appears to be dead. This has never happened before, but then again I have only been seriously promiscuous with Linux for the last month. I had not gone into UEFI territory because I wanted to switch back-and-forth between Windows and Linux.

             

            I find it hard to blame Zorin OS Linux because I had installed it twice before on the same PC, once on a hard drive and once on an SSD. Today I had started up a copy of W-7 on the PC just before I started this latest escapade. That said, I won't touch it again. I'll stick with Fedora and Korora.

             

            I will next put my other Sandy Bridge processor into the DZ68BC to see if anything changes. If that works, I will have no idea what is going on.

             

            Thanks for the comment about the battery. It seems like that was a red herring.

             

            What versions of Linux were disparaged? Zorin OS is a spin of Ubuntu, not my favorite distribution.

             

            Thanks for the "IBA GE Slot 00c8 v1365" information, but I think that was another red herring. One of the problems with the DZ68BC is that it will do a BIOS auto-F9 whenever it feels like it. I now think that's why I started seeing the network boot screen, because the BIOS was re-allowing network boot.

             

            The Machine Check Error is still a bad omen, I think.

            • 3. Re: Machine Check Error - IBA GE Slot 00c8 v1365
              paramountain

              Okay, I installed my older Sandy Bridge processor (which I know works because I previously bread-boarded it with the aforementioned DH67CL board) into the DZ68BC and exactly the same symptoms appeared; I pressed the power switch and the blue light flickered and the fans turned for about 1/2 second. There's not much I can do if I can't even get into BIOS. I think the board is toast; the king is dead, long live the king. There's one more test to perform, install the DH67CL into the case to test if the power supply or power switch failed, but not tonight. And I'll move to 0160 BIOS.

              • 4. Re: Machine Check Error - IBA GE Slot 00c8 v1365
                paramountain

                I just read the NUC forum comments you alluded to. Oh boy, that sounds like my problem. Zorin OS is a spin of Ubuntu, so it's logical that it could cause the same problem. I admit I skimmed and did not read every word of the thread, but every Linux version I saw mentioned was Ubuntu or a derivative thereof (Mint was also mentioned, but it's Debian/Ubuntu). Fedora is based on Red Hat, which is itself based on Unix. One poster, snowpine, commented that Fedora is much better. Red Hat / Fedora has some significant differences with the Debian derivatives, not the least being SELinux adoption.

                NUC5i5RYH Bricked by Ubuntu Suspend for Fifth Time

                 

                The NUC thread makes it sound like Intel boards are not tested with Linux. That's not very far-sighted, given Microsoft's W-10 debacle.


                Something I did not mention before is that I removed the original Crucial memory and replaced it with one stick of Hynix.


                I removed the battery, detached the power cord, and let it sit for fifteen minutes to duplicate what the NUC comments were recommending. Then I replaced the battery and tried starting it. No difference, still a brick. Then I tried one last thing. Instead of pressing the power switch for a short time as usual, I pressed it and held it. EUREKA! I started seeing messages: memory reduction, case was opened, battery removed, time wrong, yada yada. I was able to get into BIOS. Now it will start via the usual short button press.

                 

                Wow, it sounds like all I had to do was remove the battery, wait, and then start by pressing the power switch and holding it. I won't soon forget that lesson. And I will stick to Fedora from now on.

                • 5. Re: Machine Check Error - IBA GE Slot 00c8 v1365
                  N.Scott.Pearson

                  Glad you are back in business.

                   

                  This is all I will say on the validation argument: The per-OS/per-distro cost of validation is *very* high. For every Linux user out there, there are literally hundreds - if not thousands - that are using Windows. On top of this, there are literally hundreds of distros out there -- and, something that absolutely flummoxes me: a lot of people actually *like* Windows 10...

                   

                  ...S

                  • 6. Re: Machine Check Error - IBA GE Slot 00c8 v1365
                    Amy_Intel

                    Hello, All:

                     

                    paramountain, thank you for your feedback, I am glad to hear that you were able to resolve your issue.

                     

                    Regards,

                    • 7. Re: Machine Check Error - IBA GE Slot 00c8 v1365
                      paramountain

                      I do appreciate your comment regarding qualification costs, but I neglected to say that Intel could restrict itself to two distributions, Ubuntu and Fedora, with the former being AppArmor territory and the latter being SELinux territory. Many distributions are spins of Ubuntu. I'm too lazy to verify it, but I would wager that Ubuntu has the most spins in all of Linux-land. Fedora isn't as popular, for reasons I do not understand, but it still has some spins. It has been my experience that if the parent works, a spin will usually work (and vice versa, as I proved). Intel could state something like, we have tested Ubuntu with spins of it *probably* working as well, but caveat emptor. I am equally flummoxed, but the number of people buying NUCs pre-installed with Ubuntu shows that the market is diverging.

                       

                      Thanks for the tip regarding Linux. I would NEVER have suspected that Linux was the cause of the problem

                      • 8. Re: Machine Check Error - IBA GE Slot 00c8 v1365
                        Amy_Intel

                        Thank you for your feedback.


                        Regards,

                        • 9. Re: Machine Check Error - IBA GE Slot 00c8 v1365
                          paramountain

                          Epilogue.

                           

                          The software engineer in me refused to let it die, so I wiped the same SSD I used before and installed Zorin OS again. This time it went perfectly, as it had done once or twice previously. I do not know why it works most of the time, but perhaps it has to do with my replacing the battery just before the incident. It also probably has to do with the DZ68BC's annoying habit of reverting all-but-one BIOS setting to default whenever there is a problem with booting.

                          • 10. Re: Machine Check Error - IBA GE Slot 00c8 v1365
                            Amy_Intel

                            Thank you for taking the time to share your findings, it is really good to hear that you solved this.

                             

                            Regards,