1 2 Previous Next 18 Replies Latest reply on Aug 23, 2012 7:06 PM by potato

    DH55HC driver for 82578DC network adapter fails at startup

    dpress

      I have a new system build centered around a DH55HC motherboard with an i3-530 processor running Windows 7x64.  On startup (every power cycle or reboot), the network connection is always broken, and the Windows troubleshooter points to the hardware or driver for the 82578DC Gigabyte Enet device.  By going into Device Manager and Uninstalling the driver (while not removing it from the drive) and then doing a search for hardware changes, the port is found and the driver is automatically reinstalled... and then it starts working!  So if the driver works on reinstall, why not at startup?

        • 1. Re: DH55HC driver for 82578DC network adapter fails at startup
          bgrorud

          I have exactly the same problem, but Windows XP Pro, 32 bit.  I updated the bios to the latest release before installing the net.  Mine does not seem to work temporarily on a reinstall without reboot though.  I have tried various version of the intel network driver but did not work.

           

          My configuration - Core i5-750 cpu, DH55HC board, 4gb kingston 1333 ram, ATI video card, 420 watt power supply, xp pro 32 bit.

          • 2. Re: DH55HC driver for 82578DC network adapter fails at startup
            bgrorud

            UPDATE- I changed the video card to an ATI Radeon 3450 series (the only other one I had around) and my network card started booting.  Not sure if it was the power draw of the bigger card, or some other compatibility issue, but this fixed it for me...

             

            (on that boot, I also booted with the network cable unplugged and I moved my usb kvm mouse/kb to a different usb port further away from the network port, but I have since moved them back and it boots fine after a power cycled with the network card connected.)

             

            Hope this helps!

             

            -Brad

            • 3. Re: DH55HC driver for 82578DC network adapter fails at startup

              I am also having a similar problem with my i3-350 system. The difference is that I am using a DH55TC desktop board. I used to re-install the drivers every time I need to start-up the computer, until I found out that disabling then enabling the network adapter from the Device Manager also works (I already placed a shortcut on my desktop!). But this is still annoying me. I have updated to the latest BIOS and read through some of the similar problems at the boards to no avail. I hope I can find a fix soon.

              • 4. Re: DH55HC driver for 82578DC network adapter fails at startup
                bgrorud

                ANOTHER UPDATE- I have built 2 more of these machines.  On the first one, I made sure I installed Windows with the network cable unplugged.  I loaded the chipset driver first, then the network and the network showed a cable was unplugged, I plugged it in and it was working.  I rebooted and it still worked.  I continued to load the rest of the drivers and when I was done the network card quit working again.

                 

                I tried to disable it and reenable but still didn't work.  I ended up using msconfig to force default video mode (see previous post) and then reenable the regular video mode and it started working and hasn't quit yet.

                 

                So on my 2nd system, I still left the network cable unplugged.  I then installed chipset and network drivers and it worked.  I tried to get it to fail, restarting, shut down and power on, shut down, pull the plug, let the power dissipate and then plug back in and turn on, AND IT CONTINUED TO WORK.  I then loaded the additional drivers one by one, and between each driver I did all 3 (reboot, shutdown and turn on, shut down-hard power cycle-turn on) and it worked every time.

                 

                Last thing to load was the bios upgrade.  I intentionally left the network cable plugged in while performing the bios upgrade.  After the upgrade - NETWORK FAILED!  I then tried rebooting with and without the cable plugged in, but it still didn't fix it.

                 

                IT STARTED WORKING when I gave it the hard power cycle and made sure power was cut to the system board (I think I did this with the network cable unplugged).  After that, it started working and it hasn't failed yet.

                 

                NOW I am not claiming this would fix it for everyone, but I am pretty sure this is what I was running into and it started working form me when I did other things, but in reality, it was the hard power cycle after the bios upgrade that fixed it every time.

                 

                I don't have any more to build for a bit, and in the future I will probably be using the DP55WB board if I am not gong to use the integrated video, but for me, this explains all 3 systems and my confidence in this board has been restored.

                 

                Hope this helps

                 

                -Brad

                • 5. Re: DH55HC driver for 82578DC network adapter fails at startup
                  LGTrader

                  Not sure if this is helpful but I'm running the DH55HC with a Core i5-661 and Gentoo Linux. The network connection works EVERY time for me no matter what I throw at the machine, and I've booted it warm and cold at least 50 times this weekend. (I have other problems but not this one!) Anyway, the Linux side would suggest this is either a Windows problem or driver problem. Much better then a hardware problem.

                   

                  If there's anything special someone wants me to look at from this side let me know. So far I cannot get XP on this box so I'm happily working on bringing up Gentoo.

                   

                  Cheers!

                  • 6. Re: DH55HC driver for 82578DC network adapter fails at startup
                    fitec

                    I like the fast boot-time and simple bios of Intel boards. Thats why I want to use these boards instead of my old Asus ones.

                    But I had never these problems like I have with my DP55WG and DH55HC and i3 processor. There are bios crashes, system shutdowns, PCI-e wrong link speeds, etc. I tried out different memories and vga cards. Now I am able to run my DH55HC stable, but only with 2x2Gb certified memories. I think it is important, to use only components verified by intel. I am not glad about that, because I never got compatibility problems with asus or gigabyte. Hope intel do solve these problems with more bios updates.

                    • 7. Re: DH55HC driver for 82578DC network adapter fails at startup
                      onsitecg

                      This worked for the DH55HC MB.  Uninstall the network adapter either through Device manager or with the Intel install/uninstall.  Flash the Bios to most current version.  Reload latest NIC drivers.  Just as a note for the DH55WB setting the NIC to Force Master in Properties/Advanced solved this problem.

                      • 8. Re: DH55HC driver for 82578DC network adapter fails at startup
                        oshaker

                        Non of what has been mentioned here solved the problem. It simply fails to load the driver i.e. start the driver of the ethernet card. BIOS has been updated as well as latest updates were installed. Still the problem persists.

                        • 9. Re: DH55HC driver for 82578DC network adapter fails at startup
                          milli260876

                          I have this issue too with the DH55HC, there is a lot of info on a different NIC.. here

                          http://communities.intel.com/thread/9913

                           

                          i'm unsure if this has solved my problem, need to test further. I just applied the regedits

                          This keeps waking my PC from S3 sleep saying device disconnected...

                          Immensley annoying, apparently a SIPS issue?? Anyone from Intel care to comment? NEW Drivers Please???

                          • 10. Re: DH55HC driver for 82578DC network adapter fails at startup
                            DukeP

                            This is a common problem with Intels release drivers for win7.

                             

                            Problem did not exist with the release candidate of win 7.

                             

                            Theres several threads with these problems; mine was with the DP55SB

                             

                            ~~DukeP~~

                            • 11. Re: DH55HC driver for 82578DC network adapter fails at startup
                              milli260876

                              If this is the case then surely intel need to do something?

                              I am pretty frustrated with windows 7 to be honest(i know this is a microsoft problem!)

                              RC worked flawlessly with everything RTM seems to have broke everything...

                              Anyway back on track

                              NEW DRIVERS PLEASE INTEL?????

                              • 12. Re: DH55HC driver for 82578DC network adapter fails at startup
                                BFischer

                                Hey.

                                I got the DH55HC and the Core i5 650. Im running Windows 7 64 Ultimate.

                                I think I ran into an incompalibility between the 82578DC NIC and Microsofts bothersome build-in license software.

                                Im using the March 2010 BIOS, which at present seems to have been withdrawn from the Intel site. Upgrading from the december 2009 BIOS actually was an improvement. NIC drivers are the current from Intel.

                                Thing is, I get a BSOD at bootup. I can work aound this by first entering BIOS and disable the build-in NIC. The PC boots perfectly with no network ofc. I then reboot, enter BIOS again end enable the onboard NIC. The PC will now function perfectly and indeed perform very well. Please note, I'm not overclocking anything.

                                I couldnt be happier with the motherboard and Core i5 650 if this issue got fixed.

                                Running the old msdbg on the memory dump reveals the following, indicating to my eye that peauth.sys for some reason fainted during bootup:


                                DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

                                BUGCHECK_STR:  0x7E

                                PROCESS_NAME:  System

                                CURRENT_IRQL:  0

                                ERROR_CODE: (NTSTATUS) 0xc000001d - {EXCEPTION}  Illegal Instruction  An attempt was made to execute an illegal instruction.

                                LAST_CONTROL_TRANSFER:  from fffff88005f37e6e to fffff88005effd7c

                                FAILED_INSTRUCTION_ADDRESS:
                                peauth+45d7c
                                fffff880`05effd7c c6              ???

                                STACK_TEXT: 
                                fffff880`031a1478 fffff880`05f37e6e : fffff880`031a14a0 fffff880`031a1590 ac28f8bf`d6132ddf c59e624c`5d7cb796 : peauth+0x45d7c
                                fffff880`031a1480 fffff880`05f37f4b : fffff8a0`02760000 fffffa80`068ce000 fffffa80`068bc2a0 00000000`00000001 : peauth+0x7de6e
                                fffff880`031a1790 fffff880`05ec20b9 : 36c23ced`3ae0067f 00000000`00343000 00000000`00000001 00000000`00000000 : peauth+0x7df4b
                                fffff880`031a17e0 fffff880`05f5a104 : fffff8a0`02760000 fffffa80`068ce000 fffffa80`068ce000 fffff880`05ec1982 : peauth+0x80b9
                                fffff880`031a1810 fffff880`05f5a1e6 : fffffa80`00000000 fffffa80`6f2e2454 fffffa80`00000000 fffffa80`068ce000 : peauth+0xa0104
                                fffff880`031a1860 fffff880`05f5a391 : fffffa80`00000000 fffff880`05f5a168 0000057f`f9754608 0000057f`f9734538 : peauth+0xa01e6
                                fffff880`031a18b0 fffff880`05ebb659 : 00000000`00000000 fffffa80`068ce000 fffff800`00000000 0000057f`f9742188 : peauth+0xa0391
                                fffff880`031a1940 fffff880`05f5a583 : fffffa80`068bc2a0 00000000`00000000 fffffa80`068ce000 fffffa80`03b6bb60 : peauth+0x1659
                                fffff880`031a1970 fffff800`02e64fa7 : fffffa80`068bc2a0 fffffa80`068bc2a0 00000000`00000000 00000000`000007ff : peauth+0xa0583
                                fffff880`031a19a0 fffff800`02e653a5 : 00000000`00000001 00000000`00000000 00000000`00000000 fffff880`025b1bc0 : nt!IopLoadDriver+0xa07
                                fffff880`031a1c70 fffff800`02a89861 : fffff800`00000000 ffffffff`80000680 fffff800`02e65350 00000000`00000000 : nt!IopLoadUnloadDriver+0x55
                                fffff880`031a1cb0 fffff800`02d21a86 : 7500427d`80287507 fffffa80`03b6bb60 00000000`00000080 fffffa80`03b4c040 : nt!ExpWorkerThread+0x111
                                fffff880`031a1d40 fffff800`02a5ab06 : fffff880`02fd3180 fffffa80`03b6bb60 fffff880`02fddfc0 3c72f5c5`e8571d6a : nt!PspSystemThreadStartup+0x5a
                                fffff880`031a1d80 00000000`00000000 : fffff880`031a2000 fffff880`0319c000 fffff880`031a1160 00000000`00000000 : nt!KxStartSystemThread+0x16


                                FOLLOWUP_IP:
                                peauth+45d7c
                                fffff880`05effd7c c6              ???

                                SYMBOL_STACK_INDEX:  0

                                SYMBOL_NAME:  peauth+45d7c

                                FOLLOWUP_NAME:  MachineOwner

                                MODULE_NAME: peauth

                                IMAGE_NAME:  peauth.sys

                                DEBUG_FLR_IMAGE_TIMESTAMP:  4a5bd8df

                                STACK_COMMAND:  .cxr 0xfffff880031a0aa0 ; kb

                                FAILURE_BUCKET_ID:  X64_0x7E_BAD_IP_peauth+45d7c

                                BUCKET_ID:  X64_0x7E_BAD_IP_peauth+45d7c

                                Any thoughts on this?

                                 

                                Greeting from Denmark, Scandinavia.

                                - Bjarne.

                                • 13. Re: DH55HC driver for 82578DC network adapter fails at startup
                                  onsitecg

                                  After building multiple computers using this motherboard and having upgraded a Dell 4700 and a white box running a D945 board, ALL are having network issues.  The Dell will show a good connection, but not actually be able to access the network or internet.   This seems to happen radomly and a reboot corrects the problem.  The D945 board does almost the same thing but the network printers work even though the rest of the network and internet do not.  Sometimes the network printers don't work either.  With the DH55HC flashing the bios and updating the NIC drive works sometimes.  Other times you have to uninstall/reinstall the driver several times.  I realize that this is not very helpful except to say it is an issue and appears to be Windows 7 and not Intel.  Hopefully Intel can put enough pressure on Microsoft and get this issue resolved immediatly.

                                  • 14. Re: DH55HC driver for 82578DC network adapter fails at startup

                                    Same here...

                                     

                                    DP55WG mobo

                                    Core i5 760

                                    XP SP3 (i86)

                                    intel drivers 11.10.86.0

                                     

                                    I have to disable/re-enable the device every boot - its easier than going through the "Update drivers" routine.

                                     

                                    This is a real PITA; I suspect that it is an Intel driver problem...

                                    (I too used to have an ASUS; this may be my last Intel...)

                                    1 2 Previous Next