1 Reply Latest reply on May 23, 2011 8:39 AM by Climaco

    Need to set an IRQ explicitly for an Intel S5520SC motherboard

    tweakoz

      Board: Intel S5520SC

      CPU: 2x Intel 5520 2.26 ghz Nehalem Xeons

      RAM: 12GB ddr3

      OS: Windows 7 x64

       

      Specifically, I have USB audio glitches.

      The audio device manufacturer recommends the device be run on its own dedicated IRQ.

      This is actually a common requirement for many high end audio devices.

      Note that this means physical IRQ (IRQ<16), not virtual IRQ.

      Is there any way I can force this with an internal USB port of the ICH10R ?

      Also is the internal USB hub of the ICH10R usb devices able to be disabled ?

       

      Thanks,

      mtm

        • 1. Re: Need to set an IRQ explicitly for an Intel S5520SC motherboard
          Climaco

          Hi Michael Mayers,

          I'm having the same problem with a firewire audio card, high latency and audio glitches,

          the machine is almost the same,

           

          Intel® SC5600BASE Case
          Intel® Workstation Board S5520SC
          2 x Intel® Xeon® CPU E5620 @ 2.40GHz
          4 x KINGSTON KVR1333D3D4R9S/4G total 16Gb RAM DDR3 1333Mhz ECC
          2 x SEAGATE BARRACUDA 7200.11 1.5TB RAID 1
          SAPPHIRE RADEON HD 5670 512MB
          WIN 7 PROFESSIONAL OEM 64BIT
          SATA DVD Burner

           

          I found big latency issue on the following kernel modules hal.dll and ntoskrnl.exe, i was supposing that an IRQ sharing was the origin of the problem.

           

           

          have you solved the problem in any way?

          have you found how to assign IRQ manually?

          Thanks