2 Replies Latest reply on Jun 20, 2012 9:19 AM by krick

    Error loading operating system

    mattclary

      I just purchased an x25-v and am having some problems loading XP on it. I used a Win 7 install disk to set the offset as per these instructions:  http://www.ocztechnologyforum.com/forum/showpost.php?p=326656&postcount=3.  I used nLite to integrate my SATA drivers for the mobo, and the disk is properly recognized by the XP install. I do a format (tried quick and full) of the drive, the files copy, then, when the machine reboots to complete the install, an error message is displayed: Error loading operating system

      If use XP to delete/create the partition, the install completes properly, but as we all know, the drive is not aligned. It seems as though using the alignment causes the drive to not boot with XP. I found a post in another forum, here: http://www.ocztechnologyforum.com/forum/showthread.php?t=62093   that found the same issue. Oddly enough, I ALSO am using an Asus board.

       

      Can anyone provide any advice on the subject? I have tried a 32k and 1024k offset, but have not had time to do a lot of testing. Any help is appreciated.

        • 1. Re: Error loading operating system
          mattclary

          OK, I was able to resolve this issue. In the link to OCZ, their instructions say to use the Align command when creation the partition, instead you should use the Offset command! Worked like a champ!

          • 2. Re: Error loading operating system
            krick

            I finally found a true solution to this problem and I felt that I needed to share.

             

            First I installed XP normally and partitioned (unaligned) and formatted using the XP install CD as usual.

             

            Then I downloaded the gparted live cd from here...

            http://gparted.sourceforge.net/livecd.php

             

            ...and I followed the instructions I found on this page...

            http://lifehacker.com/5837769/make-sure-your-partitions-are-correctly-aligned-for-optimal-solid-state-drive-performance

             

            Start up Gparted and find your SSD in the upper-right dropdown menu. Select it, and click on your first partition in the menu. Hit the Resize/Move button in the toolbar. Change the "Free Space Preceding" box to 2MB, uncheck "Round to Cylinders", and hit "Resize/Move". (If you're using a newer live CD, check the "MiB" box). Hit Apply once and let it do its thing.

             

            Now hit Resize/Move again, and change the "Free Space Preceding" box to 1MB. Uncheck "Round to Cylinders" again, hit Resize/Move, then click Apply. Now your drive will be aligned to exactly 2048 blocks after the beginning of the disk, which allows for optimal SSD performance. Note that if you have multiple partitions on your SSD, you'll need to repeat this process for each partition, not just the first one on the disk.

             

            Yes, moving it 2MB away then moving it back 1MB seems like a long, roundabout method, but Gparted measures space in a weird way. When you first start up Gparted, your partition will have less than 1MB of space preceding it, but Gparted will only measure it as 0-meaning if you align it to 1MB right off the bat, it'll keep the drive annoyingly misaligned at 1.03MB. If you set it to 2MB, hit Apply, and then move it back to 1MB, it works fine.

             

             

            The difference in boot time between the original un-aligned install and the new aligned install are shocking.

             

            Some notes:

             

            No re-install of XP is necessary after this procedure.

             

            I have a single partition.  When I went to shift the partition back after shifting it 2MB, it showed that I had 3MB at the beginning.  I think this was rounding in the display or something.  I changed it to 1MB as instructed.  Then I re-adjusted the partition size so that there was zero space after the partition.  When you shift right, it shrinks the partition, then shifting back will leave space at the end if you don't grow the partition to use the space.

             

            Make sure you have "Round to MiB" selected.  It should be the default anyway.