3 Replies Latest reply on Apr 6, 2016 3:06 PM by Intel Corporation

    ssh to Edison

    Itstechpro

      Still need some info re ssh over wifi.  I finally made a connection using both putty and teraterm.  Used port 22.  Connection extremely slow; may have to wait many seconds for keypress echo and response.  Connection fragile and frequently is dropped by Edison.

      Any suggestions would be appreciated.

      Thanks,

      JM

        • 1. Re: ssh to Edison
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          HI JM,

          This could be due to network issues. I suggest you to check if your connection is stable. Have you tried to check if you get the same behavior while using the default image (3.0 version) with this I mean, without using the patch and other changes. 
          In order to log into the board you need to use the password of the board.

          Regards,
          Charlie
           

          • 2. Re: ssh to Edison
            Itstechpro

            Hi Charlie,

            The 'network' I'm dealing with consists of the PC running Win7 pro 64 bit and a workgroup hub communicating with an older Linksys dual band WAP using WEP security only and an ADSL modem for my Internet connection.  No router, per se.

             

            Perhaps I should just reflash with the latest release. Does the lastest release provide for configuring the RTC battery voltage and charging parameter register as the patch I am currently using provides?

             

            I also have another post filed about the same time this one was concerning a problem with an Edison Arduino sketch upload error which may be related to the dialout group .... /def/ttyS6 gets a permission denied response.

            Thanks,

            Jules

            • 3. Re: ssh to Edison
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Jules,

              With the latest image you are not able to edit the /sys/devices/platform/pmic_ccsm/backup_battery_charge register. You still will need the patch.
              The delays you see while using the SSH could be due to the network. Have you tried with another one.

              Regards,
              Charlie