7 Replies Latest reply on Apr 7, 2016 2:24 PM by Intel Corporation

    i cannot install the Intel Chipset Driver(s)

    AoS_Nexus

      Hello,

       

      yesterday my computer crashed for no known reason, i turned it off properly like thousands of times and when i turned it back on i was stuck on the Windows 7 (x64) bootrec screen.

       

      Nothing could restore the boot sector apparently so i formated my SSD drive and i made a fresh installation.

       

      Usually i go on the Asus website to find the drivers for my Rampage IV Extreme and everything works since 2013 when i bought it but actually nothing works..

       

      Sorry if my english is bad maybe and don't write it good but the "device manager" shows a huge amount of devices with no drivers, i got a screenshot but it is in french so

      i translated a little bit. i got :

       

      • Peripheral) basic system (x35)
      • meters of performance (x3)
      • controller of system interruption (x1)
      • unknown device (x1)
      • SM bus controller (x1)

       

      My computer seems to work correctly, i ran some smart test for HDDs and SSDs, some benchmarks.. i'm still updating windows 7 x64 but i'm worried about this devices not working.

       

      I tried a lot of "chipsetsetup.exe", extrating, dos install, device manager install...etc i tried a lot of things and i'm seriously out of options.. i don't know why installing this is not possible, i did before and it worked fine.

      When i try to install the Intel Management Engine Interfance it is very fast but there is no change, same for "chipsetsetup".. sometimes it goes "unknown error".

       

      Here is the screenshot, i thanks everyone who could help me and take the time to read my post. cheers, Alex

       

      screen.png