7 Replies Latest reply on Apr 5, 2016 5:54 PM by Itstechpro

    ssh to Edison

    Itstechpro

      Edison iwconfig:

      wlan0 IEEE 802.11abgn  ESSID:"hillfox#1"
            Mode:Managed  Frequency:2.452 GHz  Access Point: 00:06:25:0F:63:3D
            Bit Rate=11 Mb/s   Tx-Power=31 dBm
            Retry  long limit:7   RTS thr:off   Fragment thr:off
            Encryption key:off
            Power Management:on
            Link Quality=70/70  Signal level=-22 dBm
            Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
            Tx excessive retries:11  Invalid misc:1   Missed beacon:0

      ifconfig:

      wlan0 Link encap:Ethernet  HWaddr fc:c2:de:34:ea:fe
            inet addr:192.168.1.71  Bcast:192.168.1.255  Mask:255.255.255.0
            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
            RX packets:385 errors:0 dropped:0 overruns:0 frame:0
            TX packets:294 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:1000
            RX bytes:41187 (40.2 KiB)  TX bytes:230440 (225.0 KiB)

       

      I can get can Edison device information screen on my browser by using 192.168.1.71 for the URL and when I try to ssh with putty using the same ip address on port 22 it appears to connect.  Attempting to log in as 'root' and using the passphrase I confirmed in hostapd.conf I get access denied followed by a disconnect by the server.

      What am I doing wrong?

      The WAP connects to my DSL modem which serves as a router.

      Thanks.

      JM

        • 1. Re: ssh to Edison
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi JM,

          I have some questions:
          1.    Which image are you using? (Run configure_edison –version)
          2.    Which OS are you using on your PC?
          3.    Is the password on /etc/hostapd/hostapd.conf - “wpa_passphrase: ” the same you use to log-in into the board?
          4.    Which terminal emulator are you using to connect through SSH?
          You can try running systemctl stop connman and also, you can try with the Terminal Emulator included in the XDK IDE.

          Regards,
          Charlie
           

          • 2. Re: ssh to Edison
            Itstechpro

            Charlie,

            Thanks for the quick reply.

             

            The last version I loaded was 25.5-15 after which I loaded a patch by B.Brotherton (LGSInnovations/edison-bbcharge-patch · GitHub) that enabled setting of the RTC battery charging parameters.  That was after a conversation with you regarding an upcoming new version that would accomplish the same thing.

             

            When I try configure_edison --version now, I get a response:  could not determine firmware version

             

            OS     Windows 7 pro

            password to log into the board is different than the wpa passphrase .... but I've tried both with the same results

            using putty in ssh mode

            Jules

            • 3. Re: ssh to Edison
              Itstechpro

              Charlie,

              When I cat/etc/version, I find:

               

              custom_build_azureuser@20150821163131

               

              Jules

              • 4. Re: ssh to Edison
                Itstechpro

                Charlie,

                More developments.  Found a hint in an earlier Community post

                from the serial connection, tried

                 

                ifconfig usb0 down

                ifconfig wlan0 down

                ifconfig wlano up

                 

                can successfully log in with IP address using putty or teraterm

                but

                very very slow .. if I wait a bit, first few characters typed echo immediately but then things slow way down

                I wait seconds for a keypress echo or response to a command

                ?????

                Thanks,

                Jules

                • 5. Re: ssh to Edison
                  Itstechpro

                  One more item:

                  The wpa passphrase is not accepted, I have to use the password that I use for the standard serial connection.

                  • 6. Re: ssh to Edison
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hi,

                    I saw you opened a new thread with the same questions lets continue in there.

                    Regards,
                    Charlie
                     

                    • 7. Re: ssh to Edison
                      Itstechpro

                      Charlie,

                      Will do.  I'll close this thread and move to the other.

                      Jules