11 Replies Latest reply on Apr 20, 2016 8:12 AM by Hellen_Intel

    Flash BIOS update failing on D945GNTL

    MichaelLueck

      We use an Intel D945GNTL along with P4 631 "Cedar Mill" processor for customized OS/2 operating system computers. The place we source the boards and CPU's from this last time sent us ones with customized BIOS's that will not accept the flash upgrade to the latest BIOS version. I have tried updating with both the bootable ISO image, and also the BIOS recovery floppy methods. Both fail with the same error message.

       

      I had thought that BIOS version 4119 was the latest for this board, however while searching for a way to make the board accept the BIOS update, I found that version 4131 has been available.

       

      I updated to that 4131 version from the 4119 on another like system we have without the customized BIOS splash screen. It successfully upgraded from 4119 to 4131.

       

      Perhaps since the splash screen was customized, is that preventing updating the BIOS version?

       

      Any other suggestions?

       

      Flash BIOS update error screen:

       

      DSCF1331.JPG

       

      The customized BIOS splash screen:

      DSCF1330.JPG

       

      BIOS Flash update working on another same system we have:

       

      DSCF1333.JPG

       

      Usual BIOS splash screen on the system which accepted the flash update from 4119 to 4131:

       

      DSCF1334.JPG

       

      I am thankful,

      Michael Lueck

      Lueck Data Systems

        • 1. Re: Flash BIOS update failing on D945GNTL
          Hellen_Intel
          Hi MichaelLueck,

          That error that said “Flash update failed” could be because the BIOS version that your board has is too old, I suggest trying to do the updates according to the sequence below of BIOS versions.
          3239--3165--2706--1241--3930--3992--4045--4078--4119-4131.

          Download in this link the BIOS versions.
          https://downloadcenter.intel.com/product/7670/Intel-Desktop-Board-D945GNT

          Regards,
          Hellen.
          • 2. Re: Flash BIOS update failing on D945GNTL
            MichaelLueck

            Greetings Hellen,

             

            Well my my my... I downloaded the next higher version from the page you linked to: NT3309P.BIO

             

            And that upgrade worked... from 3239 to 3309.

             

            I am back to download the rest of the incremental updates and will try to step upgrade these boards.

             

            I am thankful,

            Michael

            • 3. Re: Flash BIOS update failing on D945GNTL
              Hellen_Intel

              Glad to see that it worked. Do not hesitate to contact us if any additional inquiries come up.


              Regards,

              Hellen.

              • 4. Re: Flash BIOS update failing on D945GNTL
                MichaelLueck

                Greetings again Hellen,

                 

                Well, not as smooth of success as I would have hoped for from the initial incremental update. Results are as follows:

                 

                Initial BIOS version: 3239

                3309   Worked

                3528   Failed

                3592   Worked

                3630   Failed

                3659   Worked

                3813   Failed

                3869   Failed

                3930   Failed

                3933   Failed

                3943   Failed

                3992   Failed

                3996   Failed

                4034   Failed

                4045   Failed

                4051   Failed

                4076   Failed

                4078   Failed

                4089   Failed

                4092   Failed

                4119   Failed

                4131   Failed

                 

                :-(

                 

                So the BIOS appears to be stuck at version 3659. Any other suggestions?

                 

                I am thankful,

                Michael

                • 5. Re: Flash BIOS update failing on D945GNTL
                  N.Scott.Pearson

                  Someone adding a customized splash screen does not prevent any BIOS updates from being installed - but it does use up some of the BIOS' free space. Your problem appears to be not enough flash space available to install the later BIOS updates. I have not heard of this happening if all of the free space is taken up by a splash image, but I suppose that it is possible.

                   

                  One thing your could try is to replace this splash screen. Use the Windows Paint program and produce one that is just a black box and then try installing this into a BIO file using Intel Integrator Toolkit (ITK). Use the .BIO file for the BIOS version that you currently have installed.

                   

                  Hope this helps,

                  ...S

                  • 6. Re: Flash BIOS update failing on D945GNTL
                    MichaelLueck

                    Greetings Scott,

                     

                    I pulled down ITK_5.0.2.562.msi, installed it on a Windows hard drive in the D945GNTL based system. I opened the BIOS file I last successfully flashed it with: NT3659P.BIO

                     

                    It comes up with an error:

                     

                    Unable to open BIOS file

                     

                    Unable to open NT3659P.BIO because it's in an older format.

                     

                    You may still be able to customize this BIOS if you open

                    the Intel Integrator Toolkit file that was used to generate

                    it (the file will have an .itk or .itw extension).

                     

                    So how did one customize the BIOS splash screens on this vintage Intel board?

                     

                    I am thankful,

                    Michael

                    • 7. Re: Flash BIOS update failing on D945GNTL
                      N.Scott.Pearson

                      In the folder that ITK installs into (usually C:\Program Files (x86)\Intel\Intel(R) Integrator Toolkit\Configuration Tools), there is an executable for the old version of ITK named ITKFEGUI.EXE. Try using it directly with your older BIO file...

                      • 8. Re: Flash BIOS update failing on D945GNTL
                        MichaelLueck

                        With ITKFEGUI.EXE ...

                         

                        File open dialog had extension list as "Integrator Toolkit Files (*.itk)" or "All Files" which I had to change to the later to be shown the .bio file I had downloaded. Trying to open NT3659P.BIO brought up error dialog:

                         

                        Intel Integrator Toolkit

                         

                        The specified BIOS file could not be opened. Select a different file and try again.

                         

                        I will be prodding the source we obtain these vintage boards from that this lot is simply not working... "find us another lot with the official Intel BIOS". Or do you yet have some further suggestion to try?

                         

                        I am thankful,

                        Michael

                        • 9. Re: Flash BIOS update failing on D945GNTL
                          N.Scott.Pearson

                          I am sure they're just going to tell you that this board *does* have an official Intel BIOS (it just happens to have been customized by a previous owner).

                           

                          I thought that this method of gaining accessing the old ITK program would be the easiest. There is also a copy of an older version in the downloads area for this board that you should try (here's the link: Download Intel® Integrator Toolkit Framework Edition)...

                           

                          ...S

                          • 10. Re: Flash BIOS update failing on D945GNTL
                            MichaelLueck

                            Actually the complete/correct answer is in this post, not above.

                             

                            The distributor found stock of the D945GNTL motherboard under a different SKU and agreed to swap the boards. I have performed the following on said alternate boards:

                             

                            Update from BIOS Rev 4089 to Rev 4143

                             

                            DSCF1364.JPG

                             

                            Showing default Intel splash screen:

                             

                            DSCF1366.JPG

                             

                            This is how the problem was resolved. First lot of motherboards were returned.

                             

                            I am thankful,

                            Michael

                            • 11. Re: Flash BIOS update failing on D945GNTL
                              Hellen_Intel

                              Hi,


                              Glad to know that you could do the BIOS update in this Motherboard.

                               

                              Regards,

                              Hellen.