9 Replies Latest reply on Apr 5, 2016 7:57 AM by KeenanRebera

    Unbrick Edison

    KeenanRebera

      Hi, all!

       

      Recently I tried to run this code onto my Intel Edison board:

       

      var mraa = require("mraa");

      var pwm3 = new mraa.Pwm(0);

      var motorB1 = new mraa.Gpio(33);

      var motorB2 = new mraa.Gpio(47);

      motorB1.dir(mraa.DIR_OUT);

      motorB2.dir(mraa.DIR_OUT);

      pwm3.period(0.001);

      pwm3.enable(true);

      motorB1.write(1);

      motorB2.write(0);

      pwm3.write(20);

       

      Just trying to spin a motor connected to its own powersupply through an h-bridge IC.

       

      After making some modifications to the code, the terminal started spitting out some weird stuff and I couldn't connect to the Edison any more over USB/Wifi.

      The power light would flash sporadically when connected and it would emit a clicking noise, overheat, and start to smell.

      I gave it a rest for a while and then tried to re-flash the board.

      When I connect its USB-OTG port to my computer it makes a noise as if it is releasing gas and again starts to smell.

      I'm incredibly concerned about this thing and I am wondering if you guys have any tips as to what might be the problem.

      (I'm using the sparkfun console breakout board for this, btw).

       

      Anything helps. Thanks!

        • 1. Re: Unbrick Edison
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi KeenanRebera,

          There is, indeed, a hardware issue and it seems to be related to the voltage regulator. If you got the Edison and the SparkFun block recently, I recommend you to contact them explaining the issue. The block, and probably the Edison module as well, are damaged; they should help you if you are still under their warranty period.

          I'd suggest trying to re-flash the module but you already tried it. Furthermore, if every time you plug the USB cable the board starts getting hot, I'd say that there isn't much that we can do, so try to contact SparkFun about it.

          Just to know, do you have an Arduino expansion board or a Mini-Breakout board? If so, you could try using the Edison module with one of them to confirm if only the SparkFun block is damaged, or if the Edison module is damaged too.

          Regards,
          Diego

          • 2. Re: Unbrick Edison
            KeenanRebera

            I do not. I contacted Sparkfun tech services and I am currently awaiting a reply. I removed the top connector from the stack and attempted a connection purely from the console port to no avail. I will say, however, that it no longer gets hot or hisses, so I guess this is an improvement.

            • 3. Re: Unbrick Edison
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello KeenanRebera,

              What is the "top connector" you are referring to? Could you please take a picture of your set up? That would be really helpful to understand what you have removed and what the status of your Edison board is.

              Regards,
              Diego

              • 4. Re: Unbrick Edison
                KeenanRebera

                I mean the Sparkfun 'ADC Block' connection to the Edison. This seems to be the only damaged block. It's edison connector and the connector on the edison itself have some noticeable white 'gunk' on the pins.

                 

                Here is a photo of the setup:

                IMG_3924.JPG

                And some images of the damaged pins on the ADC Block female connector and the Edison's male connector, respectively. Note buildup on the right side.

                IMG_3927 2.JPG

                IMG_3926 2.JPG

                Thanks for the attention so far. Trying to get to the bottom of this.

                • 5. Re: Unbrick Edison
                  KeenanRebera

                  One more thing to note:

                       When I plug the edison into my computer, the blue power light on the 'Base Block' (The middle board providing the console / USB OTG connection) turns on.

                       When I try to connect with it via serial USB, XDK seems to think it is an FTDI connection. The connection fails.

                  • 6. Re: Unbrick Edison
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hi KeenanRebera,

                    Did you get a response from SparkFun? The issue seems to be caused by the blocks, and consequently causing issues to the Edison module as well.

                    The Base Block has 2 USB ports; one of them is used to access the Edison's console, which is a FTDI connection: https://learn.sparkfun.com/tutorials/sparkfun-blocks-for-intel-edison---base-block-. You should use PuTTY to access the Edison's console.

                    Regards,
                    Diego

                    • 7. Re: Unbrick Edison
                      KeenanRebera

                      In the XDK, when trying to communicate with the console through a serial connection, it never said (FTDI) on my USBPort select before the issues occurred.

                       

                      Sparkfun has yet to reply to my email, so I guess I'm a sitting duck until then.

                       

                      Thanks for the help. I'll be patient.

                      • 8. Re: Unbrick Edison
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hi KeenanRebera,

                        The Base Block has two USB ports; did you check how they appear in the Device Manager when you connect both of them to the PC? Each USB port is able to power the module, but only one of them should be a FTDI connection.

                        If SparkFun doesn't reply to your email, I recommend you to send a new one just in case the first one wasn't received.

                        Regards,
                        Diego

                        • 9. Re: Unbrick Edison
                          KeenanRebera

                          My Edison has never shown up as a device on my computer during any successful connection. Yes I do understand that the Console port is for serial communication and the OTG port is for USB OTG and for flashing the firmware.

                           

                          Sparkfun has gotten back to me and have asked me to send in both the Edison and the ADC block so they can check it out.

                           

                          Thanks for sticking with this thread and for your patience in trying to help me. I value it a lot. Great customer service here.

                           

                          Have a great one- Keenan