5 Replies Latest reply on Mar 28, 2016 8:53 AM by Intel Corporation

    Data encryption issue on NUC

    Explorer

      I bought a NUC5i5RYH in Jingdong mall several days ago, the product page: http://item.jd.com/1514183.html.

      And added following components:

      Crucial LPDDR3 1600 8G memory

      Kingshare E330 series 120g sata3 SSD

      Seagate 2T 2.5 inch SATA laptop hard drive

       

      Installed Ubuntu server 14.04.4.  When I did whole disk encryption, there was a serious issue occurs! The encrypted data is different from source data after decryption!

       

       

      Here is my step:

      1.Install TrueCrypt 7.1a console x64 version.

      2.Use TrueCrypt create the hole SATA disk as encrypted disk, that is /dev/sdb. Encryption algorithm: AES, Hash algorithm: RIPEMD-160, file system: EXT4.

      3.Use TrueCrypt mount /dev/sdb as /media/test

      4.Mount portable disk as /media/src

      5.Execute this command to copy data: cp -r /media/src/* /media/test

      6.Execute this command to compare source data with copied data: diff -r /media/src /media/test.

       

       

      In step 6, I found that many big files are different. The files are larger than 300MB commonly. Small files are always same. Because the data are GIT repositories, I tried to execute "git clone" to source data and encrypted data, when I cloned the large repository from /media/test to SSD, git told me the the pack is corrupt, but if I cloned same repository from /media/src, it was always OK.

       

       

      I tried to use veracrypt 1.6 instead of truecrypt, the same issue occurs.

      I tried to do same step, but install the same SATA hard disk to PC with same OS, there is no the issue, source data and encrypted data are OK to clone, and diff command thinks they are same.

      I tried to use another disk instead of SATA, the same issue occurs.

       

       

      So, whether NUC has problem on encryption and decryption? What can I do to use TrueCrypt or VeraCrypt?

        • 1. Re: Data encryption issue on NUC
          Lokutos

          This is not the source of your problems (probably), but why do you use truecrypt on Linux using a Linux FS? That doesn't really make sense unless you want to use the hidden container feature (plausible deniability). If you don't need that, LUKS / cryptsetup would be more appropriate. And even if you do I would use the newer veracrypt. Btw, you can also mount both types with a recent enough cryptsetup / dm-crypt, don't know about creation, though.

           

          For your problem: I would first check memory using memtest86+. For memtest86+ you need to boot a BIOS/MBR grub (i.e. select legacy boot).

           

          Also, for copying the data, I would use rsync -a -HAX -hP <src> <dest>. Then you can check the data with rsync -a -HAX -hPnc <src> <dest>. The "c" means use CRCs and the "n" don't copy, rsync will list the files that differ.

          • 2. Re: Data encryption issue on NUC
            Explorer

            Hi Lokutos,

            I tried veracrypt 1.6 and veracrypt 1.7, there is same issue. In fact, I used cryptsetup ever on arm board, but I don't do fully test for crypesetup. I used truecrypt here just because I have used it on Linux or Windows for more than 7 years, it runs very well, I think it's very stable.

             

            I'll try your methods to determine the cause.

             

            Thanks very much.

            • 3. Re: Data encryption issue on NUC
              Intel Corporation
              This message was posted by Intel Corporation on behalf of

              Hello, All:

               

              Lokutos, thank you for the feedback.

               

              Explorer, let us know if the suggestion worked.

               

              Amy

               

              Regards,

              • 4. Re: Data encryption issue on NUC
                Explorer

                Hello, All:

                I have done memory test about 2 hours, it passed and no erros occured.

                 

                So I refunded it to merchant, and merchant send me a new one. I installed same OS and software, then did same test, both truecrypt 7.1a and veracrypt 1.17 works well on new device. I have tested it for 72 hours.

                 

                Maybe the old product has hardware defect.

                • 5. Re: Data encryption issue on NUC
                  Intel Corporation
                  This message was posted by Intel Corporation on behalf of

                  Explorer, thank you for sharing your findings.

                   

                  Yes, it could have been possible that it was a defective unit, but I am glad to hear that you were able to resolve this issue.

                   

                  If you need further assistance let us know.

                   

                   

                   

                  Regards,