1 Reply Latest reply on Mar 18, 2016 2:08 PM by allan_intel

    Updating RST on W10 - error loading language resource

    eCronik

      Hey,

       

      so I'm using Windows 10 64-Bit - updated through 8.1. Now I wanted to change my SATA-Controller from AHCI to RAID. To accomplish that, I had to deactivate that Windows 8/10 WHQL thingy in the BIOS and in Windows set the boot to safe mode, then changed to RAID before it got loaded. In Safe Mode the necessary driver got installed and activated automatically. Restarted, back in Windows my RAID configuration was working properly.

       

      System:

       

      MB: MSI X99S SLI Plus

      CPU: Intel i7 5930K

       

      From my prior installation Intel Rapid Storage Technology "14.6.0.1029" was installed and I saw on https://downloadcenter.intel.com/de/download/25165/Intel-Rapid-Storage-Technologie-Intel-RST-RAID-Treiber that there is the new version "14.8.0.1042". So I downloaded the zip file, extracted and wanted to start "SetupRST.exe". I always get the error: "Error loading language resouce". When I hit "OK" it closes itself. So I googled a lot and found a solution to "unzip" the .exe with 7-Zip. So I get the two .msi files to install and the "media1.cab" file. According to my 64-Bit OS I tried to install "RST_x64.msi". This didn't work. Then I thought I might have to uninstall first - same thing. I get the error with the language resource when trying to uninstall the current version of RST. Tried activating compatibility for prior Windows version what didn't help either for the installation.

       

      I don't think that it is related, but I've downloaded the F6-Floppy-Installation files also - went into the Driver Manager, updated the automatically and newly added device with pointing into the folder containing the files of the F6-stuff. Now that device in my system is called "Intel Chipset SATA RAID Controller" and I assume this is even better than the standard one Windows has used in Safe Mode to make RAID mode possible. Either way, RST and system does still work.

       

      So how can I properly update to the new version?

       

      Furthermore I have the "Intel Driver Update Utility" installed, that doesn't work anymore. I can't uninstall that one also - I don't get a message, no window - it just seems to be doing nothing. I can't uninstall something else then, as it says I have to wait for the previous Uninstallation to finish. But it doesn't.

       

      Just to not leave out any additional information - what else I have installed from Intel:

       

      - "Components of the Intel Management Engine" (translated from German - I assume it might be that in English)

       

      - Intel(R) C++ Redistributables on Intel(R) 64

       

       

      Would be nice to get some assistance on that issue. Furthermore maybe something with which I can automatically update all the Intel stuff? I also had some other official Intel-Update software installed I can't remember the exact name anymore. I did uninstall that as it didn't work either - I guess it was on Windows 8. But that uninstallation worked.

       

       

      Thanks in advance!

       

       

      Regards,

      Tim