1 2 3 Previous Next 141 Replies Latest reply: Sep 4, 2013 12:10 PM by Maki_S. RSS

    NETw5s64.sys keeps on giving me bluescreens

    tomvanallen

      My new Clevo M570TU Montevina laptop has a Intel WiFi Link 5300 AGN with the latest driver running on Windows 7 x64 (13.0.0.107). I get bluescreens several times a day. If I leave the laptop on when I go to sleep, I often will find that it has automatically restarted because of a BSoD sometime during the night. The stop error is 0x000000d1 and I believe the BSoD says DRIVER_IRQL_NOT_LESS_OR_EQUAL refering to NETw5s64.sys.

       

      It seems the BSoD occurs a lot when utilizing the my WLAN connection a bit more than just surfing. That is running 3-4 torrents, streaming Internet radio and surfing at the same time. I use the newest uTorrent client which again uses the latest Java RE (1.8.5 and 6u17). I am at the moment not using any anti virus software.

       

      In addition to the bluescreens, I often lose my WLAN connection. WLAN is however fine on my other laptops. In these cases I get the event ID 5010 referring to NETw5s64 in my in my Event Log. I resolve this issue by disabling and reenabling the WLAN card, but this is very annoying.

       

      I'm starting to think that the driver is faulty, WLAN on Windows 7 x64 is unstable at the moment, or that maybe my WLAN adapter is faulty.

       

      I ran MemTest on my laptop the whole last night without any errors. I am considering trying another torrent client.

       

      Anybody else having these problems? Any tips is highly appreciated as I'm getting fed up.

       

      Update: I've disabled 11n and power saving on the adapter, but it keeps on giving me bluescreens. A Google search shows that this is a common problem with these Intel adapters. It would really be nice if Intel would acknowledge and address these issues.

        • 1. Re: NETw5s64.sys keeps on giving me bluescreens
          hwam

          Same problem with a Dell Studio 1557 wifi 5300 agn. Blue Screen (BSOD) during copying files to NAS. Driver 13.0.0.107, Windows 7 64 bit.

           

          Grt.

          • 2. Re: NETw5s64.sys keeps on giving me bluescreens
            didier3001

            Hi there,

             

            I just wanted to confirm that I got the same BSOD on a fresh install of Windows 7 64 Bits.

             

            Driver: 13.0.0.107

            BSOD error: DRIVER_IRQL_NOT_LESS_OR_EQUAL refering to NETw5s64.sys

             

            Message for Intel: please update your driver or request us more information. I have the dump file and if I can send it to you if you want.

             

            please let us know

             

            Regards,

            Didier

            • 3. Re: NETw5s64.sys keeps on giving me bluescreens
              FSummers

              I've been getting the same BSODs and random network drops for months now with the 13.0.0.107 drivers and Windows 7 x64, running 5300 adapters in HP 8530w notebooks.  For me it's pretty easily reproducible by transmitting >30-40mbps on a LAN and surfing the web at the same time.  It's been happening ever since the first Win7 RC dropped, so it's not as if it's exactly a new problem either.     

               

              I had hoped to see better drivers (or other fix) once Windows 7 was released to retail, but it's been about 5 months now since Intel's last driver update and I've just about given up.  If this doesn't get fixed soon, I'll definitely be looking for Broadcom wireless adapters from now on (I actually would have already ripped out these POS Intel adapters, but they're whitelisted in the 8530w BIOS.)

              • 4. Re: NETw5s64.sys keeps on giving me bluescreens
                tomvanallen

                I have been in contact with Intel Customer Support, and they refuse to give me support since my card is an OEM product. They told me to contact my reseller which I then did, but my reseller told me they don't have a support deal with Intel. I have since tried another wireless router (3COM vs. D-Link), but the bluescreens still came. My reseller is now offering me a replacement 5300 card, which I don't believe in, but maybe it's worth a try...

                 

                I just wish Intel could release a new driver since all the bluescreens people are having are pointing to the driver itself (NETw5s64.sys).

                • 5. Re: NETw5s64.sys keeps on giving me bluescreens
                  hwam

                  My Dell Studio 1557 with wifi 5300 agn is only crashing when the files are going from the Laptop to the network (NAS or PC). I can download files with newsleecher without any problems. Copying to the NAS will give blue Screen. So replacing with another 5300 has no effect.

                  • 6. Re: NETw5s64.sys keeps on giving me bluescreens
                    tomvanallen

                    Yes, I realize that, but that's what my reseller want to try in lack of better ideas at the moment...

                    • 7. Re: NETw5s64.sys keeps on giving me bluescreens
                      iceking66

                      my x200 recently purchased had the same problem.  I tried vista drivers etc.  Same issue when downloading massive files BSOD - Bad Pool Caller.  I reimaged a few times.  I recently restored my image and haven't had a problem with the latest Lenovo/Drivers.  I tried these a few times before also with BSODs happening.  13.0.0.107 9/15/2009.  Vista drivers gave half the throughput but were stable.

                      • 8. Re: NETw5s64.sys keeps on giving me bluescreens
                        FSummers

                        A quick update for everyone having this problem:

                         

                        Microsoft has released a hotfix for BSODs very similar to these, caused be defective power management code.  You can read more over at Ars Technica using the following link: http://arstechnica.com/microsoft/news/2010/02/microsoft-details-windows-7-memory-leaks-hangs-freezes.ars

                         

                        I won't be able to test this until next week, and you should use caution in applying this update as it hasn't been fully tested and might break more things than it fixes, but at least there might be a solution forthcoming (and I might owe one big apology to Intel's driver team.)

                        • 9. Re: NETw5s64.sys keeps on giving me bluescreens
                          tomvanallen

                          Thanks a lot for that one, but unfortunately I have the same problems after the hotfix. :\

                          • 10. Re: NETw5s64.sys keeps on giving me bluescreens
                            FSummers

                            I knew I was forgetting something - updating this thread.  After some testing, the hotfix doesn't work for me either.

                             

                            I did notice a new behavior while testing, though - it seems that the BSODs are much more likely immediately after a "recovery" reboot (regardless of hotfix/no hotfix.)  I managed to get four of them in quick succession by starting some heavy network traffic immediately after rebooting, but things stay stable for much longer if I do a full shutdown/boot cycle after a BSOD reboot.

                             

                            I don't know if that has any relevance to anything, but thought I'd mention it.

                            • 11. Re: NETw5s64.sys keeps on giving me bluescreens
                              Ilenek

                              Intel is aware of this problem and is actively working to resolve the issue. We will update this thread as new information is available.

                               

                              Thank you,

                               

                              IleneK

                              • 12. Re: NETw5s64.sys keeps on giving me bluescreens
                                tomvanallen

                                I just wanted you to know that I just replaced my 5300 AGN with another unit from my reseller, but as I tought, it didn't help.

                                 

                                Anyways, thanks for the update IleneK. Makes things a lot easier when you acknowledge the problem. If there's anything I can do to help just let me know.

                                • 13. Re: NETw5s64.sys keeps on giving me bluescreens
                                  skoskav

                                  I thought I'd post this here since it's a top result on google.

                                   

                                  I've had Dell send me two new 5300s and a technician to replace my motherboard, but this exact problem continued. I asked them to send me a Broadcom NIC also known as "Dell WLAN 1510" and the problems stopped. The card will do as a replacement until Intel fix their drivers. So people who want to use N should demand their OEM to send them another 802.11n-capable non-Intel card with comparable specification. Dell customers should preferably ask for a card named 1520 since it's closer to Intel's 5300 in terms of performance.

                                  • 14. Re: NETw5s64.sys keeps on giving me bluescreens
                                    mojoe

                                    Update to the latest 13.1.x.x driver. It has a fix for all of these issues.

                                    1 2 3 Previous Next