4 Replies Latest reply on Apr 16, 2015 2:18 PM by MicahCatlin

    Intel Dual Band Wireless-AC7260 Desktop and ASUS AC-68U Router problems, troubleshooting

    MicahCatlin

      Several times a day, my 7260 card or driver gets into some bad state, where throughput is extremely bad.  During these times, all other people in my office also experience an almost complete connectivity interruption and start yelling at me to reboot my computer (which usually clears the condition).  I would really like to find some workaround (or proper fix) that would let me keep using this card, because it works well (when it is working).

       

      Here is the relevant state of my machine when "everything is fine".  It doesn't look meaningfully different during the broken state, but I'm willing to collect additional information if an Intel engineer can make specific requests about what to collect.

       

      Router: ASUS AC-68U  Firmware Version: 3.0.0.4.378_4585

       

      $ uname -a

      Linux micahcatlin-computer 3.16.0-34-generic #47~14.04.1-Ubuntu SMP Fri Apr 10 17:49:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


      I understand that there is a newer version of the AC-7260 firmware file which is appropriate for newer Linux kernels (

      3.19+iwlwifi-7260-ucode-25.16.12.0.tgz)

      but I don't want to switch to an unsupported (by Ubuntu) newer kernel unless it is addressing a specific, well-understood problem.


      $ lspci

      00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)

      00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)

      06:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)

       

      $ ls -l /lib/firmware/iwlwifi*

      -rw-r--r-- 1 root root 680508 Dec  1 12:45 /lib/firmware/iwlwifi-7260-9.ucode

       

      $ dmesg|grep iwl

      [    2.624994] iwlwifi 0000:06:00.0: irq 45 for MSI/MSI-X

      [    2.636156] iwlwifi 0000:06:00.0: loaded firmware version 25.228.9.0 op_mode iwlmvm

      [    2.644513] iwlwifi 0000:06:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144

      [    2.644562] iwlwifi 0000:06:00.0: L1 Disabled - LTR Enabled

       

      $ sudo iw dev wlan0 get power_save

      Power save: off

       

      $ iw dev wlan0 link

      Connected to 40:16:7e:58:2c:64 (on wlan0)

        SSID: Artillery

        freq: 5745

        RX: 25826779 bytes (31851 packets)

        TX: 6427084 bytes (17552 packets)

        signal: -42 dBm

        tx bitrate: 702.0 MBit/s

       

        bss flags: short-slot-time

        dtim period: 1

        beacon int: 100

       

      WPA2 authentication

       

      Can anyone from Intel recommend other experiments to help troubleshoot?



      Regards,

      Micah Catlin