1 6 7 8 9 10 Previous Next 200 Replies Latest reply on Jul 30, 2016 3:36 AM by willrun4fun Go to original post
      • 105. Re: NUC Haswell reboots after shutdown
        jst01

        There's something weird with these boxes. I have two identical boxes running the same hardware and the same bios and settings on the same LAN. Both are also running the exact same OS. One works properly with WOL and one doesn't. They were both bought at the same time from the same retailer.

         

        Extremely frustrating! Should we return all NUCs that don't work as 'faulty'?

        • 106. Re: NUC Haswell reboots after shutdown
          jst01

          ....and here's something more unusual that may work to fix the WOL behaviour for some people. When I went through all the differences, I had an autostart.sh script on the working device (I'm running OpenELEC). The script is to enable the onboard IR in OpenELEC. When I put the script on the non-working NUC, magically it's WOL function worked correctly.

           

          I am running a 4th gen i3-based NUC with bios v25. The file autostart.sh is in the /storage/.config directory. The contents of the script are:

          #!/bin/sh

          modprobe -r nuvoton-cir

          echo "auto" > /sys/bus/acpi/devices/NTN0530\:00/physical_node/resources

          modprobe nuvoton-cir

           

          then run:

          chmod +x /storage/.config/autostart.sh

           

          then reboot

           

          In my BIOS, I have enabled the deep S4/S5 with wake-on-lan set as Normal Boot

          • 107. Re: NUC Haswell reboots after shutdown
            JasonHoffman

            Hi all,

             

            For what it's worth disabling Wake on LAN from S3/S4 on the Power menu in the BIOS is what worked for me. I just tried it on a DN2820 (Bay Trail) and a D34010 (Haswell) that were having the reboot issue and it fixed both of them.

             

            Running latest BIOS on both.

             

            Jason

            • 108. Re: NUC Haswell reboots after shutdown
              OllieB

              Hi Jason,

               

              Respectfully I would like to point out that disabling one feature to prevent problems with another cannot and should not really be called a fix.

              • 109. Re: NUC Haswell reboots after shutdown
                KristofVDH

                Disabling WOL from S3/S4 also "fixes" the shutdown issue on my setup.

                 

                My main use of the NUC is as an HTPC with XBMC controlled via Yatse on smartphone/tablet.

                At least I can shut it down now with Yatse instead of keeping the power button pushed for more than 5 secs.

                But I also need the WOL feature to start it up!

                • 110. Re: NUC Haswell reboots after shutdown
                  JasonHoffman

                  OllieB,

                   

                  Fair enough.  How's this: Disabling the WOL feature prevents my NUCs from spontaneously rebooting.

                   

                  Does that work?

                   

                  Jason

                  • 111. Re: NUC Haswell reboots after shutdown
                    Christoph.ger

                    Hi there,

                     

                    Intel NUC D34010WYK


                    Running XBMC Gotham Beta 4


                    Same issue


                    can be "fixed" with disabling WOL


                    best regards


                    Christoph

                    • 112. Re: NUC Haswell reboots after shutdown
                      NUCuserTSG

                      Registered for updates and to say that I have recently purchased a D54250WYK, installed 30GB Intel mSATA and 8GB Kingston ram.  Nothing else is plugged in during tests other than HDMI and Ethernet. Same instant restart problem. At first it was only Suspend (sleep) causing it, until I updated the BIOS to v25, where it started doing it for Shutdown as well.

                       

                      I tried different settings in the power options. Following a recent post here, I disabled all options in the Power section first. Then enabled the 'Deep sleep S4/S5' checkbox - now the NUC behaves as expected. I am not sure if its going to S3 or lower, but I can boot from the onboard IR device with my remote luckily. Now that it works I am too scared to touch any of the options. I am not sure if WOL is set to Stay Off or Normal Boot, and can't check at this moment. I don't actually need WOL though.

                       

                      It's a shame because the computer is really quite amazing. While it now works perfectly for my needs, this should not be as hard as it is. I am now using the latest nightly of OpenELEC as the operating system after testing a few. It certainly seems like a BIOS issue to me.

                       

                      Unrelated but v25 caused my BIOS to display at the wrong resolution on my display. It's not being stretched out as far as I can tell, and is displaying 1:1.

                      • 113. Re: NUC Haswell reboots after shutdown
                        lhill

                        Hi all,

                         

                        For anyone who is experiencing these shutdown issues when Linux is installed, please consider trying the test BIOS at https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23826.

                         

                        We have successfully tested this is our engineering lab but we'd like to get confirmation from NUC owners before we roll it into a production BIOS version for all NUCs.

                         

                        Regards,

                        Lois H.

                        Intel

                        • 114. Re: NUC Haswell reboots after shutdown
                          Vassilis

                          On my nuc... 6 shutdowbs where smooth.

                          I will continue testing

                          • 115. Re: NUC Haswell reboots after shutdown
                            mdgl

                            I have been trying out the new (test) BIOS this morning and it does appear to fix the shutdown/reboot issue in my environment:

                             

                            • Ubuntu 14.04, default BIOS settings
                            • With fixed Ethernet, display, keyboard and mouse connected - shutdown stays shutdown
                            • With no devices connected other than fixed Ethernet - shutdown stays shutdown; WOL can be used to restart

                             

                            Many thanks,

                            • 116. Re: NUC Haswell reboots after shutdown
                              nh88

                              Hi lhill,

                              WYLPT10H.86A (WY4024.bio) Beta works for me.

                               

                              Intel NUC D34010WYK + Logitech K400r wireless keyboard.

                              Thanks.

                              • 117. Re: NUC Haswell reboots after shutdown
                                jason0

                                Wow.. How strange.

                                 

                                I tried the new test BIOS, and it fixed two huge problems which was great,

                                1. When i shut the NUC down with WOL on in bios, it stays shutdown

                                2. When i go to suspend in Openelec, the NUC suspends without instantly waking up.

                                 

                                However, after testing dozens of suspends, and rebooting a few times, for some completely strange reason, both these problems have now come back.. When i shutdown, it turns back on, and when i suspend, it instantly wakes up.. I did not change any BIOS settings or any settings in Linux/OpenELEC. It's completely beyond me. It's like the fixes contained in this BIOS update just stopped working, for no reason whatsoever.. I re-flashed my BIOS with this same version to no effect. I've reset all my BIOS settings to default and re-flashed. Still not working. I simply can't explain why these problems went away for a period of time after i flashed to the beta bios and now have come back without me touching anything.

                                 

                                I'm going to leave the NUC with the power out of the unit overnight, and hopefully in the morning it will be fixed. No idea what happened, why it randomly stopped working, or where to go from here... I'm curious to see if other people have experienced this behavior with the new beta BIOS.

                                 

                                PS: The GUI BIOS in this test BIOS update is crap again - can't use dropdown menu's with a keyboard alone as it seems to lock up. The only way to fix it is by plugging in a mouse and right clicking.

                                • 118. Re: NUC Haswell reboots after shutdown
                                  dCrypt

                                  Lois,

                                   

                                  Can you describe EXACTLY what did the 4024 Beta bios solve?

                                   

                                  I've found no difference in my D34010WYKH NUC (using OpenElec Beta7). I expected to have the sleep problem solved but I still need the sleep.d file fix described here:

                                  http://openelec.tv/forum/107-suspend-and-wakeup/70134-fixing-intel-nuc-s-please-help?start=15#103067

                                   

                                  BR

                                  • 119. Re: NUC Haswell reboots after shutdown
                                    Larryadd

                                    Hi DCrypt,

                                     

                                    The beta bios only resolve the issue of the powercircle when you shut down the nuc with WOL enabled.

                                    Before this bios, you needed to disable WOL to get your nuc shutdown and stay off. Now, you can have WOL enabled. tested it, it works.

                                    I still need the sleep.d trick to suspend my nuc well.

                                    1 6 7 8 9 10 Previous Next