3 Replies Latest reply: Jun 28, 2012 9:32 AM by JFFulcrum RSS

DX79SI won't recoginize optical drives?

Ron Kopald Community Member
Currently Being Moderated

Hi,

I trying to debug an issue with a new build.

I have a DX79SI with an i7 3930

DRAM: Corsair Vengeance 16 GB (4X4)

In the Bios menu, the Plextor DVD RW as well as the SSD both show as being in the proper ports, but when I try to boot I get

"Non bootable device. Insert disk and press any key"

This just gives the same message again. I have tried the CMOS reset by powering down the system, pulling the CMOS battery for one minute and trying again, and I still get the same messgae.

Can anybody help me with this??

  • 1. Re: DX79SI won't recoginize optical drives?
    rbmorse Community Member
    Currently Being Moderated

    Enter the BIOS setup (see your manual) and select the boot menu item.  One of the settings will let you determine the order in which the BIOS attempts to find a valid boot sector on the devices it has detected during POST.  Make sure the optical drive (the Plextor DVD writer) is the first device in this list.

     

    I' don't have a DX79 board on hand so I can't verify this, but the item you're looking for is probably something like "boot device priority."

     

    When you've made the appropriate adjustment, make sure a bootable disc is loaded in the Plextor and then press the "F10" key to save changes to the BIOS setup and reboot the machine.

  • 2. Re: DX79SI won't recoginize optical drives?
    Ron Kopald Community Member
    Currently Being Moderated

    Thank you  for the reply. It turns out I was supplying the BIOS with  a boot drive disc that it didn't want.

    It was looking for Windows to create the partition; thus being then able to recognize the ssd. Everything is up an 100% now. Chalk this one up to vague install instructions and a huge amount of operator error..

    A tiny bit more guidance from the BIOS utility would have been nice, but not necessary. Thank you again.

  • 3. Re: DX79SI won't recoginize optical drives?
    JFFulcrum Community Member
    Currently Being Moderated

    Remind also that is UEFI mode things are different from it was in past:


    - If your HDD/SDD number 0 is clean, your CD/DVD/BD must have a disk with EFI-capable boot loader & OS, i.e. 64-bit Windows OSes Vista and newer, or specially marked Linux distros.


    - If your HDD/SDD number 0 contain a EFI-installed OS, than boot device order in BIOS is ignored by default and installed system always boot instead. To boot from CD/DVD/BD you must either enter to installed OS boot loader utility and select exact drive to boot (drive must also contain EFI-capable boot loader & OS) or fire the BIOS boot menu key (F10 in our case) and select needed drive to boot (use 'EFI shell' marked entries for drives with EFI-enabled OSes and 'BIOS' entries for traditional Live CDs/sticks)

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points