5 Replies Latest reply: Jun 23, 2012 1:09 PM by robertjal RSS

DZ77BH-55K com and lpt1 ports

robertjal Community Member
Currently Being Moderated

Has anyone else noticed that in win7x64 there are com and lpt1 ports that are not available on this board ? it seems the bios reports them or so but the hardware is not available. I've disabled the CIR and PS/2 ports in the bios so it can't be those. None the less if the bios has not disabled CIR then I  still should not see a ltp1 port, the CIR can show up as com but not as lpt1...

i can remove them in device manager but then they show up again when i scan for new hardware

  • 1. Re: DZ77BH-55K com and lpt1 ports
    phil_l Community Member
    Currently Being Moderated

    Hi

     

    Yes I have both a COM port and printer port showing in Device Manager as well.  There is a COM port on the board, there is a header for it somewhere and it is part of the Legacy I/O controller, I suspect the printer port is also part of the same chip but hasn't been disabled, even though I don't think there are pins for a printer port.

     

    They are not causing any problems so just ignore them.

     

    Regards

     

    Phil

  • 2. Re: DZ77BH-55K com and lpt1 ports
    robertjal Community Member
    Currently Being Moderated

    thanks Phil,

     

    I guess this is a bug in the bios then :-(

     

    This board does not have either a com or a lpt1 board according to the tech spec. It has a CIR which is a sort of IR comport but I have disabled that.

     

    I do not believe that ignoring it is the solution. if the MB reports that there is something there but it's not wired properly it can lead to instability. I assume the ports are not initialized properly so there's no telling what can happen. So far everything seems stable though... fingers crossed :-)

     

    If someone from Intel reads this thread, please add this to the list of bugs...

  • 3. Re: DZ77BH-55K com and lpt1 ports
    dislikeyou Community Member
    Currently Being Moderated

    On DZ77GA-70K there is only com port, no ltp.

    dev.png

  • 4. Re: DZ77BH-55K com and lpt1 ports
    phil_l Community Member
    Currently Being Moderated

    Hi

     

    Don't worry it will not cause any instability just because nothing is connected, the same as if you had the com ports and didn't connect anything to them.  The product manual says under the Legacy I/O controller, "Serial port via onboard header", so I presume somewhere this header exists on the board, then again it might not if the spec is wrong.

     

    The printer port may just be a virtual port as part of the consumer infrared headers, i.e. wireless printing, although I doubt many people would use that today.  It is a bug as if CIR is disable it shouldn't be there, so just a BIOS issue I suspect, of which there are many.

     

    Hopefully we will get a new BIOS update for this board soon.

     

    Regards

     

    Phil

  • 5. Re: DZ77BH-55K com and lpt1 ports
    robertjal Community Member
    Currently Being Moderated

    not wired properly and not connected are two different things. There is no rs232 transceiver connected so the pins are probably grounded in the pcb layout (if not connected to CIR) in that case enabling that part could be in violation of the i/o controller's spec. if all are connected to the CIR header and it's just not disabled properly in the bios then i agree it's not more than a nuisance. However i do not know that for a fact so i would like someone at Intel to check if this is a problem or not. don't like my board's lifetime to be cut short because of a little error like this.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points