8 Replies Latest reply: Jul 31, 2012 2:11 PM by baroque-quest RSS

XP Pro 64-bit on DH67BL: sound driver not installed

baroque-quest Community Member
Currently Being Moderated

Okay, I realize that XP has minimal support on DH67 and later chipsets.  That said, I expect basic stuff to work.

 

I have installed lots of Intel motherboards and I know the drill: load the OS and then Intel's chipset, management engine, and NIC drivers from the disc.  Then let Windows Update do its thing.  Then visit Intel's website and install the latest NIC, management engine, sound, desktop utilities, graphics (assuming Windows Update didn't do it), and USB.3.0 (if applicable) drivers.

 

I have a booting disk with XP Pro 64-bit, with the Intel hardware being DH67BL / i5-2500K.  Installation of everything went okay except for the sound driver.  After installing the sound driver, Device Manager has a yellow '!' under "Other Devices -> Audio Device on High Definition Audio Bus".  Clicking on the dialog informs me that "The drivers for this device are not installed. (Code 28)".

 

As I said, I've been here before.  I know to grab the proper driver for the OS, in this case XP Pro 64-bit.  So I did it again: visited intel.com, downloaded the proper sound driver, and installed it.  Still the yellow '!'.  I even tried to have Device Manager search through the DH67BL CDROM to see if that would help, but Windows could not find an appropriate driver on the disc.

 

So am I screwed with respect to the sound driver or is there some trick I need to employ?


More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points