1 2 3 4 Previous Next 48 Replies Latest reply: Mar 26, 2014 8:16 AM by Zem Go to original post RSS
  • 30. Re: Intel(R) 82579V Gigabit Network device issues
    ci_msanchez Community Member
    Currently Being Moderated

    Simon,

     

    Thanks a lot!!!

     

    I had same problem while installing windows sbs 2011 in a motherboard DH61BE which includes Ethernet Gigabit Intel® 82579V. I followed your instructions with a little difference:

     

    1.- I used the drivers that came in the CD with the motherboard.

    2.- The inf file that I modify was:  /PRO1000/Winx64/NDIS62/e1c62x64.inf

    3.- Here you can see lines after the modification, there are some differences in the Intel.NTamdXX.X.X because of win 7 64-bit and win server 2008 64-bit but basically the procedure is just the same that you already explained...

     

     

    ; e1c62x64.INF (Intel 64-bit extension Platform Only,
    ;               Windows 7 64-bit extension and Windows Server 2008 R2 64-bit extension)

    ;
    ; Intel(R) Gigabit Network connections
    ;******************************************************************************
    ;

    [Version]
    Signature   = "$Windows NT$"
    Class       = Net
    ClassGUID   = {4d36e972-e325-11ce-bfc1-08002be10318}
    Provider    = %Intel%
    CatalogFile = e1c62x64.cat
    DriverVer   = 10/28/2010,11.8.81.0

     

    [Manufacturer]
    %Intel%     = Intel, NTamd64.6.1, NTamd64.6.1.1

     

    [ControlFlags]

    [Intel]

     

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00011179

     

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179

    %E1503NC.DeviceDesc%            = E1503.6.1.1, PCI\VEN_8086&DEV_1503
    %E1503NC.DeviceDesc%            = E1503.6.1.1, PCI\VEN_8086&DEV_1503&SUBSYS_00011179

     

     

    Regards

     

    Martin

  • 31. Re: Intel(R) 82579V Gigabit Network device issues
    Togga Community Member
    Currently Being Moderated

    I've got alot of inputs to solve my problem from this tree. But the whole answer isn't here. The answers and tips is for older network adapters that I've got. So if you SBS 2011 installation still don't recognize your intel network adapter do like this.

     

    Use the filetree and find elc62x64.inf. Open it with the texteditor.

     

    Rightclick the unistalled network adpater in the devicelist and click the tab information.

     

    (I only have swedish version so I don't know the english names)

     

    Second option in that list give you the id's of your card and probably thos are missing in the file.

     

    Third option gives you compatible id's that probably also is missing.

     

    I took all of them and added in the file. Just to be shure that SBS2011 installation should find the driver. (I was ****** after trying 12 hours)

     

    And vola, heureka it did. My complete (probably totally incorrect) working list looked like this.

     

    ; Intel(R) Gigabit Network connections
    ;******************************************************************************
    ;

     

    [Version]
    Signature   = "$Windows NT$"
    Class       = Net
    ClassGUID   = {4d36e972-e325-11ce-bfc1-08002be10318}
    Provider    = %Intel%
    CatalogFile = e1c62x64.cat
    DriverVer   = 10/28/2010,11.8.81.0

     

     

     

    [Manufacturer]
    %Intel%     = Intel, NTamd64.6.1, NTamd64.6.1.1

     

     

     

    [ControlFlags]

     

    [Intel]

     

     

     

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&rev_05
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&cc_020000
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&cc_0200
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\cc_020000
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\cc_0200
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00011179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_849c1043&rev_05
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_849c1043
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&cc_020000
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&cc_0200

     

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&rev_05
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&cc_020000
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&cc_0200
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\cc_020000
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\cc_0200
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00011179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_849c1043&rev_05
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_849c1043
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&cc_020000
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&cc_0200

  • 32. Re: Intel(R) 82579V Gigabit Network device issues
    AlexV Community Member
    Currently Being Moderated

    Ups... I did it again... Sorry, I wanted to delete my first message, and as I can see this was the false step, because all the other messages were connected to it.

     

    Someone had answered to my prays (OrangeWing: http://communities.intel.com/people/OrangeWing).

     

    However, here it is once again

     

     

    DRIVER Intel(R) 82579V Gigabit Network (Windows Server 2008 R2 + Windows Server SBS 2011)

     

    http://dc195.4shared.com/download/JNkvfzJe/intel_r__82579v_gigabit_networ.rar?tsid=20120226-171945-e5f9f02d

     

     

     

    Unzip the file, and go to:

     

    APPS/

    SETUP/

    SETUPBD/

    Winx64/

    SetupBD.exe    (double click)

     

     

    I'm terrible sorry, Orange Wings, and thanks again!

    It works perfect...

  • 33. Re: Intel(R) 82579V Gigabit Network device issues
    xsajohn Community Member
    Currently Being Moderated

    +1 for Simon's solution - you're a magician sir!

     

    (Actually I took the gist of his post - the filenames are slightly different in the latest versions, but the crux is to add 1503 lines and remove the lines from Control).

  • 34. Re: Intel(R) 82579V Gigabit Network device issues
    vinayaklm Community Member
    Currently Being Moderated

    Thank you.

  • 35. Re: Intel(R) 82579V Gigabit Network device issues
    Felix Community Member
    Currently Being Moderated

    Thanks a lot!

  • 36. Re: Intel(R) 82579V Gigabit Network device issues
    anli Community Member
    Currently Being Moderated

    Thanks a lot! Poor intel - next board is surely without any intel chipset!!!

  • 37. Re: Intel(R) 82579V Gigabit Network device issues
    Chris Community Member
    Currently Being Moderated

    Hi, regarding your post

     

     

    15.  Re: Intel(R) 82579V Gigabit Network device issues

       Simon Wright  Community Member

     

      

    I am attempting to apply your solution to the case of Windows Home Server 2011 to an Intel desktop board with the 82579.

     

    Can you tell me the appropriate lines to add into the inf file, name of file and name of the folder /sub folders it should be in.

     

    Thanks

    Chris

  • 38. Re: Intel(R) 82579V Gigabit Network device issues
    srw1973 Community Member
    Currently Being Moderated

    Hi Chris

     

    Home Server 2011 is based on Server 2008 so the solution I described should work fine; updating to the current version(17.1) you should download http://downloadmirror.intel.com/18720/eng/PROWinx64.exe and extract with a suitable zip program.

    Navigate to PROWinx64\PRO1000\Winx64\NDIS62 and find e1c62x64.inf when you look in the file you can see that all Intel have done is alter the Server2008 section such that certain network chipsets don't get detected:

     

    [ControlFlags]
    ExcludeFromSelect = \
        PCI\VEN_8086&DEV_1502,\
        PCI\VEN_8086&DEV_1503

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00021179
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_80001025
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00011179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00021179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_80001025
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_04911025

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_00021179
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_80001025

     

     

    What I do above is remove everything from the [ControlFlags] section but leave the header; then you need to look at the next section down, the device you have is in the E1503 section which you can see is missing from the [Intel.NTamd64.6.1] section.

    All you need to is copy the 6 lines with E1503 in from the [Intel.NTamd64.6.1.1] section; you should end up with:

     

    [ControlFlags]

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00021179
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_80001025
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00011179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00021179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_80001025
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_04911025

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_00021179
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_80001025

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00011179

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00021179

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_80001025

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_04911025

     

    Hope this helps

     

    Regards

     

    Simon

  • 39. Re: Intel(R) 82579V Gigabit Network device issues
    KA Community Member
    Currently Being Moderated

    All this time, and it still works! Thank you, kind sir!!!!

  • 40. Re: Intel(R) 82579V Gigabit Network device issues
    Aramis Veras Community Member
    Currently Being Moderated

    Thanks Simon, yet again... still works with 17.3 drivers, since 16.3 are no longer avail from Intel website.

     

    Regards,

     

    Aramis

  • 41. Re: Intel(R) 82579V Gigabit Network device issues
    KVChaitanya Community Member
    Currently Being Moderated

    hi sushoban

     

    recently i bought a dh77kc board, and i installed win server 208 r2 enterprise. when i was trying to install lan drivers it is showing the error : can you please help me. and i downloaded drivers from  Download Center

     

    failed driver.jpg

  • 42. Re: Intel(R) 82579V Gigabit Network device issues
    hbrix Community Member
    Currently Being Moderated

    If your BIOS version is 104, consider updating to v.105.

     

    With BIOS v. 104 the ethernet device of my DH77KC was disabled. With BIOS v. 105 it was re-enabled. It's not mentioned in the v. 105 Release Notes, but seems to be the case nonetheless.

  • 43. Re: Intel(R) 82579V Gigabit Network device issues
    shahjahan Community Member
    Currently Being Moderated

    Hi Simon,

     

    Do you think this driver will work on server 2012?

    if not, would it be possible to modify it for server 2012?

  • 44. Re: Intel(R) 82579V Gigabit Network device issues
    Nematoad Community Member
    Currently Being Moderated

    Simon, you are a genius.  Truly Intel has tried to defeat our abilities to install Server OS's on Desktop boards. I was able to use your edits to install LAN drivers for Windows Server 2008 x32, not R2, just regular Win2008, on an Intel DH77EB motherboard with a 82579V gig lan adapter. Now there is one more thing left. I have a "PCI Simple Communcations Controller" it needs a driver too. Can you recommend a .INF file edit for this one?

    Biff

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points