4 Replies Latest reply: Jun 3, 2012 9:39 AM by Sean RSS

Intel RSTe vs. X79 chipset: stuck in RAID mode, should be AHCI.

zeke009 Community Member
Currently Being Moderated

Using the Intel RST 3.x Enterprise drivers on the cd that came with my board (Gigabyte GA-X79-UD3) I am unable to see my SSD in a few different tools.

 

Searching yielded no solution, but some interesting information.  See post #7 in this thread: http://forums.aida64.com/index.php?/topic/625-aida64-v2001754-cannot-report-the-smart-infos-of-hard-disks-on-intel-x79-chipset/

From the link above:

Thank you for the data. We've done some test runs, and it seems RST Enterprise drivers are unable to provide SMART information for RAID member drives. It may be a driver bug, but we're not sure. We've contacted Intel to ask for assistance. I'll let you know once we have an update to this matter.

 

Edit: we've done more test runs with various RST driver releases to see if SMART calls work with them:

 

- RST v10.5.0.1026: SMART calls work
- RST v10.8.0.1003: SMART calls work
- RST v11.0.0.1032: SMART calls work
- RST v11.5.0.1109: SMART calls don't work

 

- RST Enterprise v3.0.0.2003: SMART calls don't work
- RST Enterprise v3.0.0.3020: SMART calls don't work
- RST Enterprise v3.0.1.7016: SMART calls don't work


So apparently from RST v11.5 and with all RST Enterprise v3 drivers SMART calls do not work anymore.

Can someone from Intel comment on whether or not the functionality will be added?  I can live with out seeing the specs for awhile, but not being able to update SSD's using this chipset could be problematic.

  • 1. Re: Does X79 support SSD/HDD S.M.A.R.T. data?
    zeke009 Community Member
    Currently Being Moderated

    I found someone with the same board as me and they are able to use all those apps that I listed above.  When they open Intel RST Enterprise they see Mode: AHCI on the right, where I see Mode: RAID.

     

    I am not running RAID, in the UEFI section for the Intel controller I have it set to AHCI and I'm running the latest Intel RSTe driver available (3.0.0.3020_PV) from this site.

     

    What do I have to do to get this driver to run in AHCI mode?

     

    IntelRSTe.PNG

    X79-UD3_IntelController.png

  • 2. Re: Does X79 support SSD/HDD S.M.A.R.T. data?
    zeke009 Community Member
    Currently Being Moderated

    The fix is to not use the Intel RSTe drivers.  If you have them installed, remove them and then uninstall the controller and delete the driver.

     

    Big thanks to lsdmeasap over at Mushkin forums for his help.

  • 3. Re: Intel RSTe vs. X79 chipset: stuck in RAID mode, should be AHCI.
    chrfranke Community Member
    Currently Being Moderated

    The Windows version of smartmontools (http://smartmontools.sourceforge.net/) supports Intel RAID via CSMI calls. I added this to smartmontools 5.41 about 1 year ago. Also works in conjuction with the GUI frontend (http://gsmartcontrol.berlios.de/).

     

    The debug output from smartctl.exe might show some info what does no longer work with the new drivers.

    Try running "smartctl -i -r ioctl,2 csmiN,PORT" from an admin console.

     

    Recently one of our users informed us about a "stuck" issue in conjunction with RST:

    http://sourceforge.net/mailarchive/forum.php?thread_name=4F5A8FBE.7050007%40t-online.de&forum_name=smartmontools-support

     

    System may stuck for a short time if a SMART command is issued via the CSMI call of RST. This happens if the SMART command has a longer (100 - 200ms) duration. This is typical for some Hitachi and Samsung HDDs and some SandForce based SSDs.

     

    This problem might be the reason why CSMI_SAS_STP_PASSTHRU is disabled in newer driver versions. This prevents SMART calls to all disks in a RAID configuration. Non RAID disks could probably still be accessed via Windows standard pass-through call (which works without stuck in older drivers).

     

    Any info is appreciated.

  • 4. Re: Intel RSTe vs. X79 chipset: stuck in RAID mode, should be AHCI.
    Sean Community Member
    Currently Being Moderated

    Hi, so the CSMI_SAS_STP_PASSTHRU is not allowed to use in the newer version of RST??

    We're trying to set the Advance Power Management (APM) on RAID configuration.

    We tried to use Smartmontools 5.43 (a test release on Windows) since it supports the APM setting function using CSMI_SAS_STP_PASSTHRU.

    However, the command always return with ReturnCode=4. From the CSMI document, it means "no enough security access".

    I'm not sure if it is because Intel has disabled the using of CSMI_SAS_STP_PASSTHRU or it limits the security access to only get the info from RAID configuration.

    If it is, are there any other ways to access the APM or other settings on RAID configuration!?

     

    Many thanks

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points