7 Replies Latest reply: Jul 12, 2012 12:54 AM by mikez RSS

WiDi connects after booting - but fails after laptop has been on standby

mikez Community Member
Currently Being Moderated

Hello,

 

I am using a Lenovo X220, with an i7-2620M CPU and Advanced-N 6250 AGN wifi adapter. I am connecting to an LG LM6700 television, with WiDi support built in.

 

After days of frustration, I have figured out that WiDi only connects after a fresh reboot.   If the laptop has at any point been on standby, then when I try to connect, it eventually just times out - roughly 60 seconds after the TV prompts to allow the connection.

 

A possibly associated symptom, is that the TV becomes "Blocked" in the My Wifi Utility list of devices.   It's not clear when or under what circumstances it becomes blocked.

 

And finally - a bug that may or may not be relevant - if I set the name of the TV in the My WiFi Utility device list, it gets reset to the MAC address on a regular basis.

 

When it works - WiDi is great - very smooth and useful.  But what a huge pain to have to reboot to get it to work. 

 

I am running the following versions of software and drivers:

Windows 7 Professional SP1

Intel My WiFi Utility:      3.0.13.0

Intel Graphics driver:     8.15.10.2622

Intel WiFi driver:           14.3.1.1

LG LM6700 firmware:     03.09.35

 

Regards,

Mike


  • 1. Re: WiDi connects after booting - but fails after laptop has been on standby
    Var Community Member
    Currently Being Moderated

    Mike, I have X220 laptop with Intel N6205 advanced network adapter and I also tred to connect to my LG LM6700 TV. So far I couldn't go that far... How did you connect (steps)?

     

    The "Intel My WiFi Technology" screen on my laptop gives me 3 options for adding a new device. It's not clear how to use any of them with this TV.

    I guess you didn't add the device (TV) from your laptop, but rather enabled the "Wi-Fi Screen Share" on the TV and let it scan for the laptop?

     

    Please could you explain the steps? Then I will be able to test it too.

     

    Thanks a lot,

    Varsham

  • 2. Re: WiDi connects after booting - but fails after laptop has been on standby
    mikez Community Member
    Currently Being Moderated

    Hello Varsham,

     

    As I understand it, you have to:

    - Enable the WiFi Screen Share setting on the TV

    - Enable the Intel My WiFi Technology on your laptop

    - Run the program called "Intel(R) WiDi" on your laptop (if you didn't install this already, you can find it as item #3 in the table shown on this page)

    - Click on Scan for available adapters  (you may have to do this several times before it sees the TV)

    - Once it has found the TV, click Connect

    - The TV will prompt you to allow the connection, use your remote to accept the connection. 

     

    If you are connecting the two devices for the very first time, there is an additional step where it prompts you for a 4 digit PIN number. Sorry, I don't recall exactly when and how that happens, but it's easy to do.

     

     

    Please let me know if you have the same problem that I described in my original post - where WiDi will only connect properly if the laptop has been rebooted, and will time out if it has been on standby.

     

    Regards,

    Mike

  • 3. Re: WiDi connects after booting - but fails after laptop has been on standby
    MBV2000@intel.com Community Member
    Currently Being Moderated

    On this case the recommendation is to change the power option to not have the system to be on stand by, use the following power options: under the select a power plan heading: check to ensure the balanced radio button is marked and next to the current plan click change plan settings, change the Dim the display by, Turn off the Display, under either / or On Battery and plugged in deadings set update the computer sleep option to a longer time setting.

  • 4. Re: WiDi connects after booting - but fails after laptop has been on standby
    electronicsguy_SP Community Member
    Currently Being Moderated

    try this Mike:

    http://communities.intel.com/message/153604#153604

     

    I have the same problem coming out of standby where the adapter keeps displaying "cannot obtain network address". but this simple workaround avoids rebooting the laptop.

  • 5. Re: WiDi connects after booting - but fails after laptop has been on standby
    mikez Community Member
    Currently Being Moderated

    Thank you ElectronicsGuy!

     

    That workaround worked for me perfectly.  A shame to have to do this every time, but infinitely better than rebooting.

     

    In case the link to the other thread breaks, for the benefit of anyone else with this issue, here is the workaround:

     

    1. Open Control Panel\Network and Internet\Network Connections
    2. Find the wireless connections with the device name:  "Microsoft Virtual WiFi Miniport Adapter".  Note that you may have more than one of these.   You need to figure out which one is related to your Intel WIDI connection. For me, it was the one with the status of "Unidentified Network".
    3. Disable that connection.  After a few seconds you should get a notification in the system tray from Intel My WiFi that it cannot find the adapter.  (If you don't get this notification, try a different "Microsoft Virtual WiFi Miniport Adapter".)
    4. Wait a few seconds, then re-enable that connection.

     

    From this point, your Intel WIDI should be able to connect as designed.

     

     

    For anyone from Intel reading this - note that I have upgraded since the original post, and can confirm this problem still exists in WiDi software version 3.1.29.0.

  • 6. Re: WiDi connects after booting - but fails after laptop has been on standby
    electronicsguy_SP Community Member
    Currently Being Moderated

    good to know it worked. you can also save time by creating a shortcut to the virtual adapter on your desktop. Then you can rightclick on that shortcut icon and disable/enable as needed.

     

    btw, I updated my intel wifi driver to the latest on (15.xx) and the problem is not there anymore.

  • 7. Re: WiDi connects after booting - but fails after laptop has been on standby
    mikez Community Member
    Currently Being Moderated

    Fantastic - many thanks for that tip electronicsguy!  

     

    I can confirm that with Intel Wireless 15.1.1 installed, the problem has gone away completely, with no need for the workaround.

     

    Cheers!

    Mike

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points