3 Replies Latest reply: May 5, 2012 2:16 PM by Syrtap RSS

Intel RST Problems After Disabling Smart Response

regan99 Community Member
Currently Being Moderated

I have an Asus P8Z68-V Pro motherboard with an Intel i7-2600K processor,  using a Crucial M4 64GB SSD drive as a caching disk via Intel RST Smart Response Technology (I have a 1TB WD Caviar Black drive as my "accelerated volume" with my OS, and all data). After initially setting everything up, the system was working great. In order to do some comparisons between using the normal HDD without caching versus with caching, I attempted to disable the SSD caching through the Intel RST interface. After disabling it, and on a subsequent reboot, Windows 7 was unable to boot. I was forced to use the install CD to boot it and to use the Repair option. Now that I have the system booted back up, Intel RST disaplys a message saying the following:

 

"The accelerated disk or volume associated with the cache device is inaccessible, and the overall performance is no longer optimized. Please power off your computer, and then reconnect the accelerated disk or volume. If the device cannot be reconnected, disassociate the cache by removing the logical connection with the missing accelerated disk or volume."

 

Also, as I boot up, the screen that shows my available disks via the Intel disk controller shows the SSD drive as "Disabled" even though it is enabled in BIOS and once the machine is up and running, it displays the SSD drive in both the "Acceleration View" and on the Status page in Intel RST. If I attempt to disassociate the accelerated device, an error message pops up that basically says "an unknown error has occured and the operation failed." By the way, the "accelerated volume" in this case is the 1TB drive that houses the OS and all data, so it is obviously not disconnected or unavailable.

 

How can I get Intel RST to completely remove any settings that make it think the SSD drive is being used for acceleration? Eventually, I want to add Smart Response back in, as it vastly increases perceived performance when it is in use. But for now, I just want to get it working without the SSD caching. Any ideas?

 

And for the record, my Asus P8Z68-V Pro BIOS version is 0501, and the Intel RST version is 10.5.0.1026 which are the latest version I could find (and are in fact recommended to be used together to allow Intel Smart Response Technology to function).

  • 1. Re: Intel RST Problems After Disabling Smart Response
    regan99 Community Member
    Currently Being Moderated

    Well, I tried uninstalling Intel RST and then doing a new install. It made no difference. The SSD drive is stilllabeled as "Disabled" when I boot the machine, and even when running the new RST install for the first time, it already has the Acceleration tab up, and thinks the SSD is associated with an accelerated volume that is not available. Can anybody confirm that they have been able to successfully disable SRT once that had it working? I'm a little bit troubled by the fact that enabling and disabling this feature might put me in a state that requires rebuilding the machine from scratch (or just abandoning SRT, which means that maybe I shouldn't have waited for the Z68 chipset).

  • 2. SOLVED: Intel RST Problems After Disabling Smart Response
    regan99 Community Member
    Currently Being Moderated

    Going into the Intel RST screen at boot (via CTRL-I) I was able to select OPtion 4 "Set isks to non-RAID) and change the SSD drive from a disabled RAID0 caching volume to a non-RAID device. Meanwhile, I left the BIOS setting for my motherboard set to RAID for SATA devices. After this, I was able to boot up, go into the Intel RST software and see that it no longer viewed the SSD drive as in use on an unusable volume. I was able to reestablish Smart Response Technology as I had it before, and everything is working normally now.

  • 3. Re: SOLVED: Intel RST Problems After Disabling Smart Response
    Syrtap Community Member
    Currently Being Moderated

    Drives are connected to SATA ports on your board and they are numbered from 0 to N (where N is the number of SATA ports you have).  The first drive that windows sees during its installation is the drive that has the lowest SATA port number (0, or 1 if 0 is not used, 2 if 0 and 1 are not used, etc).  Windows creates a reserved partition on the first drive it sees and that partition is required to boot your OS later.  If you happen to have your SSD seen as the first drive during the installation of Windows you'll end up with a 100mb reserved partition on it (no drives letter assigned to that partition in Windows)... Which is a reason why ISRT can't later unmount the drive and whipe it off to make it an acclerated drive.

     

    Quick fix is to reinstall Windows with the SSD disconnected, or move the ssd higher in the SATA chain.  If someone knows how to relocate the 100mb rserved partition on another drive and make Windows use it, well that would be another solution.

More Like This

  • Retrieving data ...