4 Replies Latest reply: May 29, 2012 12:54 AM by Damon MacMahon RSS

    Intel HD 3000 Graphics Driver Issue


      Hello, I've always had an issue with my intel hd 3000 graphics where I would experience screen freezing until I disabled the driver. Everything works fine if I use a video card and have the intel hd graphics disabled. Recently I had to sell my video card so I tried using the hd 3000 graphics again but same issues occur.  Everything is fine in safe mode or when I have the driver disabled.  I've tried reinstalling, and updating it to the new and old drivers but the same issue still occurs.  I've also updated my motherboard's bios, but nothing has help.  I was wondering if anyone would know what I can do in this case? 


      The parts I'm currently running on:


      CPU: Intel i7-2600K

      Motherboard: Gigabyte Z68A-D3H-B3



      Heres a picture of how it is.  It usually happens after I login or somtimes even during the login screen.  I can't click or do anything, only thing I can do is reset my computer or turn it off.


        • 1. Re: Intel HD 3000 Graphics Driver Issue

          Hi there!


          Let's see if I can help on this matter.


          What is your operating system version? Also, reply with the version of your current graphics driver version; do not forget to add if your operating system is 64 bit or 32 bit.




          • 2. Re: Intel HD 3000 Graphics Driver Issue

            Windows 7 Professional 64 bit     


            The latest driver version I installed was



            • 3. Re: Intel HD 3000 Graphics Driver Issue

              I'm guessing not much people know how to deal with this?  After looking at some old threads some people seem to claim it can be a faulty cpu.  Can this be it? Everything works perfectly, its just the graphics.

              • 4. Re: Intel HD 3000 Graphics Driver Issue
                Damon MacMahon

                I am having a similar problem, I run an intel I3 2310m laptop using the HD3000 graphics. I recently upgraded my ram from the factory 4gig(2x2gig) to a pair of corsair CMSO4GX31A1333C9 4gig sticks. Since then, i have had the same graphics issues as above, although its only when I try to run a 3d game. I can browse the internet and watch videos fine. I have upgraded all my drivers and also my mobo bios to latest version, since I am having these issues I have reverted back to 4gig of ram and I can run all games fine (diablo3 included) I am also running a 64bit version of windows 7 home premium