1 2 3 4 Previous Next 58 Replies Latest reply: Jul 19, 2013 1:03 PM by snoopz1 Go to original post RSS
  • 45. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    freestyler.bk Community Member
    Currently Being Moderated

    I started experiencing lower signal quality and sudden disconnects after I upgraded to firmware 14.2.0.10. The solution was simple. I have downloaded and installed version 13.5.0.6. Everything works well again.

     

    Laptop:Lenovo ThinkPad T400

    Wifi: Intel(R) WiFi Link 5100 AGN

  • 46. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Wordpainter Community Member
    Currently Being Moderated

    I was having a similar problem with only two of the 5 machines on my network. Rolling back the software didn't help. My problem was cured when I replaced my Linksys WRT160N router with a Netgear WNDR4500N and connected on the 5G band. All the problems dissapeared. Maybe it's coincidence, but though the speed is slightly slower, the signal is rock solid. Expensive solution, but in my case I needed to replace the router because the Linksys was beginning to fail. (vanishing signal, difficulty getting iinto the control interface and repeatedly asking for ID authentication even after being logged in. Don't know if this helps anhyone, but it is additional info.

  • 47. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    walker1088 Community Member
    Currently Being Moderated

    I too had similar problems.  at first the adapter wouldn't even recognize any wireless networks at all.  i disabled then re-enabled from the device mgr and that worked...for  a few months anyway.  then it started doing the same thing again, couldn't find any networks.  I've tried uninstalling the old driver and installing the newest one (14.2) to no avail.  last week i ordered a brand new wifi 5100 card.  after installing the new card (it's very simple to do), it now recognizeds the networks and i can connect but it still drops the connection periodically.  this leads me to believe that this is a software and not a hardware problem since i'm still experiencing some of the same issues with a brand new card.  I may try to find a different brand of internal wireless card since i don't like the usb ones filling up my ports.  hope this helps a little.

  • 48. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Wordpainter Community Member
    Currently Being Moderated

    I rolled back to the earlier version of the software but that sdidn't help. The new Netgear WNDR4500N solved the problem and gave me better distance signal strength with a solid signal on 5G. The gigabit wired connections on the 4500 do tend to drop onece in a while but haven't proved too troublesome, so far. I'm hoping router software updates will eventually fix that problem,

  • 49. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    manjanna Community Member
    Currently Being Moderated

    I tried everything mentioned out here and some other forums too, nothing worked for me. I was not inclined to use a usb adapter, with something sticking out always and not to mention the discomfort putting the laptop in a carry case. Also, the discomfort of carrying it where ever I move. So, I ordered intel 5100 512AN_HMW, which is the internal wifi adapter for my dell studio 1555 laptop, from ebay for $17 and installed it myself. Touch wood its working fine now.

     

    Its a hardware problem. With so many people having this issue, Intel should do something to help end point users.

  • 50. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Wickham Community Member
    Currently Being Moderated

    See if your symptoms the same as follows:

     

    Event ID 5002 (many) followed by 5005. Tried updating driver. Newer ones would hang the adapter causing re-boot to reset it; older ones would recover, but still 5002's and 5005 in the log. Only happened when streaming (like watching a ball game, etc.). Bought a Mini USB-connected wireless N adapter for $10 and the problem(s) went away - must be in the adapter or driver(s), I thought! Continued searching for answer (techies do this by nature). 'net searches on OEM sites and general showed MANY folks having same/similar problem with Intel wireless adapters. Decided to try enabling/disabling stuff in my router. Noticed an option for WMM. Researched it on the 'net. Seemed to only apply to streaming, and other bandwidth-hogging xmissions. Was advised that WMM is sometimes called Ad Hoc Qos Mode. Disabled it in the router (Was called WMM there). Found Ad Hoc Qos Mode option under the Advanced Tab in the Configuration Option for my 4695AGN adapter. Changed it to WMM disabled! Re-booted and did some streaming every day for 3 days. No more symptoms! Changed everything back just to check! Within 15 minutes 4695AGN hung while streaming! My driver is ver. 13.4.0.139, which is current distribution for W7 64-bit. I am soooooo happy! Hope this will help you not to go through a month of maddening trials, or throwing out a perfectly good adapter! I still think the driver is not handling something properly with WMM, because the older ones (12.0... and below) keep working without hanging, although you still get a boatload of 5002,5's every 1 - 60 minutes in your System event log!

     

    P.S. I am NOT saying this is your problem; but it sure fixed mine!

  • 51. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    slesae62 Community Member
    Currently Being Moderated

    I had the same problem with my wireless card. I even went out and bought a new router until I read someones message to fix the problem.

    It was very simple.

     

    It was the power management settings causing the problems.

     

    * Go to computer and right click it. Click on manage.

    * Go to Device Manager

    * Click on network adapters

    * Right click your Wifi Link 5100 AGN, then properties and go to power management. Make sure the

    (allow the computer to turn off this device to save power) is turned off.

    * Go to your ethernet NIC, right click it and do the same.

     

    Your wireless will work fine once again.

     

    It took me weeks to find this out.

     

    Steve

  • 52. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    RM Community Member
    Currently Being Moderated

    I tried the power management solution, figuring it was too good to be true having read all the postings in this forum. It worked for about ten minutes and then dropped the connection.

     

    I'm inclined to believe that this is a physical problem with the 5100 AGN card because it often diconnects when the computer (laptop) is grabbed and moved. But it still isn't that easy to pin down as it disconnected on me once for months at a stretch (I have a USB plug-in as a workaround) and then suddenly came back on.

     

    It's been more than a frustrating problem and if someone were to build the perfect incarnation of "planned obsolescence" I'm beginning to thik they could do worse than to study this card. It never dies completely, doesn't respond to any setting changes, and apparently fails over a wide range of settings and machines. And by now Intel has to be aware of it .. so thanks guys.

  • 53. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    RM Community Member
    Currently Being Moderated

    Following up on my above post, my wireless connection did drop shortly after I switched the power management selection to the setting you recommened. But then I restarted the computer and it's hung tough all day. (I've been careful about the manner in which I move the laptop as I still suspect it's a physical problem with the card.) I've had it work for stretches like this in the past and then cut out again, but it's been on all day so I'll keep my fingers crossed.

  • 54. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    slesae62 Community Member
    Currently Being Moderated

    Just checking if your wireless card was not the problem.

     

    Make sure your power management is not set to conserve energy.

     

    Steve

  • 55. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    RM Community Member
    Currently Being Moderated

    I've determined that it was/is both a physical problem and a settings problem. When I changed the settings to not allow the wifi to shut off to conserve energy, this did help considerably. Now the 5100 will come on and stay on .. *unless* the laptop is moved in some way beyond carefully grabbing it by the edges. If I grab certain corners on the laptop the wifi will disconnect and the adapter isn't recognized until I restart the machine. I have a Lenovo X200. Somebody mentioned this a long while back on this thread. So the problem is improved, but the wifi card is still delicate and disconnects easily.

  • 56. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    RM Community Member
    Currently Being Moderated

    Someday, probably when I'm about ready to toss this laptop, somebody will explain what's up with the 5100 AGN to me. I followed the suggestion of one of the above posters and went to device manager and unchecked "allow computer to turn device off to save power". For the first time in months the wireless card came back to life, and except for occasionally shutting off when I moved the computer, it worked better than it had in a long time. Then, a few days ago, it myseriously shut off again. I even opened up the laptop to take a look at the device, check for loose connections, etc .. everything looked fine. Now, after the thing working for for a long stretch of weeks, it will come on when I boot up and then cut off (and disappear from the 'network device' list) with the slightest movement. It's like it's got a life (and mostly death) of its own ..

  • 57. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Tony Community Member
    Currently Being Moderated

    Dear Kostas

     

    Thank you , thank you , thank you!!!!!!!!!!!

     

    I have been suffering with drop out for about a year now, I never knew why it started and I couddl never work out why is it was always spasmodic

     

    After recent issues were I could not even stay on-line for more than a minute and the computer was close to being ejected out of the window I found this forum and your suggestion

     

    At first though it was the router so I changed the channel to another that was not being used in the area and it still did not work so i googled the issue and found it was not just me

     

    I went into the router and disabled the 'n' type and since then, I have not had an issue!!! It is always connected , no longer do I have to reset the adaptor every few minutes.

     

    I am sure from what other people have said once I leave  the comfort of my own home I will continue to suffer but....I found in work it was great , very rarely dropped out but in hotels and other places it was a nightmare, we will see as i can not see how i do it in my computer yet to disable it

     

    I also updated the driver from Intel as per another suggestion, I should have waited to see if your answer was the item that solved it, but really I think it was as I managed to download the new driver without a drop out and only an hour before that would have been impossible

     

    I believe it was the windows up dates last week that made the problem worse. I am on Vista and i updated a lot and since then it went really bad

     

    So for me it worked !!

     

    thank you again ,

  • 58. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    snoopz1 Community Member
    Currently Being Moderated

    obviously, this is not hardware problem.

    this is how I fixed my problem on Sony VAIO notebook with intel WIFI link 5100agn

    reading through this post from beginning, give me some idea below


    1. some router did not implement "Power save polling" correctly
    Intel´┐Ż Wi-Fi Products — Power save polling (PSP) causes connection issues with access points
    .

     

    2. some router have WMM problem, upgrade router firmware or disable WMM on intel wifi 5100 fix problem
    explain by Wickham http://communities.intel.com/message/153318#153318

     

    3. some power management setting cause problem with intel wifi 5100
    http://communities.intel.com/message/153458#153458

     

    The combination of above solution + update latest driver from intel website 
    then  run "netsh winsock reset"   fixed my problem.
    maybe because some update between microsoft and hardware driver causing problem in TCP/IP stack
    and run "netsh winsock reset"   fix those problem.

    http://communities.intel.com/message/196618#196618

     

    Today, I notice that when I plug-in power cable to notebook, wireless problem come back again. (it was fine when running on battery)

    go to control panel ---> power option --> change plan setting ---> change advance power setting ---> wireless adapter setting ---> power saving mode --->  both "on battery"  and "plugged in"  : change setting to "low power saving"  or something that isn't  "Maximum performance"

     

    "Maximum performance" setting cause Intel WIFI 5100 to hang and disconnected.

1 2 3 4 Previous Next

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points