1 2 Previous Next 22 Replies Latest reply: Sep 26, 2012 6:54 AM by Neil Judell RSS

X79 SMART not enable

mic Community Member
Currently Being Moderated

Hi

 

Just installed a new system with a gigabyte GA-X79-UD3 mobo and a Intel 520 SSD.

 

My SSD toolbox won't run the optimizer and also says that SMART is disable.

 

I can't see anything about SMART in the BIOS.

 

How do I get this running?

 

Best regards

Mic

  • 1. Re: X79 SMART not enable
    parsec Community Member
    Currently Being Moderated

    You may have your 520 connected to the Marvell 9172 (Ugh!!) SATA interface, and not the Intel SATA interface. The SATA ports on your board are different colors, and you need to check which color belongs to what SATA interface, and determine where your 520 is connected. Once you figure that out, we can take it from there.

     

    Also, what SATA mode are you set to on each of those different SATA interfaces, and what drivers are you using with them?

  • 2. Re: X79 SMART not enable
    mic Community Member
    Currently Being Moderated

    Not connected to Marvel.

     

    All sata are to ahci ( correct spellig? ) in the bios.

     

    I've installed all the driver for the disk coming together with the mobo.

  • 3. Re: X79 SMART not enable
    mic Community Member
    Currently Being Moderated

    I've located the problem.

     

    It's the "Intel Rapid Storage Technology Enterprise" driver which is on the driver cd for the Gigabyte motherboard.

     

    As soon as this is installed the toolbox reports, SMART feature not enable.

     

    The driver is version 3.0.0.1112. Have also tried with version 3.0.0.3020 but same problem.

     

    Strange that Intel makes a driver which screws up its own programs.

  • 4. Re: X79 SMART not enable
    CarWiz Community Member
    Currently Being Moderated

    There are two different controller drivers for that board. One Intel for the drives connected to the PCH controller and one for the Marvell controllers. Intel RST supports drives connected to the PCH controller (Intel). Verify you have connected the drive(s) to the correct SATA ports. Advanced Host Controller Interface (AHCI) is a drive communication standard and is available on both brands of controllers. AHCI has nothing to do, per say, with WHERE the drive is installed. But you must have the drive(s) connected to the PCH controller to use IRST for those drives. Drives that are connected to the Marvell controllers will use Marvell and/or Gigabyte software. (Whatever that may be.)

     

    Here's a list of chipset supported by IRST:

    http://www.intel.com/support/chipsets/imsm/sb/CS-020644.htm

  • 5. Re: X79 SMART not enable
    mic Community Member
    Currently Being Moderated

    My 520 disk is connected to the SATA3 port controlled by the Intel chipset. I don't use the Marvel controller.

     

    Bios is set to AHCI. The SSD Toolbox works perfect until I install the IRSTe ( Enterprise ) driver, as long I'm running with the standard Windows 7 driver there's no problem.

     

    I've tried to install the normal IRST ( non enterprise ) but this is not allowed on the X79 motherboard.

     

    After installing IRSTe the SSD drive is seen as a SCSI drive instead of a IDE and therefore no longer supported by the Toolbox.

     

    So Intel has a problem here.

  • 6. Re: X79 SMART not enable
    DooRules Community Member
    Currently Being Moderated

    This has been an issue since day one with the 520 series.

     

    I think they will be dropping these E drivers all together, they seem to bring nothing but issues to the table.


    I load the 11 series IRST driver thru the device manager, this gives me IRST driver with FULL Intel toolbox functionality. Ha Ha Intel, got around your silly E driver, and much better performance also, geeze who would not want that.

  • 7. Re: X79 SMART not enable
    mic Community Member
    Currently Being Moderated

    Dave: Are you also using a X79 board?

     

    Which driver exactly did you download?

     

    I've tested this one which works quite well.

     

    AHCI: Intel® Rapid Storage Technology Driver for Intel Desktop Boards

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20913&ProdId=2101&lang=eng

     

    File name:
    f6flpy-x64_11.0.0.1032.zip
    Version:
    11.0.0.1032

     

    And then manually selecting this one:

     

    Intel(R) Desktop/Workstation/Server Express Chipset SATA AHCI Controller

  • 8. Re: X79 SMART not enable
    DooRules Community Member
    Currently Being Moderated

    Yes, I am on an Asus RIVE X79, love it.

     

    I am running the 11 series driver, the same one you linked to, just a little bit of a procedure you need to go through to get it to load.
    http://i546.photobucket.com/albums/hh423/doorules/Capture-114.png

  • 9. Re: X79 SMART not enable
    J.C. Community Member
    Currently Being Moderated

    I have an ASUS Rampage IV Extreme motherboard (X79) and Windows 7 Ultimate 64-bit and I was getting the same problem... the toolbox did not identify my Intel 520 drive with the Intel RST enterprise (RSTe) even with the updated driver 3.0.0.2003 (RSTe_V3002003_XPWin7) and software that I downloaded from the ASUS site. The drive said "Unknown 240GB", S.M.A.R.T. was not enabled (the SMART Summary said it could not report anything because SMART was disabled), and I couldn't run the optimizer. Plus I was also getting really poor performance, and system hangs under heavy load (with 4 threads copying files to the drive, or deleting files from the drive, anything needing to touch the drive would freeze for 10-30 seconds at a time). And the performance was only about half of what it should have been under normal usage (it was slower than a 7,200 RPM WD black drive for my software builds).

     

    So, after reading this article, I upgraded to the 11.0.0.1032 by going to the Device Manager -> Storage controllers -> Intel... and updated it from the link above. I installed from the f6flpy-x64_11.0.0.1032 archive, from the iaAHCI.inf file, and selected the "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller" and it installed correctly. After rebooting the toolbox works great and the drive performance was better... still a few hangs but only for a second or less at a time. However, now my Intel RSTe software no longer works. I get an error message from the Intel Rapid Storage Technology enterprise (RSTe) program IAStoreUI.exe:

     

    Window Title: Intel Rapid Storage Technology enterprise

    Error Message: An unknown error occurred while running this application. If the problem persists, please restart your computer or try reinstalling the application.

     

    I'm guessing this is because the RST enterprise (or RSTe) software is not compatible with the regular (non-enterprise) RST 11.0.0.1032 drivers. However, when I try to run the software install to install the regular RST software, STOR_Vista_Win7_11.0.0.1032_PV, I get an error message from Setup.exe:

     

    Window Title: Error

    Error Message: This computer does not meet the minimum requirements for installing the software.

     

    So, it appears I have my choice of having either the Intel RSTe drivers and software that works but with really poor performance and no toolbox, or use the RST 11 drivers and have the toolbox work and good performance but the RST software not working.

     

    Thoughts?

     

    I would hoping we will either get a version of the RST 11 drivers that work with the X79, or they'll port all the fixes/changes from the 11 drivers over to the RSTe drivers. Does anyone from Intel have an idea on what the plan is? The RSTe 3.0.0.2003 drivers are really unusable in their current state... makes the SSD slower than a traditional hard drives and those 10-30 freezes are unbearable: we all know Windows is really bad when the drive freezes (lots of programs just hang up and don't respond to anything while the drive is hung).

     

    -J.C.

  • 10. Re: X79 SMART not enable
    DooRules Community Member
    Currently Being Moderated

    You are 100% correct sir, you have to choose whcih you want, Intel says we cannot have both working at the same time, at least not yet, lol.

     

    But with performance so much better with the 11 series it's no contest really. When I rarely need to do something with the IRST CP I just reinstall the E driver, do what I must and then go back to the 11 series.

  • 11. Re: X79 SMART not enable
    t53186 Community Member
    Currently Being Moderated

    Well I was skeptical and more cautious than need be by waiting to load the V11 drivers. While I am pleased the drivers information shared works well I am disappointed with Intel.  It is a shame considering the research, time, and money spent before building my latest machine only to find to "almost" make it work as advertised a workaround needed to be used.  I appreciate many times we do what is needed to get the results we want, but really...Extreme board with server chipset top of line line hex core, latest 240GB drive and I need to roll back to a driver not even supported by Intel.

     

    OK I'm done.

     

    Thank you Dave, Parsec, and others for contributing to this thread and being patient with my reluctance.

  • 12. Re: X79 SMART not enable
    ulvi Community Member
    Currently Being Moderated

    How did you guys manage to install the 11.0.0.1032 driver?

    I have a Gigabyte X79-UD5 board with an Intel 520 180GB SSD; and the

    only drivers (Win 7 64 bit) I can install are the generic Windows driver (in

    which SMART features are enabled and the toolbox works fine), and the

    "Intel C600 Series Chipset SATA AHCI Controller" driver 3.1.0.1085 (from

    April 24 2012) in which SMART is disabled.

     

    If I point the device manager to the folder containing the 11.0.0.1032 driver, Windows

    simply refuses to install it as an upgrade to either the generic windows

    driver or the recent AHCI driver.

     

    Any help much appreciated...

     

    Ulvi

  • 13. Re: X79 SMART not enable
    t53186 Community Member
    Currently Being Moderated

    You will  get a warning message stating the device driver is not recommended because windows cannot verify that it is compatible with your hardware and a question do you want to continue installing this driver? select yes and restart.  Trust me it works. And if you want to change back let windows intall the driver automatically then restart

  • 14. Re: X79 SMART not enable
    ulvi Community Member
    Currently Being Moderated

    I don't get the warning message; instead windows simply says "you already have the

    best driver installed" (I'm paraphrasing), and refuses to install the update or give me the

    option to decide what is best

     

    Is there a way to overrride this behavior?

     

    thx

1 2 Previous Next

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points