8 Replies Latest reply: Jan 5, 2012 5:59 PM by MARK HANNA RSS

ixgbe driver related PSOD in ESX 4.1

jud.barron@silabs.com Community Member
Currently Being Moderated

Hello everyone,

 

I've been working with VMware support for some time now trying to get some progress made on a PSOD we had with an ESX 4.1 host.  VMware's fault team / engineering can't say exactly what went wrong but they claim it was ixgbe related.  This case has been open for almost two months now and I'm hoping that I can get someone from intel to help escalate this issue on the intel side.

 

Here's the information they've provided me from the PSOD analysis:

 

From the backtrace:

3:04:01:55.202 cpu6:4330)0x417f80757eb0:[0x418019792d6c]ixgbe_configure@esx:nover+0x73 stack: 0x41000fe86270, 0x41000fe86270

3:04:01:55.203 cpu6:4330)0x417f80757ed0:[0x418019794195]ixgbe_up@esx:nover+0x10 stack: 0x41000fe86270, 0x0, 0x417f80757f90,

3:04:01:55.204 cpu6:4330)0x417f80757ef0:[0x4180197942c6]ixgbe_reinit_locked@esx:nover+0x8d stack: 0xa5cf6c000001006, 0xfe823

3:04:01:55.205 cpu6:4330)0x417f80757f90:[0x41801966c1c0]vmklnx_workqueue_callout@esx:nover+0x11b stack: 0x417f80757ff0, 0x41

 

From the logs prior to the crash:

3:04:01:55.082 cpu14:4169)<3>ixgbe: ixgbe_netqueue_ops: Unhandled NETQUEUE OP 16

3:04:01:55.083 cpu14:4169)NetPort: 2232: resuming traffic on DV port 1757

3:04:01:55.083 cpu14:4169)NetPort: 982: enabled port 0x4000005 with mac 00:00:00:00:00:00

3:04:01:55.083 cpu14:4169)<3>ixgbe: vmnic7: ixgbe_alloc_tx_queue: allocated tx queue 1

3:04:01:55.083 cpu14:4169)<3>ixgbe: vmnic7: ixgbe_alloc_tx_queue: allocated tx queue 2

3:04:01:55.083 cpu14:4169)<3>ixgbe: vmnic7: ixgbe_alloc_tx_queue: allocated tx queue 3

3:04:01:55.083 cpu14:4169)<3>ixgbe: vmnic7: ixgbe_alloc_tx_queue: allocated tx queue 4

3:04:01:55.083 cpu14:4169)<3>ixgbe: vmnic7: ixgbe_alloc_tx_queue: allocated tx queue 5

3:04:01:55.083 cpu14:4169)<3>ixgbe: vmnic7: ixgbe_alloc_tx_queue: allocated tx queue 6

3:04:01:55.083 cpu14:4169)<3>ixgbe: vmnic7: ixgbe_alloc_tx_queue: allocated tx queue 7

 

I've highlighted the vmkernel log entry that looks suspicious to vmware support and I agree with them.  I get these other messages a lot from ixgbe about tx queue allocation so I think they are fine.

 

We do not have any ixgbe module options passed to the driver.  I'll post back with the specific driver that was running as I dont have that detail in front of me right this moment.

 

If I should be posting this elsewhere please let me know.

 

Thanks!

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points