1 2 3 4 Previous Next 58 Replies Latest reply: Jul 19, 2013 1:03 PM by snoopz1 RSS

Intel WiFi Link 5100 AGN problem - disconnecting

billh Community Member
Currently Being Moderated

I'm having a problem that just started with my 2 year old laptop.  The Intel WiFi Link 5100 AGN adapter keeps dropping connection.

 

On my laptop there is a light that shines blue when connected and orange when not connected.  I boot the computer and the light will be blue.  After awhile it switches to orange.  I go into device manager and disable the adapter and re-enable it and it works fine for a bit and then disconnects again.  A few weeks ago it was disconnecting one or two times a day.  Now it is disconnecting as often as every minute or two.

 

Sometimes when I go into device manager the adapter isn't even listed.  I try scanning for hardware changes and sometimes that will find it and I can re-enable it.  Sometimes the scan will not find it and all I can do is re-boot.

 

I have tried using the latest version driver from the Intel site (13.4.0.9) and that has the same problem as the version that is the latest on my laptop vendors site (13.0.0.107).

 

I have not made any changes in the last 12 months to my wireless network settings in the router or on the computer.  There are three other laptops in the home which work just fine and never drop connection.

 

Any help would be appreciated.

 

Thanks,

 

Bill

  • 1. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    jimsing59 Community Member
    Currently Being Moderated

    I have the same problem and the only solution is a reinstall of Windows. 

  • 2. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    I really don't think that will do any good... I think it is a problem  with the 5100 AGN and its drivers.  I fixed the problem this morning.  I  went to Frys, bought a USB wireless adapter, disabled the 5100 AGN,  installed the drivers for the new adapter and I've been going fine with  no dropped connections for a couple of hours.  The cost?  $39 and a  gallon of gas.

  • 3. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    I have the same problem.  I am using a new Linksys E2000 router and have a PRO 2915ABG wireless card.  I have downloaded the most updated drivers but that did not fix the problem.  The ironic thing is that I did not have this problem with my old router (linksys WRT54G).  Sorry I was not able to help but I am interested if you get any good suggestions.

  • 4. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    I have had the same issue for months! with this wireless adaptor. My laptop is an HP Probook 4411s of a little under 2 years.  A few days ago, I re-installed Windows 7 and it was fine until yesterday after a large number of Windows 7 updates were installed. I decided to find a fix for it this time. Updating latest drivers didn't solve it. I suspected the problem might have lied in one of the updates. I spent literally hours removing as many updates as possible. When the device isn't listed, it doesn't even show in BIOS, also updated to the latest downloaded from HP. I have switched to Windows 7 64bit recently. I don't remember I had this with Windows 7 32bit. However, I didn't use wireless as intensively on this laptop as now.

     

    It is either the product is faulty, which has been out of warranty in my case, or Windows 7 64bit is showing what it is once again. Luckily, I have a Mac book pro.

     

    I am going to give it up myself. Get a USB wireless adaptor if you need to connect wirelessly.

  • 5. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    And I thought I had a crappy router, as the wireless kept dropping and I had to restart the router once, twice a day. Now I still have the same problem with my new router... I've had this laptop for over a year.. How is it possible that there isn't a fix for this  problem yet??? Frustrating!

  • 6. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    RM Community Member
    Currently Being Moderated

    Yes, this is a persistent and prevalent problem and having had it for at least a month I've yet to find the correct solution. I've tried all driver updates. My connection can stay on for as little as a few minutes and as long as several hours at a stretch, and when the 5100 disconnects my only solition is a restart. The profile appears nowhere and the device isn't listed until I reboot.

     

    It worked fine for over a year. It's difficult to imagine that this is a physical problem with the device as opposed to related to some kind of software update or incompatability issue .. too many people have logged in with the same complaint after having the thing work fine for a long while out of the box.

  • 7. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    Just an update.... I bought a USB wireless adapter on 1/25 and haven't had a single disconnect since then.  Problem solved.

  • 8. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    I have no doubt that using an external USB wireless device will solve the problem. But I would prefer to exhaust all possibilities for fixing the onboard card. Particularly since the 5100 worked perfectly well for a solid year before showing problems. It would seem connected to an update or compatability issue. And it's definitely this card, as no other devices using the hub lose connection. Most frustrating is the aspect of having to restart the machine, sometimes several times, to locate the device. I find it hard to believe that someone at Intel hasn't identified the specifics of this problem, with so many users complaining about the same thing.

  • 9. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    -hi,

     

    I am 100% sure this adapter model is defunct in some way. I have (like 1000 other people) experienced the same problems.

    I have 8 computers connected to my access point - and ONLY the 1 with  Intel WiFi Link 5100 AGN drops out every few minutes.

     

    This particular pc has both Win7-32 and Linux parttions and the problem is exactly the same on both OS's. Therefore it cannot

    be driver related. At least on Linux I wrote a script to reinitilialize adapter every time it disconnects. But that can hardly be called a solution.

    Unfortunately the adapter is a built-in in a laptop, so the only way is an external USB adapter (hate it!).

     

    The problem some times gets even worse since it occationally confuses the AP router which then resets all ports. Very nice!

     

    If only Intel would admit that this adapter is defunct (or provide working firmware if possible). Then we could all stop wasting our time....

     

    regards

    /Peter B.

  • 10. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    I have little doubt that this is an adapter issue, but what's puzzling is that the adaptor worked perfectly for over a year before starting to malfunction. The problem seems to be that the adaptor disconnects when it drops the signal, and is unrecognized until the computer is restarted .. sometimes requirng multiple restarts. Also curious is that this adapter performed flawlessly for several hours at a remote location, and yet all other laptops and wireless devices work perfectly on the hub that this unit fails on repeatedly at home. All of this leads me to believe it's a flaw in the unit combined with situational circumstances.

     

    I did order a USB adapter .. but if necessary, how difficult would it be to replace the onboard adapter with something else? It's in a Lenovo X200. Isn't it just a matter of accessing the old one and hooking the new one up?

  • 11. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    I have used this in my old Dell Studio 1737 without issues. I had Vista 32-bit/64-bit and Windows 7 64-bit installed and it worked with no problems. Here are My Intel WiFi 5100 AGN Connectivity Settings

     

    When I install it on Windows 7, for the initial setup, I used the Vista 64-bit drivers from my manufacturers website and installed the drivers in the Vista SP2 Compatibility mode I later updated the drivers at Intel® Driver Update Utility for Intel® wireless adapters I was helping someone else with an issue and I then tried Installing My Wi-Fi Technology

     

    My wireless router was using these  Recommended Wireless Router Settings, I use channel 11. Having the router of auto channel can pose problems with connecting, as well as the 2.4gh cordelss phones.

     

     

    Rick

  • 12. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    - hi again,

     

    I think you are right. There has to be an obscure set of circumstances to trigger the problems. My pc also used to more stable.

    For Windows 7 this can be explained by certain "important" updates. It has been suggested that problems are related to

    "Microsoft Virtual WiFi Miniport". This is not a bad idea. Microsoft expect all adapters (even old ones!) to comply with their new

    "standard". This cannot always be the case. I have experimented with this but not really achieved convincing results.

    It does not explain why I have the same problems on Linux (Ubuntu Lucid).

     

    Only thing that changed in my network is that more clients were added over time. Because of this I upgraded AP's firmware (D-link) to the latest

    version but to no avail.

     

    I now use a D-link DWA-140 USB adapter I had "left-over" and it works flawlessly.

    I dare not try to disassemble my ACER laptop :-) Not sure what to replace adapter with anyway.

     

    regards

    /peter b.

  • 13. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    Yeah, I too purchased a Medialink USB wifi adapter and it works flawlessly, but I'd much rather have my onboard 5100 agn perational. It doesn't make sense that these problems wouldn't present out of the box if it wasn't a situational issue. I noticed that the Intel adapter worked flawlessly for several hours at another location last week. But the issue can't be soley in my wireless router because every other computer, hand held device etc works perfectly and as I said, so does my USB plug-in.

     

    I can pinpoint the day when this started happening a few months back. Maybe if there's some way to check the history of installed updates I can then track down which might have caused the 5100 to enter this mode of frequent disconnection. If all it did was disconnect that would be one thing, but the fact that the system fails to identify the device unless a restart is performed is particularly annoying. And sometimes it requires several restarts.

     

    It's frustrating when an issue is so widespread yet not acknowledged, addressed or fixed by the manufacturer. If it's a physical problem with the adapter due to over-heating with time, I'd be OK with that too and just replace the thing. But it's kind of a delicate operation on a laptop and it would good to have some definitive answer from Intel either way. It definitely isn't specific to any one brand of computer.

  • 14. Re: Intel WiFi Link 5100 AGN problem - disconnecting
    Currently Being Moderated

    Hello

     

     

    I am having the same problems with my 5100 AGN WiFi card. I see that it disconnects when 802.11 n is enabled on my router. If enable only 802.11 a/b/g I do not have disconnections. The problem probably is that 5100 AGN supports 802.11 Draft N and not the final protocol of 802.11 n. with my older router I did not have any problems.

     

     

     

     

    Regards

    Kostas

1 2 3 4 Previous Next

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points