7 Replies Latest reply: Dec 27, 2012 11:48 PM by Colin RSS

S5520HC Bios bug, Virtualization and AES-NI

neominky Community Member
Currently Being Moderated

sorry bad English

 

I bought S5520HC board and XEON E5620 CPU.

I guess, I found a BIOS bug.

 

If VT Enabled on BIOS but it's turn off VT-x, AES.
If VT Disabled on BIOS but it's turn on VT-x, AES.  Yes, working fine.

 

What happen?
I use CPU-Z and Sandra for check.

 

I tried Clear CMOS, reload default and update lastest BIOS, but no effect all.

And,
In Technical Product Specification (http://download.intel.com/support/motherboards/server/s5520hc/sb/e39529013_s5520hc_s5500hcv_s5520hct_tps_r1_9.pdf)
---
3.15 Intel® Virtualization Technology
Intel® Virtualization Technology is designed to support multiple software environments sharing
the same hardware resources. Each software environment may consist of an operating system
and applications. You can enable or disable the Intel® Virtualization Technology in the BIOS
Setup. The default behavior is disabled.
---

It's wrong, Enabled by default on BIOS. but not working, it's disabled.

I need HotFix.

  • 1. Re: S5520HC Bios bug, Virtualization and AES-NI
    edwardzh Community Member
    Currently Being Moderated

    What is your BIOS version?

     

    One reminder, after you change VT setting in BIOS, you may need to turn off the server completely, unplug the AC power cord, wait for 30 seconds and then turn it back on to make it work properly.

  • 2. Re: S5520HC Bios bug, Virtualization and AES-NI
    neominky Community Member
    Currently Being Moderated

    Thanks reply.

     

    BIOS version is 54

    Sure I know 'unplug code rule'

     

    I guess, it's a small 'displaying' bug .

    Reseller confirmed another S5520HC board has same problem.

    But I have no way directly contact local Korea Intel A/S center.  ARS saying about ths forum.

     

    I hope, Intel confirmation this bug, and make hotfix ASAP

  • 3. Re: S5520HC Bios bug, Virtualization and AES-NI
    edwardzh Community Member
    Currently Being Moderated

    I've done some tests today and below are my findings:

     

    1. You're right that VT is now enabled by default in BIOS. I guess it's changed in recent BIOS updates, and thus different from what's documented in TPS.

     

    2. CPU-Z may not be the right tool to tell you whether your system has VT enabled or not - it only tells you the CPU capability, and it displays VT-x no matter VT is enabled in BIOS or not. (When Hyper-V role is not added in Windows)

     

    3. Once Hyper-V role is added, and VT is enabled in BIOS, CPU-Z doesn't show VT-x. The reason is explained here, and Virtual Machines in Hyper-V can run well, indicating VT is actually working.

     

    4. With Hyper-V role added, and VT disabled in BIOS, CPU-Z shows VT-x, because Hypervisor is not running, and if you attempt to run any Virtual Machines in Hyper-V you'll get an error saying VT needs to be enabled in BIOS.

     

    So it's not a BIOS bug.

  • 4. Re: S5520HC Bios bug, Virtualization and AES-NI
    neominky Community Member
    Currently Being Moderated

    Thank you,I got answer.

     

    But I want to know one more.

    Why I can't use AES-NI? (when Hyper-V role is added)
    Is Microsoft's problem?

     

    I tested this sample : http://software.intel.com/en-us/articles/download-the-intel-aesni-sample-library/

    This code is not work.
    If I remove "check_for_aes_instructions()" codes, works fine.  (attached a image)
    How to check AES-NI over hypervisor?

  • 5. Re: S5520HC Bios bug, Virtualization and AES-NI
    edwardzh Community Member
    Currently Being Moderated

    I'm not 100% sure, but I guess it's the same reason - AES-NI is not available in a virtualized environment. Remember that "after installing the Hyper-V role, the Root OS (or the parent partition) which holds the Hyper-V role is also seen as a virtual machine"

  • 6. Re: S5520HC Bios bug, Virtualization and AES-NI
    neominky Community Member
    Currently Being Moderated

    Thank you very much

  • 7. Re: S5520HC Bios bug, Virtualization and AES-NI
    Colin Community Member
    Currently Being Moderated

    I can't get E5620 on S5520HC with aes flag whether VT is enabled or not.

    I have latest BIOS and Fedora system installed.

    Any idea?

     

    BIOS Information

            Vendor: Intel Corp.

            Version: S5500.86B.01.00.0063.092120121436

            Release Date: 09/21/2012

     

     

    cat /proc/cpuinfo

    processor       : 15

    vendor_id       : GenuineIntel

    cpu family      : 6

    model           : 44

    model name      : Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz

    stepping        : 2

    microcode       : 0x15

    flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 popcnt lahf_lm ida arat epb dtherm tpr_shadow vnmi flexpriority ept vpid

    $uname -r

    3.6.10-2.fc17.x86_64

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points