4 Replies Latest reply: Nov 4, 2010 9:06 AM by alexcuervo RSS

DP35DP RAM and PCI Video Conflicts

alexcuervo Community Member
Currently Being Moderated

I have system with a DP35DP with the latest bios 0572 and 2GB of ram. It has three displays working fine. The displays are driven by an PCI-e 9600GT Nvidia (2 monitors) on PCI1:0:0 and a PCI 8400gs Nvidia running the third display on PCI 8:0:0

I rencently upgraded  to 8GB of ram and the displays stoped working. I know the RAM is and the video cards are OK because:

 

1) 2GB + 8400GS = Works

2) 2GB + 9600GT = Works

3) 2GB + 8400GS + 9600GT = WORKS

4) 8GB + 8400GS = Works

5) 8GB + 9600GS = Works

But

6) 4GB + 8400GS + 9600GT = DOES NOT WORK

7) 8GB + 8400GS + 9600GT = DOES NOT WORK

 

So basically all combinations work execpt 6 and 7. Some how with 4GB  or more none of the video cards gets initialized on the PCI bus.

Any Ideas?

Relevant information:

After I put the 8GB the syslog started showing these

pci 0000:01:00.0: BAR 6: can't allocate mem resource [0xe0000000-0xdfffffff]

pci 0000:08:00.0: BAR 6: can't allocate mem resource [0xf0000000-0xefffffff]

 

nvidia: probe of 0000:01:00.0 failed with error -1

nvidia: probe of 0000:08:00.0 failed with error -1

heci: Failed to get pci regions


NVRM: The NVIDIA probe routine failed for 2 device(s).
NVRM: None of the NVIDIA graphics adapters were initialized!

EDIT: Could all this be related to http://tjworld.net/wiki/Linux/Bug/PciAllocationAlgorithm

 

Message was edited by: alexcuervo

More Like This

  • Retrieving data ...