Troubleshooting Intel® System Studio for Microcontrollers issues on Windows

Version 5

     

     

    OpenOCD fails to connect to the Board after Installation

     

    The below error when trying to Update the Microcontroller ROM after ISSM installation indicates there is no connection to the board. The most likely cause is a problem with the JTAG Driver installation.

     

    Check that the Board is correctly displayed in the Device Manager. The installer should automatically install the correct JTAG driver for your board if it is connected during setup.

    If you didn’t connect your board before install or if you change to a new board after install you may need to manually install the driver.

     

     

    On some systems the install may fail due to existing drivers with the same identifiers (VID&PID). This is often the case where Windows has automatically installed drivers from FTDI either from Windows Update or from users installing the FTDI package.

    These drivers assume the device is to be used in serial mode where OpenOCD requires them to be in JTAG (WinUSB) mode.

     

    Follow the steps below to manually install the JTAG Driver :

     

    JTAG Driver Manual Installation Steps:

     

    a. Connect your board (micro USB) to your host machine (USB) and run the driver installer to set up the Microsoft* WinUSB driver for JTAG:

     

              C:\IntelSWTools\ISSM_2016.y.xxx\tools\debugger\driver\install.bat

             

              This will attempt to install the correct drivers for the debugger device.

     

    b. If OpenOCD can still not find the device, removal of existing drivers is required:

     

              i. Open Device Manager (WIN + X).

              ii. Locate the driver either within the “Universal Serial Bus controllers” group, “USB Serial Converter”, “USB Serial Converter A” or “USB Serial Converter B”.

              iii. Right click on the device and select Uninstall. Make sure to tick the “Delete the driver software for this device”. Replug the device.

              iv. Repeat this process until Windows recognizes the device as Unknown, at which point run the driver “install.bat” shown in step “a”.

              v. You should now see the device installed as “OpenOCD JTAG”

     

    c. If OpenOCD fails to detect the device even with the “OpenOCD JTAG” device visible in the device manager here are some troubleshooting steps you can try:

     

              i. Re-plug your target/debugger.

              ii. Run the install.bat described in step “a”. (Whilst device is connected)

              iii. Remove existing FTDI drivers as described in step “b”.

              iv. Reboot your machine

     

              Warning: These steps may interfere with other FTDI devices in use.

     

    Cannot Load or Build QMSI Example Applications in Eclipse IDE

    There can be a few reasons that the Example Applications may not build in Eclipse IDE - 2 of the most common are outlined below :

     

    1. ISSM was not started correctly.

     

         ISSM must be launched using  the  C:\IntelSWTools\ISSM_2016.y.xxx\iss_mcu_launcher.bat.

     

         If  you slected 'Pin this program to taskbar' while ISSM was running - the taskbar shortcut will not start ISSM correctly the next time you start  it up - It will start Eclipse without the necessary ISSM Environment Variables configured.

         During installation you will be aked if  you want to created a Desktop Shortcut - This shorcut will point to the correct .bat file. You can pin this to the taskbar if required.

     

     

    2. There are conflicting applications in your Windows PATH

     

        Any Cygwin or MinGW or similar UNIX-like environments in your System PATH environment may cause conflicts when building example applications

     

          Update the PATH settings at the end of the  C:/IntelSWTools/ISSM_2016.1.067/issm_env.bat to :

     

         ::

         :: Extend PATH with ISSM tools

         ::

         set PATH=C:\WINDOWS\System32\Wbem

         set PATH=%ISSM_UTILS_ROOT%;%ISSM_TOOLCHAIN_BIN%/;%ISSM_TOOLCHAIN_UTILS%;%ISSM_TOOLS_ROOT%/python;%PATH%

     

         Restart ISSM

     

     

    When Updating the Microcontroller ROM the 'Update' button remains greyed out and 'ROM Path' is empty.

     

    The most likely issue here is that  ISSM was not started correctly. ISSM must be launched using  the  C:\IntelSWTools\ISSM_2016.y.xxx\iss_mcu_launcher.bat.

    The Start Menu and Desktop Shorcuts will point to the correct .bat file.

     

    The other possible senario is that the ROM file has been deleted/moved from the default path e.g. the default directory for the QMSI 1.1 ROM for the D2000 is C:\IntelSWTools\ISSM_2016.y.xxx\firmware\bsp\1.1\soc\quark_d2000\rom