Upon testing Intel's new AMT Reflector tool I was greeted with a cryptic error message. When attempting to connect to the server, the client failed with error code -4 (The AMT device is unprovisioned or provisioned in Enterprise Mode). But first, my setup. My test configuration consists of two Intel whitebox machines, each with Windows XP SP2 installed, AMT configured and provisioned in small-medium business mode running AMT 3.0. The entire network is isolated (no outside internet) and is administered by a DHCP server running on Windows Server 2003.



The left machine (hostname: gbit-vpro-01) is running the server application and the right machine (hostname: gbit-vpro-02) is attempting to run the client application (although both machines should be able to run either component). The right machine is provisioned in SMB mode, which is confirmed by accessing it through SyAM Provisioning Server







This is further confirmed by remoting into the client machine's BIOS:













No Luck

The listen and communication ports have been configured correctly. The server app is started, and begins listening. When I attempt to start the client application, I receive a notification:



I'm at a loss, because all other signs indicate that I am correctly provisioned in SMB mode. I tried unprovisioning and resetting to factory defaults and then setting up the ME from scratch.


And now it gets stranger...

When I attempt to run the reflector client on the same machine as the server (after reconfiguring the ports for localhost listening), I get some strange behavior.


  1. The server is run, configured, and started

  2. The client program is started. At this point, there is no response (no windows opens, no error, etc). But when the server is stopped, the same error message as before appears (and if the client was started multiple times while the server was running, the messages will stack.)

  3. Lastly, the server reports that multiple connections have been made. It records hundreds of in-packets, but 0 out-pakcets.

I've provided all the relevant information I can think of that would affect this usage situation. If anyone can think of a reason why this would not work in our specific network, please let me know. Overall, I'm interested by the potential of this tool, but disappointed by its non-functionality.