• DP55SB stuck at post with R9 280x

    My pc wont boot anymore after updating nvidia gt 210 to R9 280X gpu. I have tried to downgrade and upgrade bios revisions but neither of those help, I started with the newest bios revision. Motherboards leds are showi...
    Vigoor
    last modified by Vigoor
  • DH61CR board & Windows Update KB4093118, KB408875, KB4088881

    Good afternoon everybody, I've been playing a game a "whack-a-mole" for too long now. My public school has several refurbished desktop computers with the Intel D61CR motherboard and every security update since March (...
    mr_anthony
    last modified by mr_anthony
  • Dell XPS 8500 desktop w/H77 chipset - RST Uninstall?

    I'm new here and I hope this is the right forum for this question. I have 5-6 year old Dell XPS 8500 desktop PC, Win7 Home Premium, Core i7-3440 @ 3.40Ghz, 12Gb RAM, H77 chipset board, 32Gb SSD cache drive that is pai...
    Tremolux
    last modified by Tremolux
  • Z77 Chipset BIOS Questions & NVMe

    I am looking to use a NVMe as a boot device on my motherboard, and I have a few questions.   1. Was the Z77 BIOS written by AMI? 2.  I have read elsewhere on this forum that Intel Desktop boards do not sup...
    ECD2
    last modified by ECD2
  • Intel DX79SI Mainboard Ethernet Error

    I have an Intel DX79SI model motherboard. I can find out which operating system this motherboard is installed on. He does not see Ethernet. Even though there is 2 Ethernet on the motherboard, Windows only sees one: In...
    AdamSandoval
    last modified by AdamSandoval
  • questions on memory for DH67BL

    1) Intel documents state that blue memory slots should be used first. Is it just more efficient or will using only black slots not work?   2) Older equipment is getting hard to find. So what happens if I have a ...
    marma-lade
    last modified by marma-lade
  • What is the right heatsink for the DQ77CP m'board

    This board has raised circuits close by 2 sides of the chip housing (or whatever it's called?) and therefore no standard round heatsink/fans are workable. Where can I find such a heatsink?
    binkyd
    last modified by binkyd
  • Right Click on Desktop causes Delay because of igfxsrvc.exe

    Hello,   the process igfxsrvc.exe is apparently part of the Intel Common User Interface and in use/started when I perform a right click on the desktop which causes an annoying delay of about 2 seconds while open...
    Leviathan
    last modified by Leviathan
  • DH77KC Chassis intrusion + bios password

    Good morning, i have the m/b in the title. I'm getting this extremely annoying problem that is keeping me from using my pc. The BIOS recognizes a chassis intrusion, even when there is no sensor connected to his pin h...
    Fabio_Ficarella
    last modified by Fabio_Ficarella
  • my motherboard is dh61ww...can i use zotac gt710 2gb ddr3 graphic card.........my processor is intel pentium g2020

    can use zotac gt710 2gb graphic card in my intel dh61ww motherboard...my processor is intel pendium g2020
    donkakkassery
    last modified by donkakkassery
  • erro display led 1c placa mãe DP67BG

    boa tarde galera estou com uma placa mae intel dp67bg a mesma se encontra com o erro 1c no display led e não incia apenas liga e desliga alguma solução para meu problema ?
    uarlei
    last modified by uarlei
  • Possible to boot off a PCIe SATA controller on DH67?

    I'm sure the answer is no, but has anyone here successfully used an add-on SATA card, e.g. SYBA SD-PEX40099, to serve as a boot controller?
    paramountain
    last modified by paramountain
  • Intel DQ77MK Board after updating bios usb port are down, and no video signal

    Okay the bios on the board were the original factory (from 2012,)  and I needed to update it to fix some issues,  I downloaded and installed successfully "MKQ7710H.86A", but after the reboot the usb ports fa...
    jlpotocki
    last modified by jlpotocki
  • DZ77RE-75K BIOS Update - SPECTRE & MELTDOWN

    I understand DZ77RE-75K desktop board support has been discontinued and the last BIOS 0066 available for this platform is of May 2013 but given the recent security revelations re "Spectre & Meltdown" will INTEL ...
    Win7ine
    last modified by Win7ine
  • How to enable VT-d on Intel DX79TO BIOS?

    I'm running an E5-2670v1 on an Intel DX79TO motherboard with the latest BIOS version (0650). I cannot find how to enable VT-d in the BIOS. I did find and enabled VT but VT-d (IOMMU) is nowhere to be found in the BIOS...
    rudyazo
    last modified by rudyazo
  • ON DX58OG stuck at Back2BIOS button screen

    Hi, My Intel DX58OG is stuck in Back to Bios screen. I tried everything like flashing BIOS in recovery mode, removing CMOS etc. Then due to frustration I physically removed B2B button but it still shows B2B button is...
    yadavsan101
    last modified by yadavsan101
  • DX79SI motherboard,

    I recently upgraded my main drive on my pc. When I was in the BIOS, setting the new drive as the boot drive. The settings was saved as IDE, instead of AHCI(SP). Now my pc does not want to boot, I have even tried to re...
    cjholland74
    last modified by cjholland74
  • DX79SI Motherboard Mouse Keyboard and Display Issue

    Have a DX79si motherboard was working fine till the keyboard and mouse and the display stopped working any one had the same problem? If so is it fixed?
    DanZi
    last modified by DanZi
  • Unusual issue with onboard USB

    Hello,   Using an Intel motherboard that simply identifies itself to auditing software as "Intel Chiefriver". (Single board PC used in an industrial enclosure) The audit software identifies the following chips/...
    mickyj
    last modified by mickyj
  • Intel(R) MEI driver STATUS_DEVICE_POWER_FAILURE

      Win 10 Pro 64-bit (v 1704) is having difficulties with the driver "Intel(R) Management Engine Interface".   What do I need to do?   Could it be a hardware problem (a chip gone bad?)   I am ...
    MeSo2
    last modified by MeSo2